Τώρα είναι Τρί 18 Φεβ 2020 04:16 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 6 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΕΥΡΕΣΗ ΠΑΡΑΓΩΓΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 19 Νοέμ 2008 02:30 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 19 Νοέμ 2008 02:18 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
!ΠΡΟΓΡΑΜΜΑ ΤΟ ΟΠΟΙΟ ΥΠΟΛΟΓΙΖΕΙ ΤΗΝ ΠΑΡΑΓΩΓΟ ΠΟΛΥΩΝΙΜΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ ΜΕ ΘΕΤΙΚΟΥΣ ΕΚΘΕΤΕΣ<=100!
ΠΡΟΓΡΑΜΜΑ ΠΑΡΑΓΩΓΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , Ν , Β
  ΠΡΑΓΜΑΤΙΚΕΣ: Α[101] , Γ[101]
  ΛΟΓΙΚΕΣ: ΣΤΑΘΕΡΟΤΗΤΑ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ ΘΕΤΙΚΟ ΑΚΕΡΑΙΟ Ν ΜΕΧΡΙ 100 Ο ΟΠΟΙΟΣ ΘΑ ΑΝΤΙΠΡΟΣΩΠΕΥΕΙ'
  ΓΡΑΨΕ 'ΤΟΝ ΜΕΓΙΣΤΟΒΑΘΜΙΟ ΜΙΑΣ ΠΟΛΥΩΝΙΜΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ'
  ΔΙΑΒΑΣΕ Ν
  ΣΤΑΘΕΡΟΤΗΤΑ <-- ΨΕΥΔΗΣ
  ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
    ΑΝ Ν = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ΣΥΝΑΡΤΗΣΗ ΘΑ ΕΙΝΑΙ ΣΤΑΘΕΡΗ , ΟΠΟΤΕ Η ΠΑΡΑΓΩΓΟΣ ΕΙΝΑΙ f΄(x)=0'
      ΣΤΑΘΕΡΟΤΗΤΑ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ_ΑΝ Ι = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΩΡΑ ΔΩΣΕ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ'
      ΔΙΑΒΑΣΕ Α[Ι+1]
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΤΩΡΑ ΔΩΣΕ ΤΟΝ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ^'
      ΔΙΑΒΑΣΕ Α[Ι+1]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΣΤΑΘΕΡΟΤΗΤΑ = ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'ΙΔΟΥ Η ΣΥΝΑΡΤΗΣΗ f(x)='
    ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
      ΑΝ Α[Ι+1] = 0 ΤΟΤΕ
        ΓΡΑΨΕ_'+0'
      ΑΛΛΙΩΣ_ΑΝ Α[Ι+1]=1 ΚΑΙ Ι=1 ΤΟΤΕ
        ΓΡΑΨΕ_'+Χ'
      ΑΛΛΙΩΣ_ΑΝ Α[Ι+1]=1 ΚΑΙ Ι = Ν ΤΟΤΕ
        ΓΡΑΨΕ_'(Χ^',Ι,')'
      ΑΛΛΙΩΣ_ΑΝ Α[Ι+1]=1 ΤΟΤΕ
        ΓΡΑΨΕ_'+(Χ^',Ι,')'
      ΑΛΛΙΩΣ_ΑΝ Α[Ι+1] = 0 ΚΑΙ Ι = 1 ΤΟΤΕ
        ΓΡΑΨΕ_'+0'
      ΑΛΛΙΩΣ_ΑΝ Ι = 1 ΤΟΤΕ
        ΓΡΑΨΕ_'+('[Ι+1],'Χ',')'
      ΑΛΛΙΩΣ_ΑΝ Ι = Ν ΤΟΤΕ
        ΓΡΑΨΕ_'('[Ι+1],'Χ^',Ι,')'
      ΑΛΛΙΩΣ_ΑΝ Ι = 0 ΤΟΤΕ
        ΓΡΑΨΕ_'+('[Ι+1],')'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ_'+('[Ι+1],'Χ^',Ι,')'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Β <-- 0
    ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
      Γ[Ι+1] <-- Α[Ι+1]*(Ν+Β)
      Β <-- Β-1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'ΙΔΟΥ Η ΠΑΡΑΓΩΓΟΣ f΄(x)='
    ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
      ΑΝ Ι-1>=0 ΤΟΤΕ
        ΑΝ Γ[Ι+1] = 0 ΤΟΤΕ
          ΓΡΑΨΕ_'+0'
        ΑΛΛΙΩΣ_ΑΝ Ι = Ν ΚΑΙ Ι = 2 ΤΟΤΕ
          ΓΡΑΨΕ_ Γ[Ι+1],'Χ'
        ΑΛΛΙΩΣ_ΑΝ Ι = Ν ΤΟΤΕ
          ΓΡΑΨΕ_ Γ[Ι+1],'Χ^'-1
        ΑΛΛΙΩΣ_ΑΝ Ι-1 =1 ΤΟΤΕ
          ΓΡΑΨΕ_'+'[Ι+1],'Χ'
        ΑΛΛΙΩΣ_ΑΝ Ι-1 = 0 ΤΟΤΕ
          ΓΡΑΨΕ_'+'[Ι+1]
        ΑΛΛΙΩΣ
          ΓΡΑΨΕ_'+'[Ι+1],'Χ^'-1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΕΛΠΙΖΩ ΠΩΣ ΤΟ ΠΡΟΓΡΑΜΜΑ ΕΙΝΑΙ ΣΩΣΤΟ ,
ΕΠΕΙΔΗ ΕΙΜΑΙ ΜΑΘΗΤΗΣ ΚΑΙ ΣΤΟΧΕΥΩ ΣΤΟ ΚΑΛΥΤΕΡΟ ΔΕΚΤΕΣ ΟΛΕΣ ΟΙ ΠΑΡΑΤΗΡΗΣΕΙΣ ΚΑΙ ΟΙ ΔΙΟΡΘΩΣΕΙΣ :wink:


Τελευταία επεξεργασία από Yuris και Σάβ 17 Ιαν 2009 02:10 am, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΥΡΕΣΗ ΠΑΡΑΓΩΓΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 20 Νοέμ 2008 10:26 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Και να πως είναι το διάγραμμα ροής που δημιουργεί η έκδοση 9.2:


Συνημμένα:
paragwgos.png
paragwgos.png [ 269.71 KiB | 6167 προβολές ]
Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΥΡΕΣΗ ΠΑΡΑΓΩΓΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Μαρ 2009 06:52 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Ωραίος. Η μονη βελτίωση που σκέφτομαι ειναι σε περίπτωση μηδενικού συνετεστή να μην τον εμφανίζει καν(να μην λεει δηλαδη 3χ^2 + 0χ + 2, να λεει 3χ^2+2)

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΥΡΕΣΗ ΠΑΡΑΓΩΓΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Μαρ 2009 09:58 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΕΥΧΑΡΙΣΤΩ ΠΟΛΥ , ΚΑΠΟΙΑ ΣΤΙΓΜΗ ΠΟΥ ΘΑ ΕΧΩ ΠΕΡΙΣΣΟΤΕΡΟ ΧΡΟΝΟ ΘΑ ΤΟ ΦΤΙΑΞΩ.

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΥΡΕΣΗ ΠΑΡΑΓΩΓΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 29 Μάιος 2009 08:04 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
Επιτέλους :o ...... πάνε οι πανελλήνιες και έχω ξανά χρόνο να ασχοληθώ με προγραμματισμό.!!! 8)
Ορίστε μια ανανεωμένη έκδοση του προγράμματος , έκανα ένα σωρό δοκιμές και πιστεύω ότι λειτουργεί σωστά για οποιεσδήποτε τιμές . :mrgreen:
Syntax: [ Download ] [ Hide ]
!ΠΡΟΓΡΑΜΜΑ ΤΟ ΟΠΟΙΟ ΥΠΟΛΟΓΙΖΕΙ ΤΗΝ ΠΑΡΑΓΩΓΟ ΠΟΛΥΩΝΙΜΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ ΜΕ ΘΕΤΙΚΟΥΣ ΕΚΘΕΤΕΣ!
ΠΡΟΓΡΑΜΜΑ ΠΑΡΑΓΩΓΟΣ
ΣΤΑΘΕΡΕΣ
  ΜΕΓ = 100
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , Ν , Β , ΕΚ , Α[ΜΕΓ+1] , Γ[ΜΕΓ+1] , Π , Τ
  ΛΟΓΙΚΕΣ: ΣΤΑΘΕΡΟΤΗΤΑ , Σ1
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ ΘΕΤΙΚΟ ΑΚΕΡΑΙΟ Ν ΜΕΧΡΙ ',ΜΕΓ,' Ο ΟΠΟΙΟΣ ΘΑ ΑΝΤΙΠΡΟΣΩΠΕΥΕΙ'
  ΓΡΑΨΕ 'ΤΟΝ ΜΕΓΙΣΤΟΒΑΘΜΙΟ ΜΙΑΣ ΠΟΛΥΩΝΙΜΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ'
  Τ <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Τ <-- Τ + 1
    ΑΝ Τ <> 1 ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΔΩΣΕΣ ΜΕΓΙΣΤΟΒΑΘΜΙΟ ΑΝΩ ΤΟΥ',ΜΕΓ,'ΠΑΡΑΚΑΛΩ ΔΩΣΕ ΑΡΙΘΜΟ ΜΙΚΡΟΤΕΡΟ ΤΟΥ.'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Τ>3 ΤΟΤΕ
      ΓΡΑΨΕ 'ΑΝ ΕΠΙΜΕΝΕΙΣ ΝΑ ΔΩΣΕΙΣ ΜΕΓΙΣΤΟΒΑΘΜΙΟ ΑΝΩ ΤΟΥ',ΜΕΓ,'ΑΠΛΑ ΑΛΛΑΞΕ ΤΗΝ ΜΕΤΑΒΛΗΤΗ ΜΕΓ ΚΑΘΩΣ ΚΑΙ ΤΙΣ ΔΙΑΣΤΑΣΕΙΣ ΤΩΝ ΠΙΝΑΚΩΝ Α[] , Γ[]'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ Ν
  ΜΕΧΡΙΣ_ΟΤΟΥ Ν <= ΜΕΓ
  ΣΤΑΘΕΡΟΤΗΤΑ <-- ΨΕΥΔΗΣ
  ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
    ΑΝ Ν = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ΣΥΝΑΡΤΗΣΗ ΘΑ ΕΙΝΑΙ ΣΤΑΘΕΡΗ , ΟΠΟΤΕ Η ΠΑΡΑΓΩΓΟΣ ΕΙΝΑΙ f΄(x)=0'
      ΣΤΑΘΕΡΟΤΗΤΑ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ_ΑΝ Ι =1 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΩΡΑ ΔΩΣΕ ΤΟΝ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
      ΔΙΑΒΑΣΕ Α[Ι+1]
    ΑΛΛΙΩΣ_ΑΝ Ι = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΩΡΑ ΔΩΣΕ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ'
      ΔΙΑΒΑΣΕ Α[Ι+1]
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΤΩΡΑ ΔΩΣΕ ΤΟΝ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ^'
      ΔΙΑΒΑΣΕ Α[Ι+1]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΣΤΑΘΕΡΟΤΗΤΑ = ΨΕΥΔΗΣ ΤΟΤΕ
    Σ1 <-- ΨΕΥΔΗΣ
    Π <-- 0
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν+1
      Π <-- Π + Α[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Π = 0 ΤΟΤΕ
      Σ1 <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Σ1 = ΨΕΥΔΗΣ ΤΟΤΕ
      Ι <-- Ν
      ΟΣΟ Α[Ι+1] = 0 ΕΠΑΝΑΛΑΒΕ
        Ι <-- Ι-1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΕΚ <-- Ι
      ΓΡΑΨΕ 'ΙΔΟΥ Η ΣΥΝΑΡΤΗΣΗ f(x)='
      ΓΙΑ Ι ΑΠΟ ΕΚ ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
        ΑΝ Ι=ΕΚ ΚΑΙ ΠΡΟΣΗΜΟ(Α[Ι+1])='+' ΤΟΤΕ
          ΑΝ Α[Ι+1] = 1 ΤΟΤΕ
            ΓΡΑΨΕ_ 'Χ^'
          ΑΛΛΙΩΣ
            ΓΡΑΨΕ_ Α[Ι+1],'Χ^'
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ_ΑΝ Ι=ΕΚ ΚΑΙ ΠΡΟΣΗΜΟ(Α[Ι+1])='-' ΤΟΤΕ
          ΑΝ Α[Ι+1] = 1 ΤΟΤΕ
            ΓΡΑΨΕ_ '-','Χ^'
          ΑΛΛΙΩΣ
            ΓΡΑΨΕ_ '-',Α_Τ(Α[Ι+1]),'Χ^'
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ_ΑΝ Α_Τ(Α[Ι+1]) = 1 ΤΟΤΕ
          ΑΝ Ι = 1 ΤΟΤΕ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Α[2]),'Χ'
          ΑΛΛΙΩΣ_ΑΝ Ι = 0 ΤΟΤΕ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Α[1]),'1'
          ΑΛΛΙΩΣ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Α[Ι+1]),'Χ^'
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ_ΑΝ Α[Ι+1] = 0 ΤΟΤΕ

        ΑΛΛΙΩΣ
          ΑΝ Ι = 1 ΤΟΤΕ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Α[Ι+1]),Α_Τ(Α[Ι+1]),'Χ'
          ΑΛΛΙΩΣ_ΑΝ Ι = 0 ΤΟΤΕ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Α[Ι+1]),Α_Τ(Α[Ι+1])
          ΑΛΛΙΩΣ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Α[Ι+1]),Α_Τ(Α[Ι+1]),'Χ^'
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      Β <-- 0
      ΓΙΑ Ι ΑΠΟ Ν ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
        Γ[Ι+1] <-- Α[Ι+1]*(Ν+Β)
        Β <-- Β-1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ
      ΓΡΑΨΕ 'ΙΔΟΥ Η ΠΑΡΑΓΩΓΟΣ f΄(x)='
      ΓΙΑ Ι ΑΠΟ ΕΚ ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
        ΑΝ Ι=ΕΚ ΚΑΙ ΠΡΟΣΗΜΟ(Γ[Ι+1])='+' ΤΟΤΕ
          ΓΡΑΨΕ_ Γ[Ι+1],'Χ^'-1
        ΑΛΛΙΩΣ_ΑΝ Ι=ΕΚ ΚΑΙ ΠΡΟΣΗΜΟ(Γ[Ι+1])='-' ΤΟΤΕ
          ΓΡΑΨΕ_ '-',Α_Τ(Γ[Ι+1]),'Χ^'-1
        ΑΛΛΙΩΣ_ΑΝ Γ[Ι+1] = 0 ΤΟΤΕ

        ΑΛΛΙΩΣ
          ΑΝ Ι = 2 ΤΟΤΕ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Γ[Ι+1]),Α_Τ(Γ[Ι+1]),'Χ'
          ΑΛΛΙΩΣ_ΑΝ Ι = 1 ΤΟΤΕ
            ΓΡΑΨΕ ΠΡΟΣΗΜΟ(Γ[Ι+1]),Α_Τ(Γ[Ι+1])
          ΑΛΛΙΩΣ
            ΓΡΑΨΕ_ ΠΡΟΣΗΜΟ(Γ[Ι+1]),Α_Τ(Γ[Ι+1]),'Χ^'-1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΙΔΟΥ Η ΣΥΝΑΡΤΗΣΗ f(x)= 0'
      ΓΡΑΨΕ
      ΓΡΑΨΕ 'ΙΔΟΥ Η ΠΑΡΑΓΩΓΟΣ f΄(x)= 0'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



ΣΥΝΑΡΤΗΣΗ ΠΡΟΣΗΜΟ (Χ)  : ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ
ΑΡΧΗ
  ΑΝ Χ > 0 ΤΟΤΕ
    ΠΡΟΣΗΜΟ <-- '+'
  ΑΛΛΙΩΣ_ΑΝ Χ < 0 ΤΟΤΕ
    ΠΡΟΣΗΜΟ <-- '-'
  ΑΛΛΙΩΣ
    ΠΡΟΣΗΜΟ <-- '/'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Όπως πάντα δεκτές όλες οι παρατηρήσεις και οι διορθώσεις :roll:

Και κάντε κανένα σχόλιο ρε παιδιά...... :(

EDIT: Dark lord στις γραμμές εκείνες λαμβάνω υπόψη την περίπτωση που εμφανίζεται ο πρώτος αριθμός-συντελεστής , αν κάνω αυτό που λες δεν εμφανίζεται το επιθυμητό αποτέλεσμα . Ο πίνακας Γ χρησιμοποιείται για να αποθηκεύονται οι συντελεστές της παραγώγου , ξέρω ότι μπορούσε να παραλειφθεί αλλά προτιμώ να αποθηκεύονται .

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Τελευταία επεξεργασία από Sudavar{SP} και Παρ 13 Νοέμ 2009 07:34 pm, έχει επεξεργασθεί 2 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΥΡΕΣΗ ΠΑΡΑΓΩΓΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 30 Μάιος 2009 03:27 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Ωραίος, μπράβο...

Βελτιώσεις
1) Βαλε μια σταθερα μεταβλητη ΜΕΓ_ΒΑΘ = 100 σε περιπτωση που θες να αλλαξεις τον μεγιστο βαθμό να ειναι πιο ευκολο
2) καπου λες χοντρικά Αν προσιμο(χ) = '+' τοτε γραψε '+' αλλιως αν προσιμο(χ) = '-' γραψε '-', αυτο αντικατεστησε το με γραψε προσιμο(χ).(γραμμη 43 και 49)

Δεν βλέπω αλλη βελτίωση εκτος από να προσπαθήσεις να μειώσεις τον αριθμό μεταβλητών, αν γίνεται, αλλα δεν το εχω ψαξει...

edit : ο πινακας Γ δεν χρειάζεται γιατι μπορεί η παραγωγός να αποθηκευτει στον Α

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 6 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters