Τώρα είναι Τρί 18 Φεβ 2020 04:13 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Smoking Calculator
ΔημοσίευσηΔημοσιεύτηκε: Τρί 12 Φεβ 2008 11:35 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 26 Ιαν 2008 03:28 pm
Δημοσιεύσεις: 1
Είναι ένα απλό πρόγραμμα που έκανα για να μπορέσουν οι νέοι μαθητές που έρχονται σε επαφή με το μάθημα (ή και αυτοί που το βρίσκουν λίγο κινέζικο :) ) να κατανοήσουν την δομή του.


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Smoking_Calculator
!Ένα απλό πρόγραμμα που υπολογίζει σύμφωνα με τις επιλογές του χρήστη τον χαμένο χρόνο από την ζωή του λόγο του τσιγάρου,
!(εάν υποθέσουμε ότι ένα τσιγάρο είναι χάσιμο 5 λεπτών ζωής).
!Το πρόγραμμα εμφανίζει τον χαμένο χρόνο σε ώρες,λεπτά ή δευτερόλεπτα.
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΧΡΟΝΙΑ,ΤΣΙΓΑΡΑ[3],ΜΗΝΕΣ,ΜΕΡΕΣ ,Ι,Τ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΧΡΟΝΙΑ_Τ,ΜΗΝΕΣ_Τ,ΜΕΡΕΣ_Τ ,ΩΡΕΣ,ΛΕΠΤΑ,ΔΕΥΤΕΡΑ
  ΧΑΡΑΚΤΗΡΕΣ:ΕΠΙ ,ΝΗΟ

ΑΡΧΗ
  γράψε '*********************************************************************'
  γράψε '*********************************************************************'
  ΓΡΑΨΕ '*****ΚΑΛΟΣ ΟΡΙΣΑΤΕ ΣΤΟ "Smoking Calculator" v. 1.01 by Sarakinos*****'
  γράψε '*********************************************************************'
  γράψε '*********************************************************************'
  γράψε ''
  ΓΡΑΨΕ ''
  γράψε '*********************************************************************'
  ΓΡΑΨΕ '**********************ΕMAIL:bampis.s@gmail.com***********************'
  γράψε '*********************************************************************'
  ΝΗΟ <-- 'Υ'     !Μεταβλητή που χρησιμοποιήται για την επικύρωση της συνθήκης που ελένχεται στην γραμμή 136
  ΟΣΟ ΝΗΟ='Υ' ΕΠΑΝΑΛΑΒΕ

    γραψε''
    γράψε '*********************'
    γράψε '****Menu Επιλογών****'
    γράψε '*********************'
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ ''

    ΓΡΑΨΕ '1.ΧΡΟΝΙΑ'
    ΓΡΑΨΕ '2.ΜΗΝΕΣ'
    ΓΡΑΨΕ '3.ΜΕΡΕΣ'
    ΓΡΑΨΕ''

    ΓΡΑΨΕ 'ΕΠΙΛΟΓΗ:'


    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΕΠΙ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙ='1' Η ΕΠΙ='2' Η ΕΠΙ='3'
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ ''
    ΑΝ ΕΠΙ='1' ΤΟΤΕ
      ΓΡΑΨΕ 'ΠΟΣΑ ΧΡΟΝΙΑ ΚΑΠΝΙΖΕΙΣ;'
      ΓΡΑΨΕ 'ΧΡΟΝΙΑ:'
      ΔΙΑΒΑΣΕ ΧΡΟΝΙΑ
      ΓΡΑΨΕ 'ΠΟΣΑ ΤΣΙΓΑΡΑ ΚΑΠΝΙΖΕΙΣ ΠΕΡΙΠΟΥ ΤΗΝ ΗΜΕΡΑ;'
      ΓΡΑΨΕ 'ΤΣΙΓΑΡΑ:'
      ΔΙΑΒΑΣΕ ΤΣΙΓΑΡΑ[1]
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΠΕΡΙΜΕΝΕΤΕ...'
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ ΒΗΜΑ 1
        ΓΙΑ Τ ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ ΒΗΜΑ 1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      ΧΡΟΝΙΑ_Τ <-- (((5*ΤΣΙΓΑΡΑ[1])*30)*12)*ΧΡΟΝΙΑ
      ΓΡΑΨΕ 'ΕΧΕΤΕ ΧΑΣΕΙ ΤΟΝ ΠΑΡΑΚΑΤΩ ΧΡΟΝΟ ΑΠΟ ΤΗΝ ΖΩΗ ΣΑΣ:'
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΣΕ ΩΡΕΣ:'
      ΩΡΕΣ <-- ΧΡΟΝΙΑ_Τ/60
      ΓΡΑΨΕ ΩΡΕΣ

      ΓΡΑΨΕ 'ΣΕ ΛΕΠΤΑ:'

      ΓΡΑΨΕ ΧΡΟΝΙΑ_Τ
      ΓΡΑΨΕ 'ΣΕ ΔΕΥΤΕΡΟΛΕΠΤΑ:'
      ΔΕΥΤΕΡΑ <-- ΧΡΟΝΙΑ_Τ*60
      ΓΡΑΨΕ ΔΕΥΤΕΡΑ
    ΑΛΛΙΩΣ_ΑΝ ΕΠΙ='2' ΤΟΤΕ
      ΓΡΑΨΕ 'ΠΟΣΟΥΣ ΜΗΝΕΣ ΚΑΠΝΙΖΕΙΣ;'
      ΔΙΑΒΑΣΕ ΜΗΝΕΣ
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΠΟΣΑ ΤΣΙΓΑΡΑ ΚΑΠΝΙΖΕΙΣ ΠΕΡΙΠΟΥ ΤΗΝ ΗΜΕΡΑ;'
      ΔΙΑΒΑΣΕ ΤΣΙΓΑΡΑ[2]
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΠΕΡΙΜΕΝΕΤΕ...'
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ ΒΗΜΑ 1  !Τέχνασμα καθυστέρισης,για να δείξουμε ότι το πρόγραμμα υπολογίζει τα εισαγώμενα δεδομένα
        ΓΙΑ Τ ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ ΒΗΜΑ 1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΜΗΝΕΣ_Τ <-- ((5*ΤΣΙΓΑΡΑ[2])*30)*ΜΗΝΕΣ
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΕΧΕΤΕ ΧΑΣΕΙ ΤΟΝ ΠΑΡΑΚΑΤΩ ΧΡΟΝΟ ΑΠΟ ΤΗΝ ΖΩΗ ΣΑΣ:'
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΣΕ ΩΡΕΣ:'
      ΩΡΕΣ <-- ΜΗΝΕΣ_Τ/60
      ΓΡΑΨΕ ΩΡΕΣ

      ΓΡΑΨΕ 'ΣΕ ΛΕΠΤΑ:'
      ΓΡΑΨΕ ΜΗΝΕΣ_Τ
      ΓΡΑΨΕ 'ΣΕ ΔΕΥΤΕΡΟΛΕΠΤΑ:'
      ΔΕΥΤΕΡΑ <-- ΜΗΝΕΣ_Τ*60
      ΓΡΑΨΕ ΔΕΥΤΕΡΑ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΠΟΣΕΣ ΜΕΡΕΣ ΚΑΠΝΙΖΕΙΣ;'
      ΔΙΑΒΑΣΕ ΜΕΡΕΣ
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΠΟΣΑ ΤΣΙΓΑΡΑ ΚΑΠΝΙΖΕΙΣ ΠΕΡΙΠΟΥ ΤΗΝ ΗΜΕΡΑ;'
      ΔΙΑΒΑΣΕ ΤΣΙΓΑΡΑ[3]
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΠΕΡΙΜΕΝΕΤΕ...'
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ ΒΗΜΑ 1
        ΓΙΑ Τ ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ ΒΗΜΑ 1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΜΕΡΕΣ_Τ <-- (5*ΤΣΙΓΑΡΑ[3])*ΜΕΡΕΣ
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΕΧΕΤΕ ΧΑΣΕΙ ΤΟΝ ΠΑΡΑΚΑΤΩ ΧΡΟΝΟ ΑΠΟ ΤΗΝ ΖΩΗ ΣΑΣ:'
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ 'ΣΕ ΩΡΕΣ:'
      ΩΡΕΣ <-- ΜΕΡΕΣ_Τ/60
      ΓΡΑΨΕ ΩΡΕΣ

      ΓΡΑΨΕ 'ΣΕ ΛΕΠΤΑ:'
      ΓΡΑΨΕ ΜΕΡΕΣ_Τ
      ΓΡΑΨΕ 'ΣΕ ΔΕΥΤΕΡΟΛΕΠΤΑ:'
      ΔΕΥΤΕΡΑ <-- ΜΕΡΕΣ_Τ*60
      ΓΡΑΨΕ ΔΕΥΤΕΡΑ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ''
    ΓΡΑΨΕ''
    ΓΡΑΨΕ'ΘΕΛΕΤΕ ΝΑ ΕΠΑΝΑΛΑΒΕΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ; ( (Υ) ΓΙΑ ΝΑΙ , (Ν) ΓΙΑ ΟΧΙ)'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΝΗΟ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΝΗΟ='Υ' Η ΝΗΟ='Ν'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Smoking_Calculator
 


@Sarakinos@ ( 3o Γενικό Λύκειο Σερρών )
Made with Glossomatheia 9.0.8


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters