Τώρα είναι Σάβ 22 Φεβ 2020 03:41 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 20 Ιαν 2008 09:59 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 26 Δεκ 2004 01:29 pm
Δημοσιεύσεις: 2
Τοποθεσία: Αλεξανδρούπολη
Syntax: [ Download ] [ Hide ]
!Να γραφεί πρόγραμμα που να τοποθετεί τα περιεχόμενα ενός πίνακα Α[4] θέσεων
!στις περιττές θέσεις ενός πίνακα Γ[8] θέσεων και τα περιεχόμενα
!ενός πίνακα Β[4] θέσεων στις άρτιες θέσεις του πίνακα Γ[8].

ΠΡΟΓΡΑΜΜΑ Αρτιοι_και_Περιττοί_σε_εναν_Πίνακα
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,k,λ
  ΠΡΑΓΜΑΤΙΚΕΣ: Γ[8],a[4],b[4]
ΑΡΧΗ
  για i από 1 μέχρι 4
    Διάβασε a[i] , b[i]
  τέλος_επανάληψης

  k <-- 0
  λ <-- 1
  Για i από 1 μέχρι 4
    Γ[i+k] <-- a[i]
    k <-- k+1
    Γ[i+λ] <-- b[i]
    λ <-- λ+1
  Τέλος_επανάληψης
  Για i από 1 μέχρι 4
    γράψε '  ','a[',i,']=',a[i]
  Τέλος_επανάληψης

  Για i από 1 μέχρι 4
    γράψε '  ','b[',i,']=',b[i]
  Τέλος_επανάληψης

  Για i από 1 μέχρι 8
    γράψε_ '  ','Γ[',i,']='[i]
  Τέλος_επανάληψης

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters