Τώρα είναι Τρί 18 Φεβ 2020 04:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Λεξάριθμος!!!
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 17 Ιαν 2008 05:36 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 20 Δεκ 2007 05:29 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
! ===============================================================
! Να γίνει πρόγραμμα, το οποίο:
!   Α) Να ζητάει από τον χρήστη
!        - το πλήθος Ν των γραμμάτων μιας  λέξης (Ν<=20).
!        - τα Ν γράμματα αυτής της  λέξης.
!   B) -Να υπολογίζεται ο λεξάριθμος της λέξης που εισάγει ο χρήστης.
! Για παράδείγμα ο χρήστης εισαγεί τη λέξη ΝΙΚΗ
! Το πρόγραμμα τότε εκχωρεί στο κάθε γράμμα της λέξης τον
! αντίστοιχο λεξάριμθο και στο τέλος υπολογίζει το άθροισμα τους
! από όπου και προκύππτει ο Λεξάριθμος της λέξης ΝΙΚΗ.
! Δίνονται οι λεξάριθμοι των γραμμάτων:
! Α: 1
! Β: 2
! Γ: 3
! Δ: 4
! Ε: 5
! ΣΤ: 6
! Ζ: 7
! Η: 8
! Θ: 9
! Ι: 10
! Κ: 20
! Λ: 30
! Μ: 40
! Ν: 50
! Ξ: 60
! Ο: 70
! Π: 80
! Ρ: 100
! Σ: 200
! Τ: 300
! Υ: 400
! Φ: 500
! Χ: 600
! Ψ: 700
! Ω: 800
! Σημείωση: Να γίνει χρήση των λεξάριθμων.
! Οποιαδήποτε διορθώση που θα μπορούσε να γίνει ευπροσδεκτή.
! ===============================================================


ΠΡΟΓΡΑΜΜΑ ΛΕΞΑΡΙΘΜΟΣ
ΣΤΑΘΕΡΕΣ
  Α= 1
  Β= 2
  Γ= 3
  Δ= 4
  ΕΕ= 5
  ΣΤ= 6
  Ζ= 7
  ΗΗ= 8
  Θ= 9
  Ι= 10
  Κ= 20
  Λ= 30
  Μ= 40
  Ν= 50
  Ξ= 60
  Ο= 70
  Π= 80
  Ρ= 100
  Σ= 200
  Τ= 300
  Υ= 400
  Φ= 500
  Χ= 600
  Ψ= 700
  Ω= 800
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: λέξη[20],ΛΕΞ
  ΑΚΕΡΑΙΕΣ: Νi,i,ΛΛ[20],ΛΞ[20],επιλογή,S

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΑΡΧΗ
  ΓΡΑΨΕ '########################### ΕΝΑΡΞΗ #################################'
  ΓΡΑΨΕ''
  ΓΡΑΨΕ '************************************************************************'
  ΓΡΑΨΕ '* **Το πρόγραμμα υπολογίζει το λεξάριθμο της λέξης που του εισάγεις.** *'
  ΓΡΑΨΕ '* **Made by proskoposethnoys**                                         *'
  ΓΡΑΨΕ '* ** Έκδοση 1.0 **                                                     *'
  ΓΡΑΨΕ '************************************************************************'
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ '  Ν Ι Κ Ο Σ  Γ Ε Ω Ρ Γ Ι Τ Σ Ο Π Ο Υ Λ Ο Σ   '
  ΓΡΑΨΕ '          2 0 0 7- 2 0 0 8                   '
  ΓΡΑΨΕ '  Α΄ Γ Ε Ν.  Λ Υ Κ Ε Ι Ο   Σ Ι Ν Δ Ο Υ       '
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ '                                             '
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ''
    ΓΡΑΨΕ_ 'Δώσε την λέξη που θέλεις να υπολογίσεις τον λεξάριθμό για να την βλέπεις:'
    ΔΙΑΒΑΣΕ ΛΕΞ
    ΓΡΑΨΕ 'Σημείωση: Αν υπάρχει στην λέξη ο φθόγγος (ΣΤ ή στ) τότε να υπολογιστεί ώς ένα γράμμα.'
    ΓΡΑΨΕ_ 'Πόσα γράμματα έχει η λέξη  (μέχρι 20);'
    ΔΙΑΒΑΣΕ Νi

    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Νi
      ΓΡΑΨΕ 'Η λέξη είναι:',ΛΕΞ
      ΓΡΑΨΕ 'Σημείωση: Αν υπάρχει στην λέξη ο φθόγγος (ΣΤ ή στ) τότε να γραφεί μαζί ώς ένα γράμμα.'
      ΓΡΑΨΕ_ 'Δώσε το ', i, 'ο γράμμα της λέξης (χωρίς τόνο "΄", αν υπαρχεί) :'
      ΔΙΑΒΑΣΕ λέξη[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Νi
      ΑΝ  (λέξη[i]= 'Α') ή (λέξη[i]= 'α')  ΤΟΤΕ
        ΛΛ[i] <-- Α
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Β' ή λέξη[i]= 'β' ΤΟΤΕ
        ΛΛ[i] <-- Β
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Γ' Ή λέξη[i]= 'γ' ΤΟΤΕ
        ΛΛ[i] <-- Γ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Δ' ή λέξη[i]= 'δ' ΤΟΤΕ
        ΛΛ[i] <-- Δ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ε' ή λέξη[i]= 'ε' ΤΟΤΕ
        ΛΛ[i] <-- ΕΕ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ζ' ή λέξη[i]= 'ζ' ΤΟΤΕ
        ΛΛ[i] <-- Ζ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Η' ή λέξη[i]= 'η' ΤΟΤΕ
        ΛΛ[i] <-- ΗΗ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Θ' ή λέξη[i]= 'θ' ΤΟΤΕ
        ΛΛ[i] <-- Θ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ι' ή λέξη[i]= 'ι' ΤΟΤΕ
        ΛΛ[i] <-- Ι
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]='Κ' ή λέξη[i]='κ' ΤΟΤΕ
        ΛΛ[i] <-- Κ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Λ' ή λέξη[i]= 'λ' ΤΟΤΕ
        ΛΛ[i] <-- Λ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]='Μ' ή λέξη[i]='μ' ΤΟΤΕ
        ΛΛ[i] <-- Μ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ν' ή λέξη[i]= 'ν' ΤΟΤΕ
        ΛΛ[i] <-- Ν
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ξ' ή λέξη[i]= 'ξ' ΤΟΤΕ
        ΛΛ[i] <-- Ξ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ο' ή λέξη[i]= 'ο' ΤΟΤΕ
        ΛΛ[i] <-- Ο
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]='Π' Ή  λέξη[i]='π' ΤΟΤΕ
        ΛΛ[i] <-- Π
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]='Ρ' ή (λέξη[i]='ρ') ΤΟΤΕ
        ΛΛ[i] <-- Ρ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Σ' ή λέξη[i]='σ' ή λέξη[i]= 'ς' ΤΟΤΕ
        ΛΛ[i] <-- Σ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Τ' ή λέξη[i]= 'τ' ΤΟΤΕ
        ΛΛ[i] <-- Τ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Υ' Ή  λέξη[i]= 'υ' ΤΟΤΕ
        ΛΛ[i] <-- Υ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Φ' Ή  λέξη[i]= 'φ' ΤΟΤΕ
        ΛΛ[i] <-- Φ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Χ' Ή  λέξη[i]= 'χ' ΤΟΤΕ
        ΛΛ[i] <-- Χ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ψ' Ή  λέξη[i]= 'ψ' ΤΟΤΕ
        ΛΛ[i] <-- Ψ
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'Ω' Ή  λέξη[i]= 'ω' ΤΟΤΕ
        ΛΛ[i] <-- Ω
        ΛΞ[i] <-- ΛΛ[i]
      ΑΛΛΙΩΣ_ΑΝ λέξη[i]= 'ΣΤ' Ή  λέξη[i]= 'στ' ΤΟΤΕ
        ΛΛ[i] <-- ΣΤ
        ΛΞ[i] <-- ΛΛ[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ! Αθροίσμα των λεξάριθων του κάθε γράμματος
    S <-- 0
    ΓΙΑ i ΑΠΟ 1  ΜΕΧΡΙ Νi
      S <-- S+ΛΞ[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ! Φιγούρα να φάινεται πως υπολογίζει
    ΓΡΑΨΕ'Υπολογισμός του λεξάριθμου...'
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
      ΓΡΑΨΕ_'-*-'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ''
    ΓΡΑΨΕ'######################################################'
    ΓΡΑΨΕ'Ο Λεξάριθμος της λέξης "',ΛΕΞ,'" είναι:',S
    ΓΡΑΨΕ'######################################################'
    ΓΡΑΨΕ'Θέλεις να ξαναυπολογίσω;'
    ΓΡΑΨΕ'1.ΝΑΙ'
    ΓΡΑΨΕ'2.ΟΧΙ'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ_'Γράψε τον αριθμό που βρίσκεται μπροστα από την επιλογή σου:'
      ΔΙΑΒΑΣΕ επιλογή
    ΜΕΧΡΙΣ_ΟΤΟΥ (επιλογή=1) ή (επιλογή=2)
  ΜΕΧΡΙΣ_ΟΤΟΥ  επιλογή=2
  ΑΝ επιλογή=2 ΤΟΤΕ
    ΓΡΑΨΕ''
    ΓΡΑΨΕ'###################################'
    ΓΡΑΨΕ''
    ΓΡΑΨΕ '         ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ        '
    ΓΡΑΨΕ '         Ελπίζω να Βοήθησα!!       '
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ '|','*******************************','|'
    ΓΡΑΨΕ '|','                               ','|'
    ΓΡΑΨΕ '|','                               ','|'
    ΓΡΑΨΕ '|','-------------------------------','|'
    ΓΡΑΨΕ '|','  Made By "ProskoposEthnoy$"   ','|'
    ΓΡΑΨΕ '|','Email:proskoposethnoys@yahoo.gr','|'
    ΓΡΑΨΕ '|','-------------------------------','|'
    ΓΡΑΨΕ''
    ΓΡΑΨΕ'###################################'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΛΕΞΑΡΙΘΜΟΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Λεξάριθμος!!!
ΔημοσίευσηΔημοσιεύτηκε: Τετ 30 Ιούλ 2008 11:11 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 02:55 pm
Δημοσιεύσεις: 12
Κατι πιο ολοκληρωμενο, νομιζω :roll:

viewtopic.php?f=22&t=684


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters