Τώρα είναι Τρί 18 Φεβ 2020 05:08 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΔΙΑΧΩΡΙΣΜΟΣ Ν ΨΗΦΙΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Τρί 18 Δεκ 2007 09:28 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
ΝΑ ΓΡΑΦΕΙ ΠΡΟΓΡΑΜΜΑ ΠΟΥ ΝΑ ΔΙΑΒΑΖΕΙ ΕΝΑΝ ΑΡΙΘΜΟ Ν ΨΗΦΙΩΝ ΚΑΙ ΝΑ ΔΙΑΧΩΡΙΖΕΙ ΤΑ ΨΗΦΙΑ ΤΟΥ ΣΕ ΚΑΤΑΛΛΗΛΟ ΠΙΝΑΚΑ ΤΟΝ ΟΠΟΙΟ ΚΑΙ ΝΑ ΕΚΤΥΠΩΝΕΙ

(ΤΟ Ν ΝΑ ΕΙΝΑΙ ΜΙΑ ΣΤΑΘΕΡΑ, ΔΗΛΑΔΗ ΝΑ ΥΠΑΡΧΕΙ ΚΑΠΟΙΟ ΟΡΙΟ ΣΤΟΥΣ ΑΡΙΘΜΟΥΣ)

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΔΙΑΧΩΡΙΣΜΟΣ
ΣΤΑΘΕΡΕΣ
  ΜΕΓ = 10  ! ΜΕΓΙΣΤΟΣ ΑΡΙΘΜΟΣ ΕΠΙΤΡΕΠΟΜΕΝΩΝ ΨΗΦΙΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : ΠΙΝ[ΜΕΓ],Ν,Χ,Ι
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑΝ ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΔΙΑΧΩΡΙΣΤΟΥΝ ΤΑ ΨΗΦΙΑ ΤΟΥ.'
  ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΝΑ ΕΙΝΑΙ ΤΟ ΠΟΛΥ ', ΜΕΓ, ' ΨΗΦΙΟΣ'
  ΔΙΑΒΑΣΕ Ν
  ΟΣΟ Ν > (10^ΜΕΓ - 1) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΕΙΠΑΜΕ ΤΟ ΠΟΛΥ ', ΜΕΓ , 'ΨΗΦΙΟΣ'
    ΔΙΑΒΑΣΕ Ν
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ι <-- 10
  Χ <-- ΜΕΓ
  ΟΣΟ Χ > 0 ΕΠΑΝΑΛΑΒΕ
    ΠΙΝ[Χ] <-- (Ν - (Ν DIV Ι)*Ι) DIV (Ι DIV 10) ! ΚΡΑΤΑΕΙ ΤΟ ΤΕΛΕΥΤΑΙΟ ΨΗΦΙΟ
    Ι <-- Ι * 10
    Χ <-- Χ - 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΕΓ
    ΓΡΑΨΕ ΠΙΝ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΔΙΑΧΩΡΙΣΜΟΣ Ν ΨΗΦΙΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Ιουν 2008 11:27 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 25 Ιαν 2008 01:07 am
Δημοσιεύσεις: 2
ΒΑΣΙΣΜΕΝΟΣ ΣΤΟ ΠΡΟΓΡΑΜΜΑ ΣΟΥ ΕΠΙΣΥΝΑΠΤΩ ΜΙΑ ΠΡΟΤΑΣΗ ΜΕ ΛΙΓΟ ΑΠΛΟΥΣΤΕΡΟ ΚΩΔΙΚΑ

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΔΙΑΧΩΡΙΣΜΟΣ_ΨΗΦΙΩΝ
ΣΤΑΘΕΡΕΣ
  Ν=10
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Χ,Υ[Ν]

ΑΡΧΗ

  ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑΝ ΑΡΙΘΜΟ ΜΕ ΜΕΓΙΣΤΟ 10 ΨΗΦΙΑ:'
  ΔΙΑΒΑΣΕ Χ
  ΓΡΑΨΕ

  ΟΣΟ Χ>(10^Ν-1) ΕΠΑΝΑΛΑΒΕ

    ΓΡΑΨΕ 'ΛΑΘΟΣ ΕΙΣΑΓΩΓΗ!!!'
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑΝ ΑΡΙΘΜΟ ΜΕ ΜΕΓΙΣΤΟ 10 ΨΗΦΙΑ:'
    ΔΙΑΒΑΣΕ Χ
    ΓΡΑΨΕ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  Ι <-- 1

  ΟΣΟ Χ>0 ΕΠΑΝΑΛΑΒΕ

    Υ[Ι] <-- Χ MOD 10
    Χ <-- Χ DIV 10
    Ι <-- Ι+1

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ Ι ΑΠΟ Ι-1 ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1

    ΓΡΑΨΕ_ Υ[Ι]

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΔΙΑΧΩΡΙΣΜΟΣ Ν ΨΗΦΙΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Ιουν 2008 01:47 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Πολύ καλο, δεν το ειχα σκεφτει οτι διαιρόντας με το 10 το υπολοιπο θα ειναι το τελ ψηφιο... Μαλλον σκεφτομαι πολύ πολύπλοκα...

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters