Τώρα είναι Τρί 18 Φεβ 2020 04:14 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μηδενικά Στο Τέλος
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 14 Μάιος 2007 11:29 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 12 Μάιος 2007 10:21 pm
Δημοσιεύσεις: 2
Τοποθεσία: Πάτρα
Syntax: [ Download ] [ Hide ]
!ΕΙΣΑΓΕΙΣ ΤΑ ΣΤΟΙΧΕΙΑ ΕΝΟΣ ΠΙΝΑΚΑ Α ΚΑΙ ΤΑ ΕΜΦΑΝΙΖΕΙ ΜΕ ΤΗΝ ΙΔΙΑ ΣΕΙΡΑ ΠΟΥ ΤΑ ΚΑΤΑΧΩΡΗΣΕΣ
!ΒΑΖΟΝΤΑΣ ΟΜΩΣ ΟΛΑ ΤΑ ΜΙΔΕΝΙΚΑ ΣΤΟ ΤΕΛΟΣ ΤΟΥ ΠΙΝΑΚΑ


ΠΡΟΓΡΑΜΜΑ ΜΗΤΣΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Κ,Ν,Ι
  ΠΡΑΓΜΑΤΙΚΕΣ:Β[1000][1000]
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ ΤΟΝ ΑΡΙΘΜΟ ΤΩΝ ΣΤΟΙΧΕΙΩΝ ΤΟΥ ΠΙΝΑΚΑ ΠΟΥ ΠΡΟΚΕΙΤΑΙ ΝΑ ΕΙΣΑΓΕΙΣ'
    ΔΙΑΒΑΣΕ Ν
  ΜΕΧΡΙΣ_ΟΤΟΥ Ν>=1 ΚΑΙ Ν<=1000
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ ΤΑ ΣΤΟΙΧΕΙΑ ΤΟΥ ΠΙΝΑΚΑ'
    ΔΙΑΒΑΣΕ Α[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Κ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    Β[Ι] <-- 0
    ΑΝ Α[Ι]<>0 ΤΟΤΕ
      Κ <-- Κ+1
      Β[Κ] <-- Α[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΡΑΨΕ Β[Κ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΗΤΣΟΣ
 

_________________
Snoop:The Tire Smoker


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 17 Μάιος 2007 11:56 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Ένα μικρό λαθάκι στο τέλος.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΗΤΣΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Κ,Ν,Ι
  ΠΡΑΓΜΑΤΙΚΕΣ:Β[1000][1000]
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ ΤΟΝ ΑΡΙΘΜΟ ΤΩΝ ΣΤΟΙΧΕΙΩΝ ΤΟΥ ΠΙΝΑΚΑ ΠΟΥ ΠΡΟΚΕΙΤΑΙ ΝΑ ΕΙΣΑΓΕΙΣ'
    ΔΙΑΒΑΣΕ Ν
  ΜΕΧΡΙΣ_ΟΤΟΥ Ν>=1 ΚΑΙ Ν<=1000
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ ΤΑ ΣΤΟΙΧΕΙΑ ΤΟΥ ΠΙΝΑΚΑ'
    ΔΙΑΒΑΣΕ Α[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Κ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    Β[Ι] <-- 0
    ΑΝ Α[Ι]<>0 ΤΟΤΕ
      Κ <-- Κ+1
      Β[Κ] <-- Α[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν       ! <<<<< Μέχρι Ν για να εμφανιστούν και τα μηδενικά
    ΓΡΑΨΕ Β[Ι]                   ! <<<<< Εδώ θέλει Ι και όχι Κ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΗΤΣΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters