Τώρα είναι Τρί 18 Φεβ 2020 04:16 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 20 Δεκ 2006 12:55 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
!  Να γραφεί πρόγραμμα το οποίο :
!  - θα δέχεται τα οκτώ ψηφία (bit) ενός byte που αντιστοιχούν
!    στη δυαδική απεικόνιση ενός αριθμού και
!  - θα υπολογίζει και εμφανίζει την τιμή του αριθμού στο δεκαδικό σύστημα.
!  Υπενθυμίζεται ότι τα ψηφία πρέπει να είναι 0 ή 1,
!  οπότε πρέπει να γίνεται ο κατάλληλος έλεγχος και να μη γίνονται δεκτά άλλα ψηφία.
!  Το πρώτο ψηφίο που θα δοθεί είναι το περισσότερο σημαντικό.


ΠΡΟΓΡΑΜΜΑ byte
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: bit[8] , i
  ΠΡΑΓΜΑΤΙΚΕΣ: dec
ΑΡΧΗ
  dec <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ 'Δώσε το ψηφίο Νο : ' , i
    ΔΙΑΒΑΣΕ bit[i]
    ΟΣΟ (bit[i] <> 0) ΚΑΙ (bit[i] <>1) ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Ξαναδώσε το ψηφίο Νο : ' , i , ' (πρέπει να είναι 0 ή 1 )'
      ΔΙΑΒΑΣΕ bit[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    dec <-- dec + bit[i]*2^(8-i)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ_ 'Ο αριθμός '
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ_ bit[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' στο δυαδικό σύστημα,'
  ΓΡΑΨΕ 'Αντιστοιχεί στον αριθμό ' , dec , ' στο δεκαδικό σύστημα.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters