Τώρα είναι Τρί 29 Σεπ 2020 02:47 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Δεκ 2006 01:04 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα το οποίο :
! α) να δέχεται μια σειρά από 200 πραγματικούς αριθμούς.
! β) να υπολογίζει και να εμφανίζει το μέσο όρο τους.
! γ) να υπολογίζει και να εμφανίζει το πλήθος των αριθμών του πίνακα που είναι μεγαλύτεροι από το μέσο όρο.
! δ) να υπολογίζει και να εμφανίζει το ποσοστό των αριθμών του πίνακα που είναι θετικοί.
! ε) να υπολογίζει και να εμφανίζει το πλήθος των μηδενικών που πιθανόν περιέχει ο πίνακας.

ΠΡΟΓΡΑΜΜΑ PIN01
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,N,z,x
  ΠΡΑΓΜΑΤΙΚΕΣ:m[200],sum,mesos,p
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 200
    ΓΡΑΨΕ 'Δώσε αριθμό Νο :',i
    ΔΙΑΒΑΣΕ m[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  sum <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 200
    sum <-- sum + m[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mesos <-- sum/200
  N <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 200
    ΑΝ m[i] > mesos ΤΟΤΕ
      N <-- N + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  x <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 200
    ΑΝ m[i] > 0 ΤΟΤΕ
      x <-- x + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  p <-- x/200*100
  z <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 200
    ΑΝ m[i] = 0 ΤΟΤΕ
      z <-- z + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'O μέσος όρος των αριθμών του πίνακα είναι : ',mesos
  ΓΡΑΨΕ 'Μεγαλύτεροι από αυτόν είναι :',N,' αριθμοί του πίνακα.'
  ΓΡΑΨΕ 'Oι θετικοί είναι το ',p,'% των αριθμών του πίνακα.'
  ΓΡΑΨΕ 'O πίνακας περιέχει ',z,' μηδενικά'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters