Τώρα είναι Τρί 18 Φεβ 2020 04:16 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Διαχωρισμός Πινάκων
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Δεκ 2006 01:03 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα το οποίο :
! α) να δέχεται 200 πραγματικούς αριθμούς τους οποίους να καταχωρεί στον πίνακα Α[200].
! β) να δημιουργεί δύο άλλους πίνακες Β[100] και Γ[100] στους οποίους να βάζει αντίστοιχα
!    τα πρώτα 100 και τα τελευταία 100 στοιχεία του πίνακα Α[200].
! γ) να δημιουργεί δύο άλλους πίνακες Δ[100] και Ζ[100] στους οποίους να βάζει αντίστοιχα
!    τα στοιχεία του πίνακα Α[200] εναλλάξ.
! δ) να δημιουργεί πίνακα S[100] σε κάθε θέση του οποίου να βάζει το άθροισμα των αντίστοιχων
!    θέσεων των πινάκων Β, Γ, Δ, Ζ.
! ε) να εμφανίζει τα περιεχόμενα των πινάκων Β, Γ, Δ, Ζ  και S με τέτοιο τρόπο ώστε
!    να φαίνεται ότι Β[i] + Γ[i] + Δ[i] + Ζ[i] = S[i].

ΠΡΟΓΡΑΜΜΑ PIN03
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i
  ΠΡΑΓΜΑΤΙΚΕΣ: A[200], B[100], Γ[100], Δ[100], Ζ[100] ,S[100]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 200
    ΓΡΑΨΕ 'Δώσε έναν αριθμό (',i,'ος από 200)'
    ΔΙΑΒΑΣΕ A[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    B[i] <-- A[i]
    Γ[i] <-- A[100+i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    Δ[i] <-- A[2*i-1]
    Ζ[i] <-- A[2*i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    S[i] <-- B[i] + Γ[i] + Δ[i] + Ζ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ  B[i],' + ', Γ[i],' + ', Δ[i],' + ', Ζ[i], ' = ',S[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters