Τώρα είναι Δευτ 28 Σεπ 2020 10:00 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Διαγωνσιμός σε δύο φάσεις
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Δεκ 2006 12:58 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Ένας διαγωνισμός διενεργείται σε δύο φάσεις. Στην πρώτη φάση έλαβαν μέρος 1000 άτομα.
! Στη δεύτερη φάση προκρίνονται όσοι έχουν βαθμό μεγαλύτερο από το μέσο όρο των βαθμών
! της πρώτης φάσης αυξημένο κατά 20 %.
! Να γραφεί πρόγραμμα το οποίο :
!  α) δέχεται το όνομα και τη βαθμολογία κάθε διαγωνιζόμενου στην πρώτη φάση.
!  β) υπολογίζει και εμφανίζει το όριο που πρέπει να έχει κάποιος για να περάσει
!     στη δεύτερη φάση του διαγωνισμού.
!  γ) εμφανίζει το πλήθος και τα ονόματα αυτών που προκρίθηκαν.
!
!  ΠΑΡΑΤΗΡΗΣΗ : Να μη γίνεται δεκτή βαθμολογία που δεν είναι από 1 έως 100.


ΠΡΟΓΡΑΜΜΑ PIN04
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i , N
  ΠΡΑΓΜΑΤΙΚΕΣ: b[1000],s,mesos,limit
  ΧΑΡΑΚΤΗΡΕΣ: name[1000]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 1000
    ΓΡΑΨΕ 'Δώσε το όνομα του διαγωνιζομένου Νο :',i
    ΔΙΑΒΑΣΕ name[i]
    ΓΡΑΨΕ 'Δώσε και τη βαθμολογία του'
    ΔΙΑΒΑΣΕ b[i]
    ΟΣΟ b[i] < 1 ή b[i] > 100 ΕΠΑΝΑΛΑΒΕ  !
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'            ! ΕΛΕΓΧΟΣ ΕΓΚΥΡΟΤΗΤΑΣ
      ΔΙΑΒΑΣΕ b[i]                       !     ΒΑΘΜΟΛΟΓΙΑΣ              
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                     !
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  s <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 1000
    s <-- S + b[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mesos <-- s/1000                      
  limit <-- mesos + mesos*20/100
  N <-- 0
  ΓΡΑΨΕ 'To όριο για την πρόκριση στη δεύτερη φάση του διαγωνισμού είναι : ',limit
  ΓΡΑΨΕ 'To όριο αυτό πέρασαν οι εξής : '
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 1000
    ΑΝ b[i] > limit ΤΟΤΕ
      ΓΡΑΨΕ name[i]
      N <-- N + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Στη δεύτερη φάση προκρίνονται ',N,'διαγωνιζόμενοι'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters