Τώρα είναι Παρ 10 Απρ 2020 01:08 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Συνένωση πινάκων
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 15 Μαρ 2003 03:03 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ========================================================
! Να γίνει πρόγραμμα που να διαβάζει έναν πίνακα Α,
! ακεραίων αριθμών, 5 θέσεων, και έναν πίνακα Β, ακεραίων
! αριθμών, 15 θέσεων. Στη συνέχεια να τους συνενώνει σε
! έναν πίνακα Γ, ακεραίων αριθμών, 20 θέσεων, τοποθετώντας
! πρώτο τον Α και δεύτερο το Β.
! ========================================================


ΠΡΟΓΡΑΜΜΑ Συνένωση_πινάκων

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[5], Β[15], Γ[20], i

ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ 'Δώσε το ', i, 'ο στοιχείο του πίνακα Α:'
    ΔΙΑΒΑΣΕ Α[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
    ΓΡΑΨΕ 'Δώσε το ', i, 'ο στοιχείο του πίνακα Β:'
    ΔΙΑΒΑΣΕ Β[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    Γ[i] <-- Α[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 6 ΜΕΧΡΙ 20
    Γ[i] <-- Β[i-5]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Το ', i, 'ο στοιχείο του πίνακα Γ είναι:', Γ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Συνένωση_πινάκων

 

Ενδεικτικό αρχείο δεδομένων:
(χαρακτηριστικό που υλοποιήθηκε στην έκδοση 8 της ΓλωσσοΜάθειας)
Παράθεση:
1 2 3 4 5

6 7 8 9 10 11 12 13 14 15 16 17 18 19 20


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters