Τώρα είναι Τρί 18 Φεβ 2020 04:17 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 06 Ιούλ 2005 01:17 pm 
Να γίνει πρόγραμμα που γεμίζει ένα πίνακα στον οποίο να μην είναι δυνατή η αποθήκευση ενός στοιχείου περισσότερες από μία φορές


Κορυφή
  
 
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 02 Μαρ 2006 06:40 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 17 Νοέμ 2005 06:46 pm
Δημοσιεύσεις: 4
Τοποθεσία: Αθήνα
Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα για την καταχώρηση ονομάτων σε πίνακα.
! Αν κάποιο από τα εισαγόμενα ονόματα έχει ήδη καταχωρισθεί,
! να εμφανίζεται σχετικό μήνυμα και να μην γίνεται επανακαταχώρησή του.
! Ταξινόμηση του πίνακα ( φυσσαλίδα )
! Μια λύση του προβλήματος με συμπλήρωμα την εμφάνιση των στοιχείων
! σε έναν μονοδιάστατο 10θέσιο πίνακα.
! Την λύση έδωσε ο μαθητής Οικονομόπουλος Βαλάντης του 6ου
! Ενιαίου Λυκείου Περιστερίου.


ΠΡΟΓΡΑΜΜΑ Καταχώρηση1
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι,κ
  ΧΑΡΑΚΤΗΡΕΣ: Ονόματα[10],βοηθ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ '   Δώσε το ',ι,'ο όνομα προς καταχώρηση'
    ΔΙΑΒΑΣΕ Ονόματα[ι]
    κ <-- 1
    ΟΣΟ κ<ι ΕΠΑΝΑΛΑΒΕ
      ΑΝ Ονόματα[ι]=Ονόματα[κ] ΤΟΤΕ
        ΓΡΑΨΕ '  Το όνομα ',Ονόματα[ι],' υπάρχει στην θέση '
        ΓΡΑΨΕ '  Ξαναδώσε το ',ι,'ο όνομα προς καταχώρηση'
        ΔΙΑΒΑΣΕ Ονόματα[ι]
        κ <-- 1
      ΑΛΛΙΩΣ
        κ <-- κ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 10
    ΓΙΑ κ ΑΠΟ 10 ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1
      ΑΝ Ονόματα[κ-1]>Ονόματα[κ] ΤΟΤΕ
        βοηθ <-- Ονόματα[κ-1]
        Ονόματα[κ-1] <-- Ονόματα[κ]
        Ονόματα[κ] <-- βοηθ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ Ονόματα[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Καταχώρηση1


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 10 Μαρ 2006 10:37 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Ανορθόδοξα όμορφο...

Οι μαθητές δεν θα πάψουν ποτέ να μας ξαφνιάζουν

Με εκτίμηση,

Τσιωτάκης Παναγιώτης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters