Τώρα είναι Τρί 18 Φεβ 2020 04:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Πονηρό ΔΜΣ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 22 Ιαν 2005 02:35 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Να πως θα προτιμούσα το 3ο Θέμα των Πανελληνίων Εξετάσεων ΑΕΠΠ 2003 :lol:


Syntax: [ Download ] [ Hide ]

! Ο Δείκτης Μάζας του ανθρώπινου Σώματος (ΔΜΣ) υπολογίζεται από το βάρος (Β)
! σε χλγ. και το ύψος (Υ) σε μέτρα με τον τύπο ΔΜΣ=Β/Υ^2.
! Ο ανωτέρω τύπος ισχύει για άτομα άνω των 16 ετών.
! Το άτομο ανάλογα με την τιμή του ΔΜΣ χαρακτηρίζεται σύμφωνα με τον παρακάτω πίνακα:
!
!          ΔΜΣ<18,5     "αδύνατο άτομο"
!     18,5 ΔΜΣ<25       "κανονικό άτομο"
!       25<ΔΜΣ          "βαρύ άτομο"
!
! Να γράψετε πρόγραμμα το οποίο:
! α. να διαβάζει το όνομα, την ηλικία, το βάρος και το ύψος του ατόμου
!    για ένα σχολείο  150 μαθητών.
! β. εάν η ηλικία είναι μεγαλύτερη των 16 ετών, τότε
!      1.  να υπολογίζει το ΔΜΣ
!      2.  να ελέγχει την τιμή του ΔΜΣ από τον ανωτέρω πίνακα
!          και να εμφανίζει τον αντίστοιχο χαρακτηρισμό
! γ. εάν η ηλικία είναι μικρότερη ή ίση των 16 ετών,
!    τότε να εμφανίζει το μήνυμα "δεν ισχύει ο δείκτης ΔΜΣ".
! δ. να εμφανίζει το όνομα του μαθητή με το μεγαλύτερο ΔΜΣ.
! ε. να εμφανίζει τις ηλικίες των μαθητών οι οποίοι έχουν ΔΜΣ υψηλότερο
!    από το μέσο όρο του σχολείου. Ο μέσος όρος ΔΜΣ του σχολείου
!    προκύπτει μόνο από τους μαθητές με ηλικία >16.
! Παρατήρηση:   Θεωρήστε ότι το βάρος, το ύψος και η ηλικία είναι θετικοί αριθμοί
!               και μην ασχοληθείτε με τον έλεγχο τους.

ΠΡΟΓΡΑΜΜΑ πονηρό_ΔΜΣ
ΣΤΑΘΕΡΕΣ
  size=150
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,μ,Ηλικια,Ηλ_ΔΜΣ[size]
  ΠΡΑΓΜΑΤΙΚΕΣ:Υ,Β,ΔΜΣ[size],Σ,ΜΟ,max
  ΧΑΡΑΚΤΗΡΕΣ: Ονομα,Ον_ΔΜΣ[size]
ΑΡΧΗ
  μ <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ size
    ΓΡΑΨΕ 'Δώσε ονομα ',i,'ου μαθητή'
    ΔΙΑΒΑΣΕ Ονομα
    ΓΡΑΨΕ 'Δώσε ηλικία ',i,'ου μαθητή'
    ΔΙΑΒΑΣΕ Ηλικια
    ΓΡΑΨΕ 'Δώσε βάρος ',i,'ου μαθητή'
    ΔΙΑΒΑΣΕ Β
    ΓΡΑΨΕ 'Δώσε ύψος ',i,'ου μαθητή'
    ΔΙΑΒΑΣΕ Υ

    ΑΝ Ηλικια>16 ΤΟΤΕ
      μ <-- μ+1
      ΔΜΣ[μ] <-- Β/Υ^2
      Ηλ_ΔΜΣ[μ] <-- Ηλικια
      Ον_ΔΜΣ[μ] <-- Ονομα
      Σ <-- Σ + ΔΜΣ[μ]

      ΑΝ ΔΜΣ[μ]<18.5 ΤΟΤΕ
        ΓΡΑΨΕ 'Αδύνατο άτομο'
      ΑΛΛΙΩΣ_ΑΝ ΔΜΣ[μ]<25 ΤΟΤΕ
        ΓΡΑΨΕ 'Κανονικό άτομο'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Βαρύ άτομο'
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'δεν ισχύει ο δείκτης ΔΜΣ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  max <-- ΔΜΣ[1]
  θ <-- 1
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ μ
    ΑΝ ΔΜΣ[i]>max ΤΟΤΕ
      max <-- ΔΜΣ[i]
      θ <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ο μαθητής με το μεγαλύτερο ΔΜΣ είναι ο ', Ον_ΔΜΣ[θ]

  ΑΝ μ<>0 ΤΟΤΕ
    ΜΟ <-- Σ/μ
    ΓΡΑΨΕ 'οι ηλικίες των μαθητών με ΔΜΣ πάνω από το μέσο όρο είναι:'
 ΤΕΛΟΣ_ΑΝ

 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ μ
    ΑΝ ΔΜΣ[i]>ΜΟ ΤΟΤΕ
      ΓΡΑΨΕ Ηλ_ΔΜΣ[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 02 Φεβ 2005 11:53 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Κατά τη γνώμη μου αυτή είναι η επόμενη μορφή του θέματος 3 των εξετάσεων

Πολλαπλή επιλογή μέσα σε βρόχο

Με εκτίμηση,

Τσιωτάκης Παναγιώτης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 11 Μαρ 2006 09:08 pm 
μπορειτε να μου πειτε γιατι μπηκε η μεταβλητη μ ?
ευχαριστω


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters