Τώρα είναι Τετ 30 Σεπ 2020 12:06 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 17 Δεκ 2004 01:05 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]
! =====================================================================================================
! Να γίνει πρόγραμμα το οποίο να δέχεται τους βαθμούς μιας τάξης 18 μαθητών στο μάθημα της πληροφορικής
! και στη συνέχεια να εμφανίζει το βαθμό που παρατηρήθηκε τις περισσότερες φορές (επικρατούσα τιμή),
! όπως και πόσες φορές εμφανίστηκε.Θεωρήστε ότι οι βαθμοί είναι ΘΕΤΙΚΟΙ ΠΡΑΓΜΑΤΙΚΟΙ (με διαφορετικό πλήθος δεκαδικών ψηφίων ψηφίων ενδεχομένως μεταξύ τους, χωρίς αυτό να είναι γνωστό).
! =====================================================================================================

ΠΡΟΓΡΑΜΜΑ Επικρατέστερος_Βαθμός_2
ΣΤΑΘΕΡΕΣ
  N=18
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,ΣΥΧΝ,max
  ΠΡΑΓΜΑΤΙΚΕΣ:Β[N],Bmax
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Δώσε το βαθμό του ',i,'ου μαθητή'
      ΔΙΑΒΑΣΕ Β[i]
    ΜΕΧΡΙΣ_ΟΤΟΥ Β[i]>0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  max <-- 1
  Bmax <-- Β[1]
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ N
    ΣΥΧΝ <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ Β[i]=Β[j] ΤΟΤΕ
        ΣΥΧΝ <-- ΣΥΧΝ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΥΧΝ>max ΤΟΤΕ
      max <-- ΣΥΧΝ
      Bmax <-- Β[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ο βαθμός που παρατηρήθηκε περισσότερες φορές ήταν ο ',Bmax,' με συχνότητα ',max

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Ανάλογη είναι η άσκηση στη διεύθυνση: http://spinet.gr/glossomatheia/programs ... .php?t=157


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters