Τώρα είναι Τρί 18 Φεβ 2020 04:29 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Άγουρες ντομάτες **
ΔημοσίευσηΔημοσιεύτηκε: Παρ 21 Μάιος 2004 10:21 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]

! =============================================================================================================================
! Είναι γεγονός ότι εάν τοποθετηθούν ώριμες ντομάτες ανάμεσα σε άγουρες ντομάτες μέσα σε μια γραμμή παραγωγής
! τότε οι άγουρες ντομάτες θα αρχίσουν να ωριμάζουν γρηγορότερα.
! Το πρόβλημα έχει ως εξής: υπάρχουν n ντομάτες τοποθετημένες σε μια γραμμή και είναι αριθμημένες από 1 έως n (4<=n<=30).
! Μόνο m (1<=m<=n) ντομάτες από αυτές είναι κόκκινες, δηλαδή ώριμες.
! Οι αριθμοί της θέσης των κόκκινων ντοματών στη γραμμή είναι m1, m2, m3, όπου 1<=mi<=n.
! Αμφότερες οι γειτονικές ντομάτες μιας ώριμης ντομάτας θα ωριμάζουν, δηλαδή θα κοκκινίσουν, κατά τη διάρκεια μιας μέρας,
! εάν δεν είναι ήδη ώριμες. Προσοχή, κάθε ντομάτα στη γραμμή έχει δυο γειτονικές ντομάτες εκτός της πρώτης και της τελευταίας
! που έχουν μόνο μια.
! Γράψτε ένα πρόγραμμα που να υπολογίζει πόσες άγουρες ντομάτες θα παραμείνουν στη γραμμή μετά από d (1<=d<=7) ημέρες.
! Σημείωση: Στα δεδομένα εισόδου οι αριθμοί των ώριμων ντοματών δίνονται σε αύξουσα σειρά.
!
! ------------------- ΠΑΡΑΔΕΙΓΜΑ ------------------------- n=20, d=3, m=4 με m1=2, m2=13, m3=15, m4=20 (16 άγουρες, 4 κόκκινες)
! αρχική μέρα:     α κ α α α α α α α α α α κ α κ α α α α κ
! τέλος 1ης μέρας: κ κ κ α α α α α α α α κ κ κ κ κ α α κ κ
! τέλος 2ης μέρας: κ κ κ κ α α α α α α κ κ κ κ κ κ κ κ κ κ
! τέλος 3ης μέρας: κ κ κ κ κ α α α α κ κ κ κ κ κ κ κ κ κ κ         μετά από 3 ημέρες έχουν μείνει 4 άγουρες ντομάτες
!
!κλπ, όπου α = άγουρη ντομάτα  και  κ = κόκκινη ντομάτα
!
! ( Από τον 15ο Πανελλήνιο Διαγωνισμό Πληροφορικής, Φάση 1η )
! ( http://epy.compulink.gr/panellinios/ )    
!
! Υπόδειξη: Το πρόγραμμα σας θα πρέπει να διαβάζει:
! α) το συνολικό αριθμό των ντοματών n (ακέραιος)
! β) τις μέρες παραμονής των ντοματών d (ακέραιος)
! γ) τον αρχικό αριθμό κόκκινων ντομάτων m (ακέραιος)
! δ) τις θέσεις mi στη γραμμή παραγωγής, των των m κόκκινων ντομάτων (ακέραιος)
!
! Θα πρέπει κάθε μερά να εμφανίζει την εικόνα της γραμμής πααγωγής όπως στο παράδειγμα,
! και στο τέλος να εμφανίζει πόσες άγουρες ντομάτες έχουν απομείνει.
! =============================================================================================================================


ΠΡΟΓΡΑΜΜΑ Παραγωγή_Τοματών
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,n,m,d,Θ,Π,Κ
  ΧΑΡΑΚΤΗΡΕΣ:Χ[30]
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε αριθμό ντομάτων'
    ΔΙΑΒΑΣΕ n
  ΜΕΧΡΙΣ_ΟΤΟΥ (n>=4) ΚΑΙ (n<=30)

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε μέρες παραμονής ντομάτων'
    ΔΙΑΒΑΣΕ d
  ΜΕΧΡΙΣ_ΟΤΟΥ (d>=1) ΚΑΙ (d<=7)

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε αριθμό κόκκινων ντομάτων'
    ΔΙΑΒΑΣΕ m
  ΜΕΧΡΙΣ_ΟΤΟΥ (m>=1) ΚΑΙ (m<=n)

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
    Χ[i] <-- 'α'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ m
    ΓΡΑΨΕ 'Δώσε θέση ',i,'ης κόκκινης ντομάτας'
    ΔΙΑΒΑΣΕ Θ
    Χ[Θ] <-- 'κ'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ              

  ΓΡΑΨΕ_ '   Αρχικα:         '
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
    ΓΡΑΨΕ_ Χ[i],' '
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ d
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
      ΑΝ  Χ[i]='κ' ΤΟΤΕ
        ΑΝ i=1 ΤΟΤΕ
          ΑΝ Χ[2]='α' ΤΟΤΕ
            Χ[2] <-- 'κ'
            i <-- i+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ_ΑΝ i=n ΤΟΤΕ
          Χ[n-1] <-- 'κ'
        ΑΛΛΙΩΣ
          Χ[i-1] <-- 'κ'
          ΑΝ Χ[i+1]='α' ΤΟΤΕ
            Χ[i+1] <-- 'κ'
            i <-- i+1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ_ 'Μετα από ',j,' μέρες:  '
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
      ΓΡΑΨΕ_ Χ[i],' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  Π <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
    ΑΝ Χ[i]='α' ΤΟΤΕ
      Π <-- Π+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Βρέθηκαν ',Π,' άγουρες ντομάτες'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters