Τώρα είναι Τρί 18 Φεβ 2020 04:45 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Έλεγχος εισόδου δεδομένων
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 18 Απρ 2004 01:50 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 30 Νοέμ 2003 07:20 pm
Δημοσιεύσεις: 5
Τοποθεσία: Αθήνα - Κηφισιά
Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα το οποίο θα δέχεται από το πληκτρολόγιο 10 διαφορετικούς αριθμούς
! τους οποίους θα καταχωρεί σε πίνακα,
! αφού προηγουμένως κατά την είσοδο ελέγχει αν είναι όλοι διαφορετικοί,
! αλλιώς θα ζητάει από τον χρήστη την επαναεισαγωγή του τελευταίου αριθμού.


ΠΡΟΓΡΑΜΜΑ Έλεγχος_Εισόδου
ΜΕΤΑΒΛΗΤΕΣ
  ΛΟΓΙΚΕΣ:Flag
  ΑΚΕΡΑΙΕΣ:I,J,Α[10]
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε 10 ΔΙΑΦΟΡΕΤΙΚΟΥΣ Αριθμούς'
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 10
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Flag <-- Ψευδής
      ΓΡΑΨΕ  'Δώσε τον ',I,'ο αριθμό'
      ΔΙΑΒΑΣΕ  Α[I]
      ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ I-1
        ΑΝ Α[J]=Α[I] ΤΟΤΕ
          Flag <-- Αληθής
          ΓΡΑΨΕ 'Ο αριθμός '[J], ' υπάρχει, δώσε άλλον αριθμό'
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΕΧΡΙΣ_ΟΤΟΥ Flag = Ψευδής
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ I,' --> '[I]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  Έλεγχος_Εισόδου
 

_________________
Δημήτρης Παπακωνσταντίνου


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters