Τώρα είναι Τρί 18 Ιουν 2019 12:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 01 Ιαν 2014 03:23 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Δεκ 2013 12:46 pm
Δημοσιεύσεις: 8
    Νομιζω οτι το διορθωσα,πειτε μου αν βρειτε λαθος
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  μετατροπη01

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ι,αρ,Ψ[8]
  ΧΑΡΑΚΤΗΡΕΣ:απ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'δωσε εναν αριθμο απο το 0 μέχρι το 255'
      ΔΙΑΒΑΣΕ αρ
    ΜΕΧΡΙΣ_ΟΤΟΥ αρ>=0 και αρ<=255
    σ <-- 0
    ΓΙΑ ι απο 7 μέχρι 0 ΜΕ ΒΗΜΑ -1
      ΑΝ αρ>=2^ι και αρ-σ>=2^ι τότε    
        Ψ[ι+1] <-- 1
        σ <-- σ+2^ι
      ΑΛΛΙΩΣ
        Ψ[ι+1] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ Ψ[8][7][6][5][4][3][2][1]
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΞΑΝΑ?(ναι η οχι)'
      ΔΙΑΒΑΣΕ απ
    ΜΕΧΡΙΣ_ΟΤΟΥ απ='ναι'η απ='οχι'
  ΜΕΧΡΙΣ_ΟΤΟΥ απ='οχι'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ





 

_________________
paul


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters