Τώρα είναι Σάβ 22 Φεβ 2020 03:07 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: epithymhth exada arithmwn
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 06 Ιαν 2013 09:23 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 05 Ιαν 2013 03:10 pm
Δημοσιεύσεις: 2
Kalhmera sas

xronia sas polla , kalh xronia

borei kapoios na me vohthhsei sas parakalw??????
na anaptyxw pseydokwdika:
υπάρχει μια άγνωστη στους παίκτες «επιθυμητή» εξάδα αριθμών
(δηλαδή, έξι διαφορετικοί ακέραιοι αριθμοί στο διάστημα από το 1 ως και το
49) και ο παίκτης,
προσπαθώντας να μαντέψει αυτή την εξάδα, επιλέγει έξι (6) διαφορετικούς
ακέραιους
αριθμούς, από το 1 έως και το 49. Ο παίκτης κερδίζει στο παιχνίδι εάν
τουλάχιστον τρεις από
τους αριθμούς που έχει επιλέξει ανήκουν στην «επιθυμητή» εξάδα.

να αναπτυχθεί σε ψευδοκώδικα μια διαδικασία, η οποία
θα λαμβάνει ως παράμετρο ένα μονοδιάστατο πίνακα ακεραίων έξι θέσεων, που
θα περιέχει την
«επιθυμητή» εξάδα αριθμών, και θα υλοποιεί τις κάτωθι ενέργειες:
 Θα διαβάζει από τον παίκτη τους έξι διαφορετικούς αριθμούς που έχει
επιλέξει, και
 Θα εξάγει μήνυμα για το αν ο παίκτης έχει κερδίσει ή όχι και, σε
περίπτωση που έχει
κερδίσει, πόσους από τους αριθμούς που έχει επιλέξει ανήκουν στην
«επιθυμητή» εξάδα.

amyntikos programatismos arithmoi apo 1-49......

sas eyxaristw poly


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: epithymhth exada arithmwn
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 06 Ιαν 2013 07:18 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 06 Ιαν 2013 07:14 pm
Δημοσιεύσεις: 1
Τι ακριβώς αναζητάς να μάθεις?


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: epithymhth exada arithmwn
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 10 Ιαν 2013 09:46 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 05 Ιαν 2013 03:10 pm
Δημοσιεύσεις: 2
Δεν ειμαι καλός στη γραφή της γλώσσας(τώρα μαθαίνω), χριάζομαι βοήθεια από σας όπως, ποιά διαδικασία να επιλέξω, και πως να ξεκινάει αυτό το πρόγραμμα????????


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: epithymhth exada arithmwn
ΔημοσίευσηΔημοσιεύτηκε: Τετ 15 Μάιος 2013 06:14 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 10 Οκτ 2012 04:00 am
Δημοσιεύσεις: 7
Νομίζω ότι θέλει δουλειά η γραμμή 17 που δημιουργεί ψευδοτυχαίους αριθμούς. Αρκετοί αριθμοί μάλλον ΔΕΝ διαλέγονται ΠΟΤΕ από το πρόγραμμα. :( Πάντως αυτός είναι ο κώδικας σε γενικές γραμμές.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΕΠΙΘΥΜΗΤΗ_ΕΞΑΔΑ_ΑΡΙΘΜΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Χ[6],Κ,Α[6]
ΑΡΧΗ
  ΓΡΑΨΕ 'Θέστε 6 ακέραιους από το 1 ως και το 49'
  ΓΡΑΨΕ 'Για να κερδίσετε πρέπει να μαντέψετε τουλάχιστον 3 αριθμούς'
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'Δώστε τον αριθμό'
    Ι <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Ι=1 ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'Αριθμός εκτός ορίων προσπαθήστε ξανά'
      ΤΕΛΟΣ_ΑΝ
      ΔΙΑΒΑΣΕ Χ[Κ]
      Α[Κ] <-- ΣΤΡΟΓΓ(49/(ΤΥΧΑΙΟΣ(Χ[Κ])+1))
      Ι <-- 1
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ[Κ]>0 ΚΑΙ Χ[Κ]<50
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Λ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΝ Α[Κ]=Χ[Ι] ΤΟΤΕ
        Λ <-- Λ+1
        Κ <-- 6
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ''
  ΑΝ Λ>=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Κερδίσατε !'
    ΓΡΑΨΕ 'Μαντέψατε',Λ,'αριθμούς'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Χάσατε'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Peace to everyone, and - who knows ? - maybe one day ... civilization !!!" - Pat Condell


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters