Τώρα είναι Πέμ 18 Ιούλ 2019 04:28 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 9 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 11 Αύγ 2010 07:53 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 08 Αύγ 2010 04:11 pm
Δημοσιεύσεις: 8
Σε οσες εξισωσεις το δοκιμασα δουλεψε σωστα,αλλα για δοκιμαστο και εσεις γιατι οι εξισωσεις ειναι απειρες........ :mrgreen:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΕΞΙΣΩΣΕΙΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: λ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ,χ,χ1,χ2,π,μ,Δ,α1,α2,ξ
ΑΡΧΗ
  π <-- 1
  όσο π=1  ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1 ΓΙΑ ΠΡΩΤΟΒΑΘΜΙΑ ΕΞΙΣΩΣΗ Ή 2 ΓΙΑ ΔΕΥΤΕΡΟΒΑΘΜΙΑ'
    ΔΙΑΒΑΣΕ λ
    ΑΝ  λ=1 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
      ΔΙΑΒΑΣΕ α
      ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΑΘΕΡΟ ΟΡΟ'
      ΔΙΑΒΑΣΕ β
      χ <-- β/α
      ΓΡΑΨΕ 'χ='
    ΑΛΛΙΩΣ_ΑΝ  Λ=2 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ^2'
      ΔΙΑΒΑΣΕ α
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
      ΔΙΑΒΑΣΕ β
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΤΑΘΕΡΟ ΟΡΟ'
      ΔΙΑΒΑΣΕ γ
      Δ <-- β^2-4*α*γ
      ΑΝ  Δ>0 ΤΟΤΕ
        χ1 <-- (-β+Τ_Ρ(Δ))/(2*α)
        χ2 <-- (-β-Τ_Ρ(Δ))/(2*α)
        ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΡΙΖΕΣ ΤΗΝ χ=',χ1,'Ή ΤΗΝ χ=',χ2,'ΜΕ Δ=',Δ,'S=',χ1+χ2,'ΚΑΙ P=',χ1*χ2
      ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
        χ <-- -β/(2*α)
        ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΔΙΠΛΗ ΡΙΖΑ ΤΗΝ χ=',χ,'ΜΕ Δ=',Δ,'S=',2*χ,'ΚΑΙ P=',χ^2
      ΑΛΛΙΩΣ
        α1 <-- -β/2*α
        α2 <-- Τ_Ρ(-Δ)/2*α
        ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΜΙΓΑΔΙΚΕΣ ΡΙΖΕΣ ΤΗΝ ζ1=',α1,'+',α2,'i','και την ζ2=',α1,'-',α2,'i ΜΕ Δ=',Δ,'S=',2*α1,'ΚΑΙ P=',(α1^2)+(α2^2)
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ξ <-- 1
    ΟΣΟ ξ=1  ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ Ή 2 ΓΙΑ ΣΥΝΕΧΕΙΑ'
      ΔΙΑΒΑΣΕ μ
      ΑΝ μ=2 τότε
        π <-- 1
        ξ <-- 2
      ΑΛΛΙΩΣ_ΑΝ μ=1 τότε
        π <-- 2
        ξ <-- 2
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΛΑΘΟΣ ΕΝΤΟΛΗ'
        ξ <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' kotsarikos ΑΠΟ 1ο ΛΥΚΕΙΟ ΚΗΦΙΣΙΑΣ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ   ΕΞΙΣΩΣΕΙΣ


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Αύγ 2010 05:55 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
καλό θα ήταν να ελέγχεις τα α να είναι διάφορα του 0 (ίσως και να συνεχίζει κατάλληλα , δηλαδή να λύνει πρωτοβάθμια αν είναι στην δευτεροβάθμια το α είναι 0 και να λέει αν είναι αδύνατη ή μη αν είναι πρωτοβάθμια), για να μην πετάει σφάλμα, άλλωστε μην ξεχνάς ότι δεν ξέρεις τι γνώσεις ή τι διάθεση έχει ο χρήστης... :wink:

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 17 Αύγ 2010 11:26 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 08 Αύγ 2010 04:11 pm
Δημοσιεύσεις: 8
συμφωνα με τις συμβουλες του φιλου περικλη..... :D
Syntax: [ Download ] [ Hide ]
 
ΠΡΟΓΡΑΜΜΑ ΕΞΙΣΩΣΕΙΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: λ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ,χ,χ1,χ2,π,μ,Δ,α1,α2,ξ
ΑΡΧΗ
  π <-- 1
  όσο π=1  ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1 ΓΙΑ ΠΡΩΤΟΒΑΘΜΙΑ ΕΞΙΣΩΣΗ Ή 2 ΓΙΑ ΔΕΥΤΕΡΟΒΑΘΜΙΑ'
    ΔΙΑΒΑΣΕ λ
    ΑΝ  λ=1 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
      ΔΙΑΒΑΣΕ α
      ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΑΘΕΡΟ ΟΡΟ'
      ΔΙΑΒΑΣΕ β
      ΑΝ α=0 και β=0 τότε
        ΓΡΑΨΕ 'ΗΕΞΙΣΩΣΗ ΕΙΝΑΙ ΑΟΡΙΣΤΗ'
      ΑΛΛΙΩΣ_ΑΝ α=0 και β<>0 τότε
        ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ ΑΔΥΝΑΤΗ'
      ΑΛΛΙΩΣ
        χ <-- β/α
        ΓΡΑΨΕ 'χ='
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ  Λ=2 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ^2'
      ΔΙΑΒΑΣΕ α
      ΑΝ α=0 τότε
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
        ΔΙΑΒΑΣΕ β
        ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΑΘΕΡΟ ΟΡΟ'
        ΔΙΑΒΑΣΕ γ
        ΑΝ β=0 και γ=0 τότε
          ΓΡΑΨΕ 'ΗΕΞΙΣΩΣΗ ΕΙΝΑΙ ΑΟΡΙΣΤΗ'
        ΑΛΛΙΩΣ_ΑΝ β=0 και γ<>0 τότε
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ ΑΔΥΝΑΤΗ'
        ΑΛΛΙΩΣ
          χ <-- γ/β
          ΓΡΑΨΕ 'χ='
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
        ΔΙΑΒΑΣΕ β
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΤΑΘΕΡΟ ΟΡΟ'
        ΔΙΑΒΑΣΕ γ
        Δ <-- β^2-4*α*γ
        ΑΝ  Δ>0 ΤΟΤΕ
          χ1 <-- (-β+Τ_Ρ(Δ))/(2*α)
          χ2 <-- (-β-Τ_Ρ(Δ))/(2*α)
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΡΙΖΕΣ ΤΗΝ χ=',χ1,'Ή ΤΗΝ χ=',χ2,'ΜΕ Δ=',Δ,'S=',χ1+χ2,'ΚΑΙ P=',χ1*χ2
        ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
          χ <-- -β/(2*α)
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΔΙΠΛΗ ΡΙΖΑ ΤΗΝ χ=',χ,'ΜΕ Δ=',Δ,'S=',2*χ,'ΚΑΙ P=',χ^2
        ΑΛΛΙΩΣ
          α1 <-- -β/2*α
          α2 <-- Τ_Ρ(-Δ)/2*α
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΜΙΓΑΔΙΚΕΣ ΡΙΖΕΣ ΤΗΝ ζ1=',α1,'+',α2,'i','και την ζ2=',α1,'-',α2,'i ΜΕ Δ=',Δ,'S=',2*α1,'ΚΑΙ P=',(α1^2)+(α2^2)
        ΑΛΛΙΩΣ
          ΓΡΑΨΕ   'ΛΑΘΟΣ ΕΝΤΟΛΗ'
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ξ <-- 1
    ΟΣΟ ξ=1  ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ Ή 2 ΓΙΑ ΣΥΝΕΧΕΙΑ'
      ΔΙΑΒΑΣΕ μ
      ΑΝ μ=2 τότε
        π <-- 1
        ξ <-- 2
      ΑΛΛΙΩΣ_ΑΝ μ=1 τότε
        π <-- 2
        ξ <-- 2
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΛΑΘΟΣ ΕΝΤΟΛΗ'
        ξ <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' kotsarikos ΑΠΟ 1ο ΛΥΚΕΙΟ ΚΗΦΙΣΙΑΣ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ   ΕΞΙΣΩΣΕΙΣ


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Αύγ 2010 06:26 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Κώδικας:
        ΑΝ  Δ>0 ΤΟΤΕ
          χ1 <-- (-β+Τ_Ρ(Δ))/(2*α)
          χ2 <-- (-β-Τ_Ρ(Δ))/(2*α)
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΡΙΖΕΣ ΤΗΝ χ=',χ1,'Ή ΤΗΝ χ=',χ2,'ΜΕ Δ=',Δ,'S=',χ1+χ2,'ΚΑΙ P=',χ1*χ2
        ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
          χ <-- -β/(2*α)
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΔΙΠΛΗ ΡΙΖΑ ΤΗΝ χ=',χ,'ΜΕ Δ=',Δ,'S=',2*χ,'ΚΑΙ P=',χ^2
        ΑΛΛΙΩΣ
          α1 <-- -β/2*α
          α2 <-- Τ_Ρ(-Δ)/2*α
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΜΙΓΑΔΙΚΕΣ ΡΙΖΕΣ ΤΗΝ ζ1=',α1,'+',α2,'i','και την ζ2=',α1,'-',α2,'i ΜΕ Δ=',Δ,'S=',2*α1,'ΚΑΙ P=',(α1^2)+(α2^2)
        ΑΛΛΙΩΣ
          ΓΡΑΨΕ   'ΛΑΘΟΣ ΕΝΤΟΛΗ'
        ΤΕΛΟΣ_ΑΝ

:shock: :? αυτό, νομίζω, δεν θα έπρεπε να το επιτρέπει η γλωσσομάθεια... είναι συντακτικό σφάλμα ... δεν επιτρέπονται 2 εντολές ΑΛΛΙΩΣ στην ίδια ΑΝ (για να μην γίνει παρανόηση, δεν εννοώ και τις ΑΛΛΙΩΣ_ΑΝ).

επίσης οι λύσεις στην πρωτοβάθμια της μορφής αχ+β=0 με α<>0 είναι χ=-β/α και όχι χ=β/α.

ΥΓ. για να γίνετε πιο εύκολα κατανοητός ο αλγόριθμος και να μπορείς να τον διορθώσεις πιο εύκολα θα ήταν καλώ όταν έχεις σειρές εντολών που εκτελούν το ίδιο πράγμα (όπως η επίλυση της πρωτοβάθμιας εδώ) να της βάζεις σε μια διαδικασία και να καλείς εκείνη όπου χρειάζεται (π.χ. Πρωτοβάθμια(α, β) , κάλεσε Πρωτοβάθμια(β, γ) )

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Αύγ 2010 03:58 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
periklis93 έγραψε:
:shock: :? αυτό, νομίζω, δεν θα έπρεπε να το επιτρέπει η γλωσσομάθεια... είναι συντακτικό σφάλμα ... δεν επιτρέπονται 2 εντολές ΑΛΛΙΩΣ στην ίδια ΑΝ (για να μην γίνει παρανόηση, δεν εννοώ και τις ΑΛΛΙΩΣ_ΑΝ).

Αυτό το λάθος έχει διορθωθεί στη νέα έκδοση 9.2.1 ώστε να εμφανίζεται σχετικό μήνυμα σφάλματος.
Σελίδα λήψης:
http://spinet.gr/glossomatheia/download

Ευχαριστώ για την επισήμανση.


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Αύγ 2010 06:20 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 08 Αύγ 2010 04:11 pm
Δημοσιεύσεις: 8
periklis93 έγραψε:

:shock: :? αυτό, νομίζω, δεν θα έπρεπε να το επιτρέπει η γλωσσομάθεια... είναι συντακτικό σφάλμα ... δεν επιτρέπονται 2 εντολές ΑΛΛΙΩΣ στην ίδια ΑΝ (για να μην γίνει παρανόηση, δεν εννοώ και τις ΑΛΛΙΩΣ_ΑΝ).


χμμμμ ναι :roll: δοκιμαζα κατι πιο πριν και ξεχασα μετα να το σβησω :mrgreen:

periklis93 έγραψε:

ΥΓ. για να γίνετε πιο εύκολα κατανοητός ο αλγόριθμος και να μπορείς να τον διορθώσεις πιο εύκολα θα ήταν καλώ όταν έχεις σειρές εντολών που εκτελούν το ίδιο πράγμα (όπως η επίλυση της πρωτοβάθμιας εδώ) να της βάζεις σε μια διαδικασία και να καλείς εκείνη όπου χρειάζεται (π.χ. Πρωτοβάθμια(α, β) , κάλεσε Πρωτοβάθμια(β, γ) )


επειδη μονο ενα μηνα εχω κανει μαθηματα πανω στον προγραμματισμο και δεν ξερω και πολλα αυτο με τη διαδικασια που ειπες το εψαξα και κατι καταφερα ελπιζω να δουλευει σωστα....
Κώδικας:
ΠΡΟΓΡΑΜΜΑ ΕΞΙΣΩΣΕΙΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: λ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ,χ,χ1,χ2,π,μ,Δ,α1,α2,ξ
ΑΡΧΗ
  π <-- 1
  όσο π=1  ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1 ΓΙΑ ΠΡΩΤΟΒΑΘΜΙΑ ΕΞΙΣΩΣΗ Ή 2 ΓΙΑ ΔΕΥΤΕΡΟΒΑΘΜΙΑ'
    ΔΙΑΒΑΣΕ λ
    ΑΝ  λ=1 ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΩΤΟΒΑΘΜΙΑ(α,β)

    ΑΛΛΙΩΣ_ΑΝ  Λ=2 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ^2'
      ΔΙΑΒΑΣΕ α 
      ΑΝ α=0 τότε
        ΚΑΛΕΣΕ ΠΡΩΤΟΒΑΘΜΙΑ(α,β)
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
        ΔΙΑΒΑΣΕ β
        ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΑΘΕΡΟ ΟΡΟ'
        ΔΙΑΒΑΣΕ γ     
        Δ <-- β^2-4*α*γ
        ΑΝ  Δ>0 ΤΟΤΕ
          χ1 <-- (-β+Τ_Ρ(Δ))/(2*α)
          χ2 <-- (-β-Τ_Ρ(Δ))/(2*α)
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΡΙΖΕΣ ΤΗΝ χ=',χ1,'Ή ΤΗΝ χ=',χ2,'ΜΕ Δ=',Δ,'S=',χ1+χ2,'ΚΑΙ P=',χ1*χ2
        ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
          χ <-- -β/(2*α)
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΔΙΠΛΗ ΡΙΖΑ ΤΗΝ χ=',χ,'ΜΕ Δ=',Δ,'S=',2*χ,'ΚΑΙ P=',χ^2
        ΑΛΛΙΩΣ
          α1 <-- -β/2*α
          α2 <-- Τ_Ρ(-Δ)/2*α
          ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΜΙΓΑΔΙΚΕΣ ΡΙΖΕΣ ΤΗΝ ζ1=',α1,'+',α2,'i','και την ζ2=',α1,'-',α2,'i ΜΕ Δ=',Δ,'S=',2*α1,'ΚΑΙ P=',(α1^2)+(α2^2)
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ξ <-- 1
    ΟΣΟ ξ=1  ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ Ή 2 ΓΙΑ ΣΥΝΕΧΕΙΑ'
      ΔΙΑΒΑΣΕ μ
      ΑΝ μ=2 τότε
        π <-- 1
        ξ <-- 2
      ΑΛΛΙΩΣ_ΑΝ μ=1 τότε
        π <-- 2
        ξ <-- 2
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΛΑΘΟΣ ΕΝΤΟΛΗ'
        ξ <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                               
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ   ΕΞΙΣΩΣΕΙΣ
ΔΙΑΔΙΚΑΣΙΑ ΠΡΩΤΟΒΑΘΜΙΑ(α,β)                     
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,χ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΑΘΕΡΟ ΟΡΟ'
  ΔΙΑΒΑΣΕ β
  ΑΝ α=0 και β=0 τότε
    ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ ΑΟΡΙΣΤΗ'
  ΑΛΛΙΩΣ_ΑΝ α=0 και β<>0 τότε
    ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ ΑΔΥΝΑΤΗ'
  ΑΛΛΙΩΣ
    χ <-- -β/α
    ΓΡΑΨΕ 'χ=',χ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ ΠΡΩΤΟΒΑΘΜΙΑ(α,β)


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 23 Αύγ 2010 12:34 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
SpiN έγραψε:
Αυτό το λάθος έχει διορθωθεί στη νέα έκδοση 9.2.1 ώστε να εμφανίζεται σχετικό μήνυμα σφάλματος.
Σελίδα λήψης:
http://spinet.gr/glossomatheia/download

Ευχαριστώ για την επισήμανση.

:oops: Συγνώμη, είχα μείνει στην 9.2, δεν είχα πάρει είδηση ότι βγήκε καινούργια έκδοση.
off-topic: Υπάρχει κάποιος τρόπος για να ενημερωνόμαστε για τις καινούργιες εκδόσεις ?

kotsarikos έγραψε:
επειδη μονο ενα μηνα εχω κανει μαθηματα πανω στον προγραμματισμο και δεν ξερω και πολλα αυτο με τη διαδικασια που ειπες το εψαξα και κατι καταφερα ελπιζω να δουλευει σωστα....


Οι 2 παράμετροι ( ΠΡΩΤΟΒΑΘΜΙΑ(α,β) ) στην Διαδικασία δεν είναι απαραίτητοι, μπορείς να τους αφαιρέσεις (αλλά φυσικά όχι και από τις μεταβλητές της διαδικασίας). Εγώ τους είχα αναφέρει απλώς επειδή σκεφτόμουν να ζητάς στο κύριο μέρος τους συντελεστές και να τους περνάς στην πρωτοβάθμια αλλά ο τρόπος που διάλεξες είναι καλύτερος.

Κώδικας:
          α1 <-- -β/2*α
          α2 <-- Τ_Ρ(-Δ)/2*α

Στις γραμμές 32, 33 οι παρενθέσεις στους παρανομαστές δεν μπορούν να παραληφθούν γιατί έτσι είναι σαν να γράφεις :
Κώδικας:
          α1 <-- -(β/2)*α
          α2 <-- (Τ_Ρ(-Δ)/2)*α

κάτι με το οποίο δεν θα συμφωνούσε ένας μαθηματικός :P
(υπενθυμίζω ότι οι μαθηματικές πράξεις ίσης προτεραιότητας γίνονται με την σειρά που της συναντάμε από τα αριστερά προς τα δεξιά)

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 24 Αύγ 2010 12:09 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
periklis93 έγραψε:
:oops: Συγνώμη, είχα μείνει στην 9.2, δεν είχα πάρει είδηση ότι βγήκε καινούργια έκδοση.
off-topic: Υπάρχει κάποιος τρόπος για να ενημερωνόμαστε για τις καινούργιες εκδόσεις ?

Περικλή δεν το είχες πάρει είδηση γιατί η έκδοση 9.2.1 (που διορθώνει το λάθος με τις πολλές ΑΛΛΙΩΣ) βγήκε τώρα.
Η τρέχουσα έκδοση θα φαίνεται πάντα στη σελίδα λήψης.


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 24 Αύγ 2010 05:42 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
SpiN έγραψε:
Περικλή δεν το είχες πάρει είδηση γιατί η έκδοση 9.2.1 (που διορθώνει το λάθος με τις πολλές ΑΛΛΙΩΣ) βγήκε τώρα.
Η τρέχουσα έκδοση θα φαίνεται πάντα στη σελίδα λήψης.

Βασικά εννοούσα αν υπάρχει κάποιο rss ή κάτι αντίστοιχο με την παρακολούθηση θέματος που υπάρχει εδώ (στο ασκησιολόγιο) για να μας ενημερώνει πότε υπάρχουν νέες απαντήσεις , αλλά να μας ενημερώνει όταν βγαίνουν καινούργιες εκδόσεις ...

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 9 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters