Τώρα είναι Παρ 18 Οκτ 2019 02:00 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Η καλύτερη αριθμομηχανή !!
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Σεπ 2009 01:43 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 28 Σεπ 2009 01:37 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΑΘΗΜΑΤΙΚΟ_ΕΡΓΑΛΕΙΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : Α , Χ , Υ , Ω , Π , Ο, Φ, Γ, Ξ, Κ, Λ, Τ, ς, Ρ
ΑΡΧΗ
  Π <-- 1
  ΟΣΟ Π = 1 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1  ΓΙΑ ΠΡΟΣΘΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 2  ΓΙΑ ΑΦΕΡΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 3  ΓΙΑ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 4  ΓΙΑ ΔΙΕΡΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 5  ΓΙΑ ΑΡΙΘΜΟ ΣΤΟ ΤΕΤΡΑΓΩΝΟ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 6  ΓΙΑ ΑΡIΘΜΟ ΣΤΗΝ ΡΙΖΑ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 7  ΓΙΑ 1/x '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 8  ΓΙΑ ΤΡΙΓΩΝΟΜΕΤΡΙΚΟΥΣ ΑΡΙΘΜΟΥΣ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 9  ΓΙΑ ΕΞΙΣΩΣΕΙΣ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 10 ΓΙΑ ln ΤΟΥ Χ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 11 ΓΙΑ ΕΜΒΑΔΟΝ '
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α = 1 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΠΡΟΣΘΕΣΕΤΕ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ + Υ
      ΓΡΑΨΕ ' ΤΟ ΑΘΡΟΙΣΜΑ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΑΛΛΙΩΣ_ΑΝ Α = 2 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΑΦΕΡΕΣΕΤΕ ΜΕ ΣΩΣΤΗ ΣΕΙΡΑ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ - Υ
      ΓΡΑΨΕ ' Η ΔΙΑΦΟΡΑ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΑΛΛΙΩΣ_ΑΝ Α = 3 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΠΟΛΛΑΠΛΑΣΙΑΣΕΤΕ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ * Υ
      ΓΡΑΨΕ ' ΤΟ ΓΙΝΟΜΕΝΟ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΑΛΛΙΩΣ_ΑΝ Α = 4 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΔΙΕΡΕΣΕΤΕ ΜΕ ΣΩΣΤΗ ΣΕΙΡΑ '
      ΔΙΑΒΑΣΕ Χ , Υ
      ΑΝ Υ = 0 ΤΟΤΕ
        ΓΡΑΨΕ ' Η ΔΙΑΙΡΕΣΗ ΕΙΝΑΙ ΑΔΥΝΑΤΗ '
      ΑΛΛΙΩΣ_ΑΝ Υ <> 0 ΤΟΤΕ
        Ω <-- Χ / Υ
        ΓΡΑΨΕ ' ', Ω
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ Α = 5 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ ΣΤΟ ΤΕΤΡΑΓΩΝΟ '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- Χ ^ 2
      ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΣΤΟ ΤΕΤΡΑΓΩΝΟ ΕΙΝΑΙ ', Ω
    ΑΛΛΙΩΣ_ΑΝ Α = 6 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ ΣΤΗΝ ΡΙΖΑ '
      ΔΙΑΒΑΣΕ Χ
      ΑΝ Χ < 0 ΤΟΤΕ
        ΓΡΑΨΕ ' ΑΔΥΝΑΤΗ ΡΙΖΑ '
      ΑΛΛΙΩΣ_ΑΝ Χ >= 0 ΤΟΤΕ
        Ω <-- Τ_Ρ ( Χ )
        ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΣΤΗΝ ΡΙΖΑ ΕΙΝΑΙ ', Ω
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ Α = 7 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ 1/x '
      ΔΙΑΒΑΣΕ Χ
      ΑΝ Χ = 0 ΤΟΤΕ
        ΓΡΑΨΕ ' ΑΔΥΝΑΤΟ '
      ΑΛΛΙΩΣ_ΑΝ Χ <> 0 ΤΟΤΕ
        Ω <-- 1 / Χ
        ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΣΤΟ 1/x ΕΙΝΑΙ ', Ω
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ Α = 8 ΤΟΤΕ
      ΓΡΑΨΕ ' ΓΙΑ ΗΜΙΤΟΝΟ ΜΙΑΣ ΓΩΝΙΑΣ ΠΑΤΗΣΤΕ 1 '
      ΓΡΑΨΕ ' ΓΙΑ ΣΥΝΙΜΗΤΟΝΟ ΜΙΑΣ ΓΩΝΙΑΣ ΠΑΤΗΣΤΕ 2 '
      ΓΡΑΨΕ ' ΓΙΑ ΕΦΑΠΤΟΜΕΝΗ ΜΙΑΣ ΓΩΝΙΑΣ ΠΑΤΗΣΤΕ 3 '
      ΔΙΑΒΑΣΕ Ο
      ΑΝ Ο = 1 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΗΝ ΓΩΝΙΑ ΣΕ ΜΟΙΡΕΣ '
        ΔΙΑΒΑΣΕ Π
        Ρ <-- ΗΜ(Π)
        ΓΡΑΨΕ ' '
      ΑΛΛΙΩΣ_ΑΝ Ο = 2 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΗΝ ΓΩΝΙΑ ΣΕ ΜΟΙΡΕΣ '
        ΔΙΑΒΑΣΕ Π
        Ρ <-- ΣΥΝ(Π)
        ΓΡΑΨΕ ' ', Π
      ΑΛΛΙΩΣ_ΑΝ Ο = 3 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΗΝ ΓΩΝΙΑ ΣΕ ΜΟΙΡΕΣ '
        ΔΙΑΒΑΣΕ Π
        Ρ <-- ΕΦ(Π)
        ΓΡΑΨΕ ' ', Ρ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ Α = 9 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1 ΓΙΑ ΕΞΙΣΩΣΕΙΣ 1ου ΒΑΘΜΟΥ '
      ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 2 ΓΙΑ ΕΞΙΣΩΣΕΙΣ 2ου ΒΑΘΜΟΥ '
      ΔΙΑΒΑΣΕ ς
      ΑΝ ς = 1 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΜΕΤΑΒΛΗΤΗ ΤΟΥ χ '
        ΓΡΑΨΕ ' ΚΑΙ ΜΕΤΑ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ '
        ΔΙΑΒΑΣΕ Γ, Φ
        Ξ <-- - Φ / Γ
        ΓΡΑΨΕ ' ΤΟ χ ΕΙΝΑΙ ', Ξ
      ΑΛΛΙΩΣ_ΑΝ ς = 2 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΜΕΤΑΒΛΗΤΗ ΤΟΥ χ^2, '
        ΓΡΑΨΕ ' ΜΕΤΑ ΔΩΣΤΕ ΤΟΝ ΜΕΤΑΒΛΗΤΗ ΤΟΥ χ '
        ΓΡΑΨΕ ' ΚΑΙ ΤΕΛΟΣ ΔΩΣΤΕ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ '
        ΔΙΑΒΑΣΕ Γ, Φ, Τ
        Ρ <-- (Φ ^ 2) - (4 * Γ * Τ)
        ΑΝ Ρ < 0 ΤΟΤΕ
          ΓΡΑΨΕ ' Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ ΑΔΥΝΑΤΗ '
        ΑΛΛΙΩΣ_ΑΝ Ρ >= 0 ΤΟΤΕ
          Κ <-- ( - Φ + ( Τ_Ρ ( ( Φ ^ 2 ) - ( 4 * Γ * Τ ) ) ) ) / ( 2 * Γ )
          Λ <-- ( - Φ - ( Τ_Ρ ( ( Φ ^ 2 ) - ( 4 * Γ * Τ ) ) ) ) / ( 2 * Γ )
          ΓΡΑΨΕ ' ΤΟ χ ΕΙΝΑΙ ', Κ
          ΓΡΑΨΕ ' Ή ΤΟ χ ΕΙΝΑΙ ', Λ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ Α = 10 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΓΙΑ ln '
      ΔΙΑΒΑΣΕ Γ
      ΑΝ Γ <= 0 ΤΟΤΕ
        ΓΡΑΨΕ ' ΑΔΥΝΑΤΟ '
      ΑΛΛΙΩΣ_ΑΝ Γ > 0 ΤΟΤΕ
        Ξ <-- ΛΟΓ(Γ)
        ΓΡΑΨΕ ' ', Ξ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ Α = 11 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1 ΓΙΑ ΕΜΒΑΔΟΝ ΤΕΤΡΑΓΩΝΟΥ '
      ΓΡΑΨΕ '         2             ΤΡΙΓΩΝΟΥ '
      ΓΡΑΨΕ '         3             ΚΥΚΛΟΥ '
      ΓΡΑΨΕ '         4             ΤΡΑΠΕΖΙΟΥ '
      ΔΙΑΒΑΣΕ ς
      ΑΝ ς = 2 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΕ ΤΟ ΥΨΟΣ ΚΑΙ ΤΗ ΒΑΣΗ '
        ΔΙΑΒΑΣΕ Γ, Π
        Ω <-- ( Γ * Π ) / 2
        ΓΡΑΨΕ ' ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ ', Ω
      ΑΛΛΙΩΣ_ΑΝ ς = 1 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΕ ΤΙΣ ΔΥΟ ΠΛΕΥΡΕΣ '
        ΔΙΑΒΑΣΕ Γ, Π
        Ω <-- Γ * Π
        ΓΡΑΨΕ ' ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ ', Ω
      ΑΛΛΙΩΣ_ΑΝ ς = 3 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΕ ΤΗΝ ΑΚΤΙΝΑ ΤΟΥ ΚΥΚΛΟΥ '
        ΔΙΑΒΑΣΕ Γ
        Ω <-- 3.14 * (Γ^2)
        ΓΡΑΨΕ ' ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ ', Ω
      ΑΛΛΙΩΣ_ΑΝ ς = 4 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΕ ΤΗ ΜΕΓΑΛΗ ΚΑΙ ΤΗΝ ΜΙΚΡΗ ΒΑΣΗ '
        ΔΙΑΒΑΣΕ Γ, Π
        ΓΡΑΨΕ ' ΤΩΡΑ ΔΩΣΤΕ ΤΟ ΥΨΟΣ '
        ΔΙΑΒΑΣΕ Ο
        Ω <-- (( Γ + Π ) * Ο ) /2
        ΓΡΑΨΕ ' ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ ', Ω
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 2 ΓΙΑ ΣΥΝΕΧΕΙΑ '
    ΓΡΑΨΕ '         1 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ '
    ΔΙΑΒΑΣΕ Ο
    ΑΝ Ο = 2 ΤΟΤΕ
      Π <-- 1
    ΑΛΛΙΩΣ_ΑΝ Ο = 1 ΤΟΤΕ
      Π <-- 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' BY : L. D. KOSTAS ΑΠΟ Γ ΛΥΚΕΙΟΥ ΡΟΔΟΛΙΒΟΥΣ '
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΑΘΗΜΑΤΙΚΟ_ΕΡΓΑΛΕΙΟ                      


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Η καλύτερη αριθμομηχανή !!
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Σεπ 2009 01:46 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 28 Σεπ 2009 01:37 pm
Δημοσιεύσεις: 2
Οποιεσδήποτε συμβουλές καθώς και ιδέες για την επόμενη "εκδοση" είναι δεκτές !! :)


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Η καλύτερη αριθμομηχανή !!
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Νοέμ 2009 07:13 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 21 Νοέμ 2009 07:11 pm
Δημοσιεύσεις: 2
Θα πρέπει να είναι ΔΙΑΙΡΕΣΗ και όχι ΔΙΕΡΕΣΗ.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters