Τώρα είναι Παρ 18 Οκτ 2019 09:40 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 14 Μαρ 2009 02:19 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 13 Μαρ 2009 08:55 pm
Δημοσιεύσεις: 2
Ένα απλό πρόγραμμα που εφτιαξα για τον υπολογισμό του Μέσου Όρου στα μαθήματα της Α' Γενικού Λυκείου, στην οποία και φητώ. Υπολογίζονται μόνο τα μαθήματα που επηρεάζουν το μέσο όρο.
(με βαθμό: Βϵ[1,20])

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  ΜΟ_μαθηματων_Α_γενικού_λυκείου
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΓΕΩ, ΑΛΓ, ΘΡΗ, ΑΡΧ, ΟΙΚ, ΦΥΣ, ΧΗΜ, ΑΓΓ, ΚΕΙ, ΓΛΩ, ΙΣΤ, ΤΕΧ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟ


ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε Όνομα Μαθητή:'
  ΔΙΑΒΑΣΕ ΟΝΟ

  ΓΡΑΨΕ 'Δώσε βαθμό Θρησκευτικών:'
  ΔΙΑΒΑΣΕ ΘΡΗ



  ΟΣΟ ΘΡΗ>20  ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν θα πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό θρησκευτικών: (<=20)'
    ΔΙΑΒΑΣΕ ΘΡΗ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό Αρχαίων:'
  ΔΙΑΒΑΣΕ ΑΡΧ

  ΟΣΟ ΑΡΧ>20  ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό θρησκευτικών: (<=20)'
    ΔΙΑΒΑΣΕ ΑΡΧ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



  ΓΡΑΨΕ 'Δώσε βαθμό Λογοτεχνίας:'
  ΔΙΑΒΑΣΕ ΚΕΙ
  ΟΣΟ ΚΕΙ>20 ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό Λογοτεχνίας: (<=20)'
    ΔΙΑΒΑΣΕ ΚΕΙ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ




  ΓΡΑΨΕ 'Δώσε βαθμό Νεοελληνικής Γλώσσας:'
  ΔΙΑΒΑΣΕ ΓΛΩ
  ΟΣΟ ΓΛΩ>20 ΕΠΑΝΑΛΑΒΕ
    Γραψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό Νεοελληνικής Γλώσσας: (<=20)'
    ΔΙΑΒΑΣΕ ΓΛΩ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό Ιστορίας:'
  ΔΙΑΒΑΣΕ ΙΣΤ
  ΟΣΟ ΙΣΤ>20 ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό Ιστορίας: (<=20)'
    ΔΙΑΒΑΣΕ ΙΣΤ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε βαθμό Άλγεβρας:'
  ΔΙΑΒΑΣΕ ΑΛΓ
  όσο ΑΛΓ>20 επαναλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό Άλγερβας: (<=20)'
    διάβασε ΑΛΓ
  τέλος_επανάληψης


  ΓΡΑΨΕ 'Δώσε βαθμό Γεωμετρίας:'
  ΔΙΑΒΑΣΕ ΓΕΩ
  όσο ΓΕΩ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό Γεωμετρίας: (<=20)'
    Διαβασε ΓΕΩ
  τέλος_επανάληψης



  ΓΡΑΨΕ 'Δώσε βαθμό Φυσικής:'
  ΔΙΑΒΑΣΕ ΦΥΣ
  όσο ΦΥΣ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό Φυσικής: (<=20)'
    Διαβασε ΦΥΣ
  τελος_επαναληψης



  ΓΡΑΨΕ 'Δώσε βαθμό Χημείας:'
  ΔΙΑΒΑΣΕ ΧΗΜ
  όσο ΧΗΜ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό Χημείας: (<=20)'
    διάβασε ΧΗΜ
  τελος_επαναληψης



  ΓΡΑΨΕ 'Δώσε βαθμό Οικονομίας:'
  ΔΙΑΒΑΣΕ ΟΙΚ
  όσο ΟΙΚ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνάει το 20'
    γράψε 'Δώσε βαθμό Οικονομίας: (<=20)'
    διάβασε ΟΙΚ
  τελος_επαναληψης




  ΓΡΑΨΕ 'Δώσε βαθμό Τεχνολογίας:'
  ΔΙΑΒΑΣΕ ΤΕΧ
  όσο ΤΕΧ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό Τεχνολογίας: (<=20)'
    διάβασε ΤΕΧ
  τελος_επαναληψης




  ΓΡΑΨΕ 'Δώσε βαθμό Αγγλικών:'
  ΔΙΑΒΑΣΕ ΑΓΓ
  όσο ΑΓΓ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό Αγγλικών: (<=20)'
    διάβασε ΑΓΓ
  τελος_επαναληψης


  ΓΡΑΨΕ 'Ο Μέσος Όρος του μαθητή', ΟΝΟ,'είναι:', (ΘΡΗ+ΑΡΧ+ΚΕΙ+ΓΛΩ+ΙΣΤ+ΑΛΓ+ΓΕΩ+ΦΥΣ+ΧΗΜ+ΟΙΚ+ΤΕΧ+ΑΓΓ)/12
  ΑΝ (ΘΡΗ+ΑΡΧ+ΚΕΙ+ΓΛΩ+ΙΣΤ+ΑΛΓ+ΓΕΩ+ΦΥΣ+ΧΗΜ+ΟΙΚ+ΤΕΧ+ΑΓΓ)/12<9.5 ΤΟΤΕ
    ΓΡΑΨΕ 'Ο μαθητής', ΟΝΟ,'ΑΠΟΡΡΙΠΤΕΤΑΙ'
  ΑΛΛΙΩΣ_ΑΝ (ΘΡΗ+ΑΡΧ+ΚΕΙ+ΓΛΩ+ΙΣΤ+ΑΛΓ+ΓΕΩ+ΦΥΣ+ΧΗΜ+ΟΙΚ+ΤΕΧ+ΑΓΓ)/12>=9.5 ΤΟΤΕ
    ΓΡΑΨΕ 'Ο μαθητής', ΟΝΟ,'ΠΡΟΑΓΕΤΑΙ'
  ΤΕΛΟΣ_ΑΝ
 ΓΡΑΨΕ 'leonidasmark@gmail.com'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΟ_μαθηματων_Α_γενικού_λυκείου


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Νοέμ 2009 08:08 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 21 Νοέμ 2009 07:11 pm
Δημοσιεύσεις: 2
Έκανα κάποιες μετατροπές για τη Β'Λυκείου Τεχνολογικής κατεύθυνσης καθώς επίσης διόρθωσα κάποια ορθογραφικά και συντακτικά λάθη.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  ΜΟ_μαθηματων_Β_γενικού_λυκείου
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΜΑΘ, ΑΛΓ, ΘΡΗ, ΑΝΤ, ΔΙΚ, ΦΥΣ, ΦΥΣΚ, ΑΓΓ, ΚΕΙ, ΓΛΩ, ΙΣΤ, ΤΕΧ, ΒΙΟ, ΑΣΤ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟ


ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε Όνομα Μαθητή:'
  ΔΙΑΒΑΣΕ ΟΝΟ

  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Θρησκευτικών:'
  ΔΙΑΒΑΣΕ ΘΡΗ



  ΟΣΟ ΘΡΗ>20  ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν θα πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος θρησκευτικών: (<=20)'
    ΔΙΑΒΑΣΕ ΘΡΗ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Αντιγόνης:'
  ΔΙΑΒΑΣΕ ΑΝΤ

  ΟΣΟ ΑΝΤ>20  ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Αντιγόνης: (<=20)'
    ΔΙΑΒΑΣΕ ΑΝΤ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Λογοτεχνίας:'
  ΔΙΑΒΑΣΕ ΚΕΙ
  ΟΣΟ ΚΕΙ>20 ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Λογοτεχνίας: (<=20)'
    ΔΙΑΒΑΣΕ ΚΕΙ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ




  ΓΡΑΨΕ 'Δώσε βαθμό Νεοελληνικής Γλώσσας (Έκθεσης):'
  ΔΙΑΒΑΣΕ ΓΛΩ
  ΟΣΟ ΓΛΩ>20 ΕΠΑΝΑΛΑΒΕ
    Γραψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Νεοελληνικής Γλώσσας (Έκθεσης): (<=20)'
    ΔΙΑΒΑΣΕ ΓΛΩ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Ιστορίας:'
  ΔΙΑΒΑΣΕ ΙΣΤ
  ΟΣΟ ΙΣΤ>20 ΕΠΑΝΑΛΑΒΕ
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Ιστορίας: (<=20)'
    ΔΙΑΒΑΣΕ ΙΣΤ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Άλγεβρας:'
  ΔΙΑΒΑΣΕ ΑΛΓ
  όσο ΑΛΓ>20 επαναλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Άλγεβρας: (<=20)'
    διάβασε ΑΛΓ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Μαθηματικών (Κατεύθυνσης):'
  ΔΙΑΒΑΣΕ ΜΑΘ
  όσο ΜΑΘ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Μαθηματικών (Κατεύθυνσης): (<=20)'
    Διαβασε ΜΑΘ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Φυσικής (Γενικής Παιδείας):'
  ΔΙΑΒΑΣΕ ΦΥΣ
  όσο ΦΥΣ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Φυσικής (Γενικής Παιδείας): (<=20)'
    Διαβασε ΦΥΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Φυσικής (Κατεύθυνσης):'
  ΔΙΑΒΑΣΕ ΦΥΣΚ
  όσο ΦΥΣΚ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Φυσικής (Κατεύθυνσης): (<=20)'
    διάβασε ΦΥΣΚ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Δικαίου:'
  ΔΙΑΒΑΣΕ ΔΙΚ
  όσο ΔΙΚ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνάει το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Δικαίου: (<=20)'
    διάβασε ΔΙΚ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Τεχνολογίας Επικοινωνιών:'
  ΔΙΑΒΑΣΕ ΤΕΧ
  όσο ΤΕΧ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Τεχνολογίας Επικοινωνιών: (<=20)'
    διάβασε ΤΕΧ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Βιολογίας:'
  ΔΙΑΒΑΣΕ ΒΙΟ
  όσο ΒΙΟ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Βιολογίας: (<=20)'
    διάβασε ΒΙΟ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Αστρονομίας:'
  ΔΙΑΒΑΣΕ ΑΣΤ
  όσο ΑΣΤ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Αστρονομίας: (<=20)'
    διάβασε ΑΣΤ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε βαθμό διαγωνίσματος Αγγλικών:'
  ΔΙΑΒΑΣΕ ΑΓΓ
  όσο ΑΓΓ>20 επανάλαβε
    γράψε 'Ο βαθμός δεν πρέπει να ξεπερνά το 20'
    γράψε 'Δώσε βαθμό διαγωνίσματος Αγγλικών: (<=20)'
    διάβασε ΑΓΓ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



  ΓΡΑΨΕ 'Ο Μέσος Όρος του μαθητή', ΟΝΟ,'είναι:', (ΘΡΗ+ΑΝΤ+ΚΕΙ+ΓΛΩ+ΙΣΤ+ΑΛΓ+ΜΑΘ+ΦΥΣ+ΦΥΣΚ+ΒΙΟ+ΔΙΚ+ΤΕΧ+ΑΓΓ+ΑΣΤ)/14
  ΑΝ (ΘΡΗ+ΑΝΤ+ΚΕΙ+ΓΛΩ+ΙΣΤ+ΑΛΓ+ΜΑΘ+ΦΥΣ+ΦΥΣΚ+ΔΙΚ+ΤΕΧ+ΑΓΓ+ΒΙΟ+ΑΣΤ)/14<10 ΤΟΤΕ
    ΓΡΑΨΕ 'Ο μαθητής', ΟΝΟ,'ΑΠΟΡΡΙΠΤΕΤΑΙ'
  ΑΛΛΙΩΣ_ΑΝ (ΘΡΗ+ΑΝΤ+ΚΕΙ+ΓΛΩ+ΙΣΤ+ΑΛΓ+ΜΑΘ+ΦΥΣ+ΦΥΣΚ+ΔΙΚ+ΤΕΧ+ΑΓΓ+ΒΙΟ+ΑΣΤ)/14>=10 ΤΟΤΕ
    ΓΡΑΨΕ 'Ο μαθητής', ΟΝΟ,'ΠΡΟΑΓΕΤΑΙ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'leonidasmark@gmail.com'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΟ_μαθηματων_Β_γενικού_λυκείου


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters