Τώρα είναι Παρ 18 Οκτ 2019 09:44 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΤΟ ΩΡΟΣΚΟΠΙΟ ΤΩΝ ΜΕΤΑΛΛΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 15 Μάιος 2003 04:50 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Πρέβεζα
Χωρίς Σχόλια
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΤΖΙΝΙ_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  ΕΤΟΣ, ΜΗΝΑ ,ΜΕΡΑ,Ι, ΣΟΥΜΑ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΤΟ ΩΡΟΣΚΟΠΙΟ ΤΩΝ ΜΕΤΑΛΛΩΝ'
  ΓΡΑΨΕ 'Βασισμένο στην ESPRESSO Πέμπτη 15 Μαϊου 2003, Σελ 20,21'
  ΓΡΑΨΕ '----------------------------------------------------------'
  ΓΡΑΨΕ 'ΠΡΩΤΑ ΘΑ ΥΠΟΛΟΓΙΣΩ ΤΟΝ ΠΡΟΣΩΠΙΚΟ ΣΟΥ ΑΡΙΘΜΟ'
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΕΤΟΣ ΓΕΝΝΗΣΗΣ ΣΟΥ Π.Χ. 1901'
  ΔΙΑΒΑΣΕ ΕΤΟΣ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤOΝ ΜΗΝΑ ΓΕΝΝΗΣΗΣ ΣΟΥ Π.Χ. 12'
  ΔΙΑΒΑΣΕ ΜΗΝΑ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΗΝ ΗΜΕΡΑ ΓΕΝΝΗΣΗΣ ΣΟΥ'
  ΔΙΑΒΑΣΕ ΜΕΡΑ
  ΓΡΑΨΕ 'ΕΛΠΙΖΩ ΝΑ ΤΑ ΕΓΡΑΨΕΣ ΣΩΣΤΑ! ',ΜΕΡΑ,'-',ΜΗΝΑ,'-',ΕΤΟΣ
  Ι <-- ΣΟΥΜΑ+1
  ΟΣΟ Ι<>ΣΟΥΜΑ ΕΠΑΝΑΛΑΒΕ
    Ι <-- ΣΟΥΜΑ
    ΣΟΥΜΑ <-- ΣΟΥΜΑ + ΕΤΟΣ MOD 10+ΜΗΝΑ MOD 10+ΜΕΡΑ MOD 10
    ΕΤΟΣ <-- ΕΤΟΣ DIV 10
    ΜΗΝΑ <-- ΜΗΝΑ DIV 10
    ΜΕΡΑ <-- ΜΕΡΑ DIV 10
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΟΣΟ ΣΟΥΜΑ>9 ΕΠΑΝΑΛΑΒΕ
    Ι <-- ΣΟΥΜΑ
    ΣΟΥΜΑ <-- 0
    ΟΣΟ Ι>0 ΕΠΑΝΑΛΑΒΕ
      ΣΟΥΜΑ <-- ΣΟΥΜΑ+Ι MOD 10
      Ι <-- Ι DIV 10
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΤΟ ΜΕΤΑΛΟ ΣΟΥ ΕΙΝΑΙ '
  ΕΠΙΛΕΞΕ ΣΟΥΜΑ
    ΠΕΡΙΠΤΩΣΗ 1
      ΓΡΑΨΕ 'ΧΡΥΣΟΣ'
    ΠΕΡΙΠΤΩΣΗ 2
      ΓΡΑΨΕ 'ΑΣΗΜΙ'
    ΠΕΡΙΠΤΩΣΗ 3
      ΓΡΑΨΕ 'ΥΔΡΑΡΓΥΡΟΣ'
    ΠΕΡΙΠΤΩΣΗ 4
      ΓΡΑΨΕ 'ΧΑΛΚΟΣ'
    ΠΕΡΙΠΤΩΣΗ 5
      ΓΡΑΨΕ 'ΣΙΔΗΡΟΣ'
    ΠΕΡΙΠΤΩΣΗ 6
      ΓΡΑΨΕ 'ΚΑΣΣΙΤΕΡΟΣ'
    ΠΕΡΙΠΤΩΣΗ 7
      ΓΡΑΨΕ 'ΜΟΛΥΒΔΟΣ'
    ΠΕΡΙΠΤΩΣΗ 8
      ΓΡΑΨΕ 'ΝΙΚΕΛΙΟ'
    ΠΕΡΙΠΤΩΣΗ 9
      ΓΡΑΨΕ 'ΠΛΑΤΙΝΑ'
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
  ΓΡΑΨΕ 'ΠΕΡΙΣΣΟΤΕΡΑ ΣΤΗΝ ΕΦΗΜΕΡΙΔΑ......'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 19 Ιουν 2006 01:08 pm 
ΒΑΖΟΥΜΕ ΚΑΙ ΚΑΜΙΑ ΕΚΦΩΝΗΣΗ....ΝΑ ΚΑΤΑΛΑΒΑΙΝΟΥΜΕ ΚΑΙ ΕΜΕΙΣ ΟΙ ΜΑΘΗΤΕΣ ΤΑΞΕΩΝ ΚΑΤΩ ΤΗΣ 3ΗΣ ΛΥΚΕΙΟΥ....


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 19 Ιουν 2006 05:33 pm 
Αν καταφέρεις να το "διαβάσεις" θα είσαι περισσότερο κερδισμένος.

Ουσιαστικά το πρόγραμμα περιγράφει έναν τρόπο πρόσθεσης ψηφίων ημερομηνιών, όπου το 1996 π.χ. δίνει 1+9+9+6=25...= 2+5=7 με χρήση των MOD (ακαίρεο υπόλοιπο) και DIV (ακέραια διαίρεση).
Στο πρώτο ΟΣΟ η προηγούμενη ΣΟΥΜΑ (στο Ι) θα γίνει ίση με την τελευταία ΣΟΥΜΑ όταν τα ΕΤΟΣ, ΜΗΝΑ, ΜΕΡΑ γίνουν 0.
Στο δεύτερο ΟΣΟ (δυο φωλιασμένα ΟΣΟ), όσο η προηγούμενη ΣΟΥΜΑ (το Ι) δεν είναι 0 (είναι δηλαδή μεγαλύτερο από 0) τότε προσθέτουμε το πρώτο ψηφιό από δεξιά (π.χ. από Ι=12, το 2 το προσθέτουμε στη ΣΟΥΜΑ, και αφήνουμε το Ι=1). Συνεχίζουμε όσο το Ι είναι μεγαλύτερο από 0.
Το εξωτερικό ΟΣΟ, είναι και το πιο μυστήριο....εκεί έχουμε το Ι να δέχεται την τιμή ΣΟΥΜΑ, και το ΣΟΥΜΑ να μηδενίζει. έτσι υποχρεωτικά θα μπούμε στο δεύτερο και θα προστεθούν όλα τα ψηφία μέχρι το Ι να αδειάσει (να μηδενίσει). Όσο παραμένει το ΣΟΥΜΑ μεγαλύτερο του 9 θα συνεχίζουμε την ίδια τακτική. Θα είχαμε πρόβλημα αν η κάθε νέα ΣΟΥΜΑ βγάζει μεγαλύτερο αριθμό από τη προηγούμενη, αλλά αυτό δεν γίνεται...π.χ. το 19 γίνεται 10 και μετά 1, ή το 1999 γίνεται 28, μετά 10, μετά 1. Πάντα δηλαδή θα έχουμε μείωση αριθμών, άρα θα τερματίζει το ΟΣΟ.

Στο τέλος έχουμε μια "ελεγχόμενη" ΓΡΑΨΕ, από μια δομή ΕΠΙΛΕΞΕ, με μεταβήτή ελέγχου τη ΣΟΥΜΑ (που θα είναι μεταξύ 1 και 9).

Η μόνη περίπτωση να μην δώσει απάντηση το πρόγραμμα είναι να δώσουμε μηδενικές τιμές, οπότε το πρώτο ΟΣΟ δίνει ΣΟΥΜΑ=0, το δεύτερο ΟΣΟ δεν θα γίνει. το ΕΠΙΛΕΞΕ δεν θα δώσει ΓΡΑΨΕ.
Επειδή θέλουμε να περάσει η ροή του προγράμματος από το πρώτο ΟΣΟ, ώστε τα ΕΤΟΣ, ΜΗΝΑ, ΜΕΡΑ να χρησιμοποιηθούν δίνουμε ένα Ι = ΣΟΥΜΑ+1 οπότε το Ι διάφορο του ΣΟΥΜΑ θα είναι αληθή από την πρώτη φορά.


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters