Τώρα είναι Πέμ 18 Ιούλ 2019 03:29 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 16 Ιουν 2008 01:22 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 16 Ιουν 2008 01:17 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
! Ζητάει έναν ακέραιο αριθμό και εμφανίζει αν είναι ή δεν είναι πρώτος

ΠΡΟΓΡΑΜΜΑ ΠΡΩΤΟΣ_ΑΡΙΘΜΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ, Ι, ΜΙΣΟ, Υ
  ΛΟΓΙΚΕΣ: ΣΗΜΑΙΑ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ ΑΡΙΘΜΟ:'
  ΔΙΑΒΑΣΕ Χ
  ΜΙΣΟ <-- Α_Μ(Χ/2)
  ΣΗΜΑΙΑ <-- ΑΛΗΘΗΣ
  Ι <-- 2
  ΟΣΟ (Ι <= ΜΙΣΟ) ΚΑΙ (ΣΗΜΑΙΑ = ΑΛΗΘΗΣ) ΕΠΑΝΑΛΑΒΕ
    Υ <-- Χ MOD Ι
    ΑΝ Υ = 0 ΤΟΤΕ
      ΣΗΜΑΙΑ <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
    Ι <-- Ι + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΣΗΜΑΙΑ = ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Ο αριθμός είναι πρώτος'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο αριθμός δεν είναι πρώτος'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters