Τώρα είναι Πέμ 18 Ιούλ 2019 04:09 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 31 Οκτ 2007 02:49 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 31 Οκτ 2007 01:48 pm
Δημοσιεύσεις: 3
Τοποθεσία: ΛΕΥΚΑΔΑ
Syntax: [ Download ] [ Hide ]
!-------------------------------------------------------------------
! Το πρόγραμμα δέχεται ένα θετικό ακέραιο και
! απλοποιεί την ρίζα του Α,
!  π.χ. αν Α=12  τότε Τ_Ρ(12)= 2*Τ_Ρ(3)
!------------------------------------------------------------------

ΠΡΟΓΡΑΜΜΑ ΑΠΛΟΠΟΙΗΣΗ_ΡΙΖΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,ΔΥΠ,ΔΑΚ,Ι

ΑΡΧΗ
  ΓΡΑΨΕ_ 'Δώσε ένα θετικό ακέραιο'
  ΔΙΑΒΑΣΕ Α
  ΑΝ Α<0 ΤΟΤΕ
    Α <-- (-1)*Α
  ΤΕΛΟΣ_ΑΝ
  ΔΥΠ <-- Α
  ΔΑΚ <-- 1
  Ι <-- 2
  ΟΣΟ Ι<=Α_Μ(Τ_Ρ(Α)) ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΔΥΠ  MOD Ι^2=0 ΤΟΤΕ
      ΔΑΚ <-- ΔΑΚ*Ι
      ΔΥΠ <-- ΔΥΠ DIV  Ι^2
    ΑΛΛΙΩΣ
      Ι <-- Ι+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τ_Ρ(',Α,')=',ΔΑΚ,'*Τ_Ρ(',ΔΥΠ,')'
  ΓΡΑΨΕ Α,'=',ΔΑΚ,'^2 *',ΔΥΠ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
takis


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters