Τώρα είναι Πέμ 18 Ιούλ 2019 04:19 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 26 Δεκ 2006 02:45 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]

! Να γραφεί πρόγραμμα που να δέχεται ακεραίους αριθμούς και
! · Υπολογίζει και εμφανίζει το μέσο όρο τους
! · Υπολογίζει και εμφανίζει το γινόμενό τους.
! Το πρόγραμμα αγνοεί τον αριθμό μηδέν και σταματά αν δοθεί
! ο αριθμός 1000 (τον οποίο δεν υπολογίζει) ή
! όταν το πλήθος των αριθμών φθάσει το 10.


ΠΡΟΓΡΑΜΜΑ ΕΠ_1_15
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x , Ν ,s , p
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε αριθμό'
  ΔΙΑΒΑΣΕ x
  Ν <-- 0
  s <-- 0
  p <-- 1
  ΟΣΟ x <>1000 ΚΑΙ Ν <=10 ΕΠΑΝΑΛΑΒΕ
    ΑΝ x <>0 ΤΟΤΕ
      Ν <-- Ν + 1
      s <-- s + x
      p <-- P*x
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Δώσε αριθμό'
    ΔΙΑΒΑΣΕ x
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '’θροισμα =',s
  ΓΡΑΨΕ 'Γινόμενο =',p
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters