Τώρα είναι Κυρ 08 Δεκ 2019 08:43 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εμβαδόν Τριγώνων
ΔημοσίευσηΔημοσιεύτηκε: Τρί 26 Δεκ 2006 11:38 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα το οποίο :
! · θα δέχεται τη βάση και το ύψος τριγώνων,
! · θα υπολογίζει και θα τυπώνει το εμβαδόν του κάθ΄ ενός,
! · θα τυπώνει στο τέλος τον αριθμό των τριγώνων για τα οποία έγιναν υπολογισμοί,
! · θα υπολογίζει και θα τυπώνει το μέσο όρο του εμβαδού όλων των τριγώνων.
! Το πρόγραμμα θα σταματά αν δοθεί ως ύψος ή ως βάση το μηδέν και θα αγνοεί τα
! στοιχεία κάθε τριγώνου για το οποίο θα δοθεί ως ύψος ή βάση αρνητικός αριθμός.


ΠΡΟΓΡΑΜΜΑ ΕΠ_1_13
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν
  ΠΡΑΓΜΑΤΙΚΕΣ: β , υ , s ,εμ ,μ
ΑΡΧΗ
  Ν <-- 1
  s <-- 0
  ΓΡΑΨΕ 'Δώσε τη βάση και το ύψος του 1ου τριγώνου'
  ΔΙΑΒΑΣΕ β ,υ
  ΟΣΟ β <> 0 ΚΑΙ υ <> 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ β > 0 ΚΑΙ υ > 0 ΤΟΤΕ
      εμ <-- β*υ/2
      ΓΡΑΨΕ ' ΕΜΒΑΔΟΝ =',εμ
      s <-- s + εμ
      Ν <-- Ν + 1
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Δώσε τη βάση και το ύψος του',Ν,'ου τριγώνου'
    ΔΙΑΒΑΣΕ β ,υ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ν <-- Ν -1
  μ <-- s/Ν
  ΓΡΑΨΕ 'Υπολογίστηκε το εμβαδό',Ν,'τριγώνων.'
  ΓΡΑΨΕ 'Ο μέσος όρος τους είναι :'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters