Τώρα είναι Τρί 23 Ιούλ 2019 06:26 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Από 24 σε 12
ΔημοσίευσηΔημοσιεύτηκε: Τετ 20 Δεκ 2006 12:58 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα το οποίο :
!  - θα δέχεται την ώρα σε εικοσιτετράωρη μορφή ως ένα τετραψήφιο αριθμό
!    (π.χ. 1845 για το επτά παρά τέταρτο)
!  - Θα ελέγχει αν ο αριθμός που δόθηκε μπορεί να αποτελεί εικοσιτετράωρη
!    ένδειξη ώρας και αν υπάρχει λάθος θα εμφανίζει αντίστοιχο μήνυμα.
!  - Θα εμφανίζει την ώρα σε δωδεκάωρη μορφή. (π.χ. για το 1025 θα εμφανίζει
!    10:25 π.μ. ενώ για το 2225 θα εμφανίσει 10:25 μ.μ.)

ΠΡΟΓΡΑΜΜΑ Ωρες
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x , h , m
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε την ώρα σε εικοσιτετράωρη μορφή'
  ΔΙΑΒΑΣΕ x
  h <-- x DIV 100
  m <-- x MOD 100
  ΟΣΟ h > 23 ή m > 59 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Η ώρα που μου έδωσες είναι λάθος. Ξαναδώσε.'
    ΔΙΑΒΑΣΕ x
    h <-- x DIV 100
    m <-- x MOD 100
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ h > 12 ΤΟΤΕ
    ΓΡΑΨΕ h - 12 , ':' , m , ' μ.μ.'
  ΑΛΛΙΩΣ_ΑΝ h < 12 ΤΟΤΕ
    ΓΡΑΨΕ h , ':' , m , ' π.μ.'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ h , ':' , m , ' μ.μ.'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Από 24 σε 12
ΔημοσίευσηΔημοσιεύτηκε: Τρί 09 Σεπ 2008 03:58 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Έχω να προτείνω μια μικρή αλλαγή, γιατί αν δοθεί αρνητικό χ μας δίνει και αρνητική ώρα. δηλαδή άμα δώσουμε -2345 τότε θα μας δώσει -23 : -45 π.μ. κάτι που δεν είναι λογικό. οπότε νομίζω ότι πρέπει η γραμμή
Syntax: [ Download ] [ Hide ]
 ΟΣΟ h > 23 ή m > 59 ΕΠΑΝΑΛΑΒΕ
να γίνει
Syntax: [ Download ] [ Hide ]
ΟΣΟ h > 23 ή m > 59 ή x < 0 ΕΠΑΝΑΛΑΒΕ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters