Τώρα είναι Κυρ 08 Δεκ 2019 08:44 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Πολλαπλασιασμός αλά ρωσικά
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:57 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ===========================================
! Να γίνει πρόγραμμα που να ζητάει δύο
! ακέραιους αριθμούς και να τους
! πολλαπλασιάζει αλά ρωσικά.
! ===========================================


ΠΡΟΓΡΑΜΜΑ Πολλαπλασιασμός_αλά_ρωσικά

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Μ1, Μ2, Ρ

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε τον πρώτο αριθμό:'
  ΔΙΑΒΑΣΕ Μ1
  ΓΡΑΨΕ 'Δώσε το δεύτερο αριθμό:'
  ΔΙΑΒΑΣΕ Μ2

  Ρ <-- 0
  ΟΣΟ Μ2>0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ Μ2 MOD 2 = 1 ΤΟΤΕ
      Ρ <-- Ρ+Μ1
    ΤΕΛΟΣ_ΑΝ
    Μ1 <-- Μ1*2
    Μ2 <-- Μ2 DIV 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Το γινόμενό τους είναι: ', Ρ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πολλαπλασιασμός_αλά_ρωσικά

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters