Τώρα είναι Τρί 23 Ιούλ 2019 06:32 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μέσος όρος
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 19 Φεβ 2006 04:32 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 27 Ιαν 2006 07:40 pm
Δημοσιεύσεις: 6
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Νίκος2

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΘΡΟΙΣΜΑ, ΜΕΤΡΗΤΗΣ, Χ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
ΑΡΧΗ
  ΓΡΑΨΕ 'Το πρόγραμμα βρίσκει τον μέσο όρο.'
  ΓΡΑΨΕ 'Γράψτε τους αριθμούς και όταν θέλεται να τελειώσεται πατήστε αρνητικό αριθμό '

  ΑΘΡΟΙΣΜΑ <-- 0
  ΜΕΤΡΗΤΗΣ <-- 0


  ΓΡΑΨΕ 'Δώστε αριθμό'
  ΔΙΑΒΑΣΕ Χ
  ΑΘΡΟΙΣΜΑ <-- Χ
  ΜΕΤΡΗΤΗΣ <-- 1

  ΟΣΟ Χ>=0  ΕΠΑΝΑΛΑΒΕ

    ΓΡΑΨΕ 'Δώστε αριθμό'
    ΔΙΑΒΑΣΕ Χ
    ΑΘΡΟΙΣΜΑ <-- ΑΘΡΟΙΣΜΑ + Χ
    ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ + 1

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ - 1
  ΑΘΡΟΙΣΜΑ <-- ΑΘΡΟΙΣΜΑ - Χ


  ΜΟ <-- ΑΘΡΟΙΣΜΑ / ΜΕΤΡΗΤΗΣ

  ΓΡΑΨΕ 'Ο μέσος όρος είναι', ΜΟ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Νίκος2                            


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 10 Μαρ 2006 10:32 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Αγαπητέ Νίκο,

Αν ο πρώτος αριθμός που θα διαβαστεί είναι αρνητικός τότε το πρόγραμμα δεν συμπεριφέρεται σωστά.


Γλίτωσες το Αν μετά την επανάληψη εκχωρώντας τον πρώτο αριθμό πριν το βρόχο, αλλά αν αυτός είναι αρνητικός δεν πρέπει να συμπεριληφθεί στο μέσο όρο...

Με εκτίμηση,

Τσιωτάκης Παναγιώτης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters