Τώρα είναι Παρ 18 Οκτ 2019 09:05 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 23 Δεκ 2004 03:09 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 15 Δεκ 2004 04:26 am
Δημοσιεύσεις: 10
Τοποθεσία: Πρέβεζα
Syntax: [ Download ] [ Hide ]
!===========================================
! netnick
!===========================================
! Ελέγχει εάν ο αριθμός που διαβάζεται έχει τα ψηφία του
! σε φθίνουσα σειρά πχ. 54321 (αποτέλεσμα ΑΛΗΘΗΣ = TRUE )
! ή όχι, πχ 1111, 1234, 54323 (αποτέλεσμα ΨΕΥΔΗΣ = FALSE)      

ΠΡΟΓΡΑΜΜΑ digits1
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: number,d1,d2
  ΛΟΓΙΚΕΣ: ισχύει
ΑΡΧΗ

  ΓΡΑΨΕ 'ΔΩΣΕ ΑΡΙΘΜΟ ΓΙΑ ΕΛΕΓΧΟ: '
  ΔΙΑΒΑΣΕ number

  ισχύει <-- ΑΛΗΘΗΣ
  d1 <-- number MOD 10
  number <-- number DIV 10
  ΟΣΟ ((number <> 0) ΚΑΙ (ισχύει = ΑΛΗΘΗΣ)) ΕΠΑΝΑΛΑΒΕ
    d2 <-- number MOD 10
    number <-- number DIV 10
    ΑΝ d1 >= d2 ΤΟΤΕ            
      ισχύει <-- ΨΕΥΔΗΣ
    ΑΛΛΙΩΣ
      d1 <-- d2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ ισχύει ΤΟΤΕ
    ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΕΧΕΙ ΤΑ ΨΗΦΙΑ ΤΟΥ ΣΕ ΦΘΙΝΟΥΣΑ ΣΕΙΡΑ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΔΕΝ ΕΧΕΙ ΤΑ ΨΗΦΙΑ ΤΟΥ ΣΕ ΦΘΙΝΟΥΣΑ ΣΕΙΡΑ'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters