Τώρα είναι Πέμ 18 Ιούλ 2019 03:36 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Αχ ! κουνελάκια ! *
ΔημοσίευσηΔημοσιεύτηκε: Παρ 21 Μάιος 2004 06:00 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]
! ========================================================================================================
! Σε ένα δάσος ζει μια κοινότητα κουνελιών με τα εξής χαρακτηριστικά:
! Στην αρχή κάθε χρόνου δυστυχώς :( 3 κουνελάκια εγκαταλείπουν το δάσος,
! από αυτά το 1 ειναι αρσενικό και τα 2 θηλυκά. Στο τέλος κάθε 4ου έτους όμως
! αν στο δάσος έχει μείνει τουλάχιστον 1 αρσενικό και 1 θηλυκό, τότε αυτά
! αναπαράγονται :).  Κάθε "ζευγάρι" κουνελιών που βρίσκεται στο δάσος γεννά 5 κουνελάκια
! (ας δεχτούμε χάρην ευκολίας ότι πάντα από τα 5 νεογεννητα, είναι το 1 αρσενικό και τα 4 θηλυκά)
! Θεωρούμε έπίσης ότι ακόμη και πριν συμπληρώσουν ένα έτος ζωής, τα κουνελάκια μπορούν να
! αναπαράγονται αν ισχύουν οι απαραιτητες συνθήκες ζευγαρώματος.
! Να αναπτύξετε αλγόριθμο που
! α) Να διαβάζει τον αρχικό αριθμό Ν>=4 των κουνελιών που ζει στο δάσος.
!      Θεωρήστε ότι αν ο Ν είναι αρτιος, έχουμε αρχικά ίσους πληθυσμους αρσενικών και θηλυκών,
!      ενώ αν ο Ν είναι περιττος, θεωρήστε όι τα θηλυκά ειναι, κατά ένα περισσότερα από τα αρσενικά.
! β) Να εμφανίζει στο τέλος καθε έτους πόσα αρσενικα και πόσα θηλυκά κουνελια έχουν μεινει στο δάσος.
! γ) Να υπολογίζει μετα από 20 χρόνια, τους αντίστοιχους πληθυσμούς, εκτός αν νωρίτερα έχουν εγκαταλήψει
!    όλα τα κουνελάκια το δάσος, όποτε και θα πρέπει να εμφανίζει μετά από ποσα χρονια θα συμβεί αυτό.
! =========================================================================================================

ΠΡΟΓΡΑΜΜΑ Κουνελάκια
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,Ν,ΑΡΣ,ΘΗΛ,ΖΕΥΓ, ΕΤΗ
ΑΡΧΗ
 ! ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε ακέραιο πλήθος κουνελιών που υπάρχουν σήμερα στο δάσος (Ν>=4)'
    ΔΙΑΒΑΣΕ Ν
 ! ΜΕΧΡΙΣ_ΟΤΟΥ Ν>=4

  ΑΡΣ <-- Ν DIV 2            !    ΑΝ (Ν MOD 2)=0 ΤΟΤΕ
  ΘΗΛ <-- Ν DIV 2            !      ΑΡΣ <-- Ν DIV 2
  ΑΝ (Ν MOD 2)<>0 ΤΟΤΕ       !      ΘΗΛ <-- Ν DIV 2
    ΘΗΛ <-- ΘΗΛ + 1          !     ΑΛΛΙΩΣ
  ΤΕΛΟΣ_ΑΝ                   !      ΑΡΣ <-- Ν DIV 2
                             !      ΘΗΛ <-- Ν DIV 2 +1
                             !   ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ '-------  Σήμερα υπάρχουν στο δάσος ',ΑΡΣ,' αρσενικα και ',ΘΗΛ, ' θηλυκά κουνέλια'
  ΕΤΗ <-- 0
  ΟΣΟ (Ν>0) ΚΑΙ (ΕΤΗ<20) ΕΠΑΝΑΛΑΒΕ      ! ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΕΤΗ <-- ΕΤΗ+1
    ΑΡΣ <-- ΑΡΣ-1
    ΘΗΛ <-- ΘΗΛ-2

    ΑΝ (ΑΡΣ>ΘΗΛ) ΤΟΤΕ
      ΖΕΥΓ <-- ΘΗΛ
    ΑΛΛΙΩΣ
      ΖΕΥΓ <-- ΑΡΣ
    ΤΕΛΟΣ_ΑΝ

    ΑΝ ((ΕΤΗ MOD 4)=0) ΚΑΙ (ΖΕΥΓ>=1) ΤΟΤΕ
      ΑΡΣ <-- ΑΡΣ+1*ΖΕΥΓ
      ΘΗΛ <-- ΘΗΛ+4*ΖΕΥΓ
    ΤΕΛΟΣ_ΑΝ

    ΑΝ ΑΡΣ<0 ΤΟΤΕ
      ΑΡΣ <-- 0
    ΤΕΛΟΣ_ΑΝ

    ΑΝ ΘΗΛ<0 ΤΟΤΕ
      ΘΗΛ <-- 0
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Μετα από ',ΕΤΗ, ' χρονια έχουν παραμείνει ',ΑΡΣ,' αρσενικά και ',ΘΗΛ, ' θηλυκά κουνέλια'

    Ν <-- ΑΡΣ + ΘΗΛ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                     ! ΜΕΧΡΙΣ_ΟΤΟΥ (Ν=0) Η (ΕΤΗ=20)

  ΑΝ Ν=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα κουνέλια μετα από ',ΕΤΗ, ' χρόνια έχουν εγκαταλήψει όλα το δάσος'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


Μπορείτε να υπολογίσετε το όριο του αρχικού αριθμού κουνελιών, κατώ από το οποίο, τελικά όλα τα κουνελάκια εγκαταλείπουν το δάσος, ένω πάνω από αυτό το δάσος θα πλημμυρίσει από κουνέλια ? :D


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters