Τώρα είναι Κυρ 08 Δεκ 2019 08:44 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμός βαθμολογίας.
ΔημοσίευσηΔημοσιεύτηκε: Τετ 03 Μαρ 2004 05:45 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 19 Φεβ 2004 01:39 am
Δημοσιεύσεις: 3
Τοποθεσία: ΠΕΙΡΑΙΑΣ,ΜΥΤΙΛΗΝΗ
Το πρόγραμμα υπολογίζει τη βαθμολογία πλήθους μαθητών.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ βαθμολογια
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:πληθος,πληθοςΚΒ
  ΠΡΑΓΜΑΤΙΚΕΣ:βαθμος,αθροισμα,max
  ΧΑΡΑΚΤΗΡΕΣ: ονομα,ονομα_max
ΑΡΧΗ
  αθροισμα <-- 0
  πληθος <-- 0
  πληθοςΚΒ <-- 0 !το πληθος των βαθμων που ειναι κατω απο τη βαση
  ΓΡΑΨΕ 'δωσε ονομα και βαθμο μαθητη'
  ΔΙΑΒΑΣΕ ονομα,βαθμος
  max <-- βαθμος
  ονομα_max <-- ονομα !το ονομα του μαθητη με τον μεγιστο βαθμο
  ΟΣΟ βαθμος>0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ βαθμος>max ΤΟΤΕ
      max <-- βαθμος
      ονομα_max <-- ονομα
    ΤΕΛΟΣ_ΑΝ
    ΑΝ βαθμος<9.5 ΤΟΤΕ
      πληθοςΚΒ <-- πληθοςΚΒ+1
    ΤΕΛΟΣ_ΑΝ
    αθροισμα <-- αθροισμα+βαθμος
    πληθος <-- πληθος+1
    ΓΡΑΨΕ 'δωσε ονομα και βαθμο μαθητη'
    ΔΙΑΒΑΣΕ ονομα,βαθμος
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ονομα,βαθμος του καλυτερου μαθητη:',ονομα_max,max
  ΓΡΑΨΕ 'πληθος των μαθητων με βαθμο κατω απο τη βαση:',πληθοςΚΒ
  ΑΝ πληθος<>0 ΤΟΤΕ
    ΓΡΑΨΕ 'μεσος ορος βαθμων:',αθροισμα/πληθος
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'δεν μπορει να υπολογιστει ο μεσος ορος'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ βαθμολογια
 

_________________
to gorgon kai xarin exei
iMpReZaMaN


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters