Τώρα είναι Πέμ 18 Ιούλ 2019 03:24 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Αγορά_Σπιτιού
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 29 Φεβ 2004 03:04 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 26 Οκτ 2003 02:28 pm
Δημοσιεύσεις: 3
Το πρόγραμμα αυτό υπολογίζει πόσο τυχερός ή άτυχος μπορεί να είναι ένας εργαζόμενος.
Syntax: [ Download ] [ Hide ]
!==============================================================================================
! Ένας εργαζόμενος προσλαμβάνεται σε μια εταιρία με αρχικό μισθό { Α_Μισθός }
! Κάθε χρόνο θα παίρνει μηνιαία αύξηση { Μ_Αύξηση } (σε Ευρώ).
! Από τα χρήματα που συγκεντρώνει το χρόνο αποταμιεύει ένα ποσοστό% { Π_Αποταμίευσης }
! με σκοπό κάποια στιγμή να αγοράσει ένα διαμέρισμα που κοστίζει { Κ_Διαμερίσματος }
! και στο οποίο θέλει να βάλει επίπλωση αξίας { Κ_Επίπλωσης }
! Κάθε χρόνο η τιμή του σπιτιού αυξάνεται κατά χ1% και της επίπλωσης κατά χ2%
!----------------------------------------------------------------------------------------------
! Να γραφεί πρόγραμμα που θα διεκπεραιώνει τις εξής διεργασίες:
! Α] Θα υπολογίζει πόσα χρόνια θα περάσουν μέχρι ο εργαζόμενος να αποκτήσει το δικό του σπίτι,
!  και να τερματίζει τη διαδικασία, αν υπολογίζει ότι ο εργαζόμενος αδυνατεί να το αγοράσει.
! Β] Θα εξετάζει αν υπάρχει περίσσευμα χρημάτων για να μπορέσει ο εργαζόμενος να αγοράσει
! την επίπλωση που επιθυμεί
! ΣΗΜΕΙΩΣΗ: Να ελέγχεται μήπως ο εργάζομενος αδυνατεί να αγοράσει το σπίτι
!===============================================================================================

ΠΡΟΓΡΑΜΜΑ Αγορά_Σπιτιού
ΣΤΑΘΕΡΕΣ
  Χρόνια_Εργασίας =3
! Έστω ότι θα δουλέψει 40 χρόνια

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α_Μισθός, Μ_Αύξηση, Π_Αποταμίευσης, Κ_Διαμερίσματος, Κ_Επίπλωσης, χ1, χ2
  ΠΡΑΓΜΑΤΙΚΕΣ: SUM_Μισθών, SUM_Διαμερίσματος, Μισθός, Περίσσευμα, Αποταμίευση, SUM_Επίπλωσης
  ΑΚΕΡΑΙΕΣ: i, Χρόνια, ν
  ΧΑΡΑΚΤΗΡΕΣ: ΣΤΟΠ
ΑΡΧΗ

! -<ΕΙΣΑΓΩΓΗ ΔΕΔΟΜΕΝΩΝ ΑΡΧΗ>---------------------------------------------------------------------
  ΓΡΑΨΕ 'Αρχικός Μισθός Εργαζόμενου:'
  ΔΙΑΒΑΣΕ Α_Μισθός

  i <-- 0
  ΟΣΟ  (Α_Μισθός<=0) ΚΑΙ (i<=3) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Ο μισθός δεν μπορεί να είναι αρνητικός ή μηδενικός αριθμός'
    ΓΡΑΨΕ 'Μισθός Εργαζόμενου:'
    ΔΙΑΒΑΣΕ Α_Μισθός
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Μηνιαία Αύξηση Μισθού:'
  ΔΙΑΒΑΣΕ Μ_Αύξηση

  i <-- 0
  ΟΣΟ  (Μ_Αύξηση<0) ΚΑΙ (i<=3) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'H μηνιαία αύξηση δεν μπορεί να είναι αρνητικός αριθμός'
    ΓΡΑΨΕ 'Μηνιαία Αύξηση Μισθού:'
    ΔΙΑΒΑΣΕ Μ_Αύξηση
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ποσοστό Αποταμίευσης:'
  ΔΙΑΒΑΣΕ Π_Αποταμίευσης

  i <-- 0
  ΟΣΟ  (Π_Αποταμίευσης<0) Η (Π_Αποταμίευσης>100) ΚΑΙ (i<=3) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Το Ποσοστό Αποταμίευσης κυμαίνεται μεταξύ 0 και 100'
    ΓΡΑΨΕ 'Ποσοστό Αποταμίευσης:'
    ΔΙΑΒΑΣΕ Π_Αποταμίευσης
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  Π_Αποταμίευσης <-- Π_Αποταμίευσης/100

  ΓΡΑΨΕ 'Κόστος Διαμερίσματος:'
  ΔΙΑΒΑΣΕ Κ_Διαμερίσματος

  i <-- 0
  ΟΣΟ  (Κ_Διαμερίσματος<0) ΚΑΙ (i<=3) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Το κόστος Διαμερίσματος δεν μπορεί να είναι αρνητικός αριθμός'
    ΓΡΑΨΕ 'Κόστος Διαμερίσματος:'
    ΔΙΑΒΑΣΕ Κ_Διαμερίσματος
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Κόστος Επίπλωσης:'
  ΔΙΑΒΑΣΕ Κ_Επίπλωσης

  i <-- 0
  ΟΣΟ  (Κ_Επίπλωσης<0) ΚΑΙ (i<=3) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Το κόστος Επίπλωσης δεν μπορεί να είναι αρνητικός αριθμός'
    ΓΡΑΨΕ 'Κόστος Επίπλωσης:'
    ΔΙΑΒΑΣΕ Κ_Επίπλωσης
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ποσοστιαία αύξηση σπιτιού ετησίως:'
  ΔΙΑΒΑΣΕ χ1
  χ1 <-- χ1/100
  ΓΡΑΨΕ 'Ποσοστιαία αύξηση επίπλωσης ετησίως:'
  ΔΙΑΒΑΣΕ χ2
  χ2 <-- χ2/100
! -<ΕΙΣΑΓΩΓΗ ΔΕΔΟΜΕΝΩΝ ΤΕΛΟΣ>--------------------------------------------------------------------

! Έλεγχος για το αν θα καταφέρει να αγοράσει ποτέ το σπίτι
  SUM_Μισθών <-- (Χρόνια_Εργασίας/2)*(2*Α_Μισθός*12+(Χρόνια_Εργασίας-1)*Μ_Αύξηση*12)
  ΓΡΑΨΕ 'SUM_Μισθών=', SUM_Μισθών
! άθροισμα αριθμητικής προόδου:
! S=ν/2*[2*α1+(ν-1)*ω],  οπου ν= Χρόνια_Εργασίας(χρόνια), α1=Α_Μισθός*12, ω=Μ_Αύξηση*12
  SUM_Διαμερίσματος <-- Κ_Διαμερίσματος*(χ1^Χρόνια_Εργασίας-1)/(χ1-1)
! άθροισμα γεωμετρικής προόδου:
! S=α1*(λ^ν-1)/(λ-1), όπου λ=χ1, α1=αρχικό_Κ_Διαμερίσματος, ν=Χρόνια_Εργασίας(χρόνια)

  ΑΝ (SUM_Μισθών*Π_Αποταμίευσης < SUM_Διαμερίσματος) ΤΟΤΕ
    ΓΡΑΨΕ 'Δυστυχώς, η αγορά αυτού του σπιτιού θα παραμείνει ένα ανεκπλήρωτο όνειρο!'
    ΓΡΑΨΕ 'Κι αυτό γιατί η συνολική αποταμίευση θα είναι: ', SUM_Μισθών*Π_Αποταμίευσης
  ΑΛΛΙΩΣ
    Χρόνια <-- 0
    Μισθός <-- Α_Μισθός*12
    Αποταμίευση <-- Π_Αποταμίευσης*Μισθός

    ν <-- 1
    ΟΣΟ Αποταμίευση<Κ_Διαμερίσματος*(χ1^ν-1)/(χ1-1) ΕΠΑΝΑΛΑΒΕ
      Χρόνια <-- Χρόνια+1
      Μισθός <-- Μισθός+Μ_Αύξηση*12
      Αποταμίευση <-- Αποταμίευση+Μισθός*Π_Αποταμίευσης
      ν <-- ν+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    Περίσσευμα <-- Αποταμίευση-Κ_Διαμερίσματος*(χ1^ν-1)/(χ1-1)

    ΑΝ (Χρόνια<>0) ΤΟΤΕ
      SUM_Επίπλωσης <-- Κ_Επίπλωσης*(χ2^Χρόνια -1)/(χ2-1)
    ΑΛΛΙΩΣ
      SUM_Επίπλωσης <-- Κ_Επίπλωσης
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Το σπίτι θα αγοραστεί μετά από ', Χρόνια, ' Χρόνια'
    ΓΡΑΨΕ 'ΣΗΜΕΙΩΣΗ: Η επίπλωση του σπιτιού κοστίζει πλέον: ', SUM_Επίπλωσης

    ΑΝ (Περίσσευμα >= SUM_Επίπλωσης) ΤΟΤΕ
      ΓΡΑΨΕ 'Περισσεύουν', Περίσσευμα-SUM_Επίπλωσης, 'Ευρώ'
      ΓΡΑΨΕ 'και ο εργαζόμενος έχει τη δυνατότητα να αγοράσει την επίπλωση του σπιτιού'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Περισσεύουν', Περίσσευμα, 'Ευρώ'
      ΓΡΑΨΕ 'αλλά δεν έχει τη δυνατότητα ο εργαζόμενος να επιπλώσει το καινούριο του σπιτάκι'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ   !(SUM_Μισθών*Π_Αποταμίευσης < SUM_Διαμερίσματος)

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Αγορά_Σπιτιού
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters