Τώρα είναι Τρί 23 Ιούλ 2019 06:50 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 07 Απρ 2014 11:48 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 07 Απρ 2014 11:38 pm
Δημοσιεύσεις: 1
Πρόκειται για ένα πολύ απλό πρόγραμμα που βγαίνει με την βοήθεια των εντολών 'όσο...επανάλαβε' και 'αν'
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΠΑΙΧΝΙΔΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Σ,Ν
  ΧΑΡΑΚΤΗΡΕΣ:Α,Β
ΑΡΧΗ
  Σ <-- 0
  Ν <-- 0
  ΓΡΑΨΕ 'ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ: ΤΙ ΘΑ ΠΑΙΞΕΙΣ?'
  ΔΙΑΒΑΣΕ Α
  ΟΣΟ Α <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ: ΤΙ ΘΑ ΠΑΙΞΕΙΣ ?'
    ΔΙΑΒΑΣΕ Β
    ΑΝ Α='ΠΕΤΡΑ' ΚΑΙ Β='ΠΕΤΡΑ' ΤΟΤΕ
      ΓΡΑΨΕ 'ΙΣΟΠΑΛΙΑ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΠΕΤΡΑ' ΚΑΙ Β='ΜΟΛΥΒΙ' ΤΟΤΕ
      Σ <-- Σ+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΠΕΤΡΑ' ΚΑΙ Β='ΨΑΛΙΔΙ' ΤΟΤΕ
      Σ <-- Σ+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΠΕΤΡΑ' ΚΑΙ Β='ΧΑΡΤΙ' ΤΟΤΕ
      Ν <-- Ν+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΜΟΛΥΒΙ' ΚΑΙ Β='ΠΕΤΡΑ' ΤΟΤΕ
      Ν <-- Ν+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΜΟΛΥΒΙ' ΚΑΙ Β='ΜΟΛΥΒΙ' ΤΟΤΕ
      ΓΡΑΨΕ 'ΙΣΟΠΑΛΙΑ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΜΟΛΥΒΙ' ΚΑΙ Β='ΨΑΛΙΔΙ' ΤΟΤΕ
      Ν <-- Ν+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΜΟΛΥΒΙ' ΚΑΙ Β='ΧΑΡΤΙ' ΤΟΤΕ
      Σ <-- Σ+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΨΑΛΙΔΙ' ΚΑΙ Β='ΠΕΤΡΑ' ΤΟΤΕ
      Ν <-- Ν+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΨΑΛΙΔΙ' ΚΑΙ Β='ΜΟΛΥΒΙ' ΤΟΤΕ
      Σ <-- Σ+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΨΑΛΙΔΙ' ΚΑΙ Β='ΨΑΛΙΔΙ' ΤΟΤΕ
      ΓΡΑΨΕ 'ΙΣΟΠΑΛΙΑ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΨΑΛΙΔΙ' ΚΑΙ Β='ΧΑΡΤΙ' ΤΟΤΕ
      Σ <-- Σ+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΧΑΡΤΙ' ΚΑΙ Β='ΠΕΤΡΑ' ΤΟΤΕ
      Σ <-- Σ+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΧΑΡΤΙ' ΚΑΙ Β='ΜΟΛΥΒΙ' ΤΟΤΕ
      Ν <-- Ν+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΧΑΡΤΙ' ΚΑΙ Β='ΨΑΛΙΔΙ' ΤΟΤΕ
      Ν <-- Ν+1
      ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ.'
    ΑΛΛΙΩΣ_ΑΝ Α='ΧΑΡΤΙ' ΚΑΙ Β='ΧΑΡΤΙ' ΤΟΤΕ
      ΓΡΑΨΕ 'ΙΣΟΠΑΛΙΑ'
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ: ΤΙ ΘΑ ΠΑΙΞΕΙΣ?'
    ΔΙΑΒΑΣΕ Α
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΑΝ Σ=Ν ΤΟΤΕ
    ΓΡΑΨΕ 'ΥΠΑΡΧΕΙ ΙΣΟΠΑΛΙΑ.'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο ΠΡΩΤΟΣ ΠΑΙΚΤΗΣ ΚΕΡΔΙΣΕ',Σ,'ΦΟΡΕΣ ΚΑΙ Ο ΔΕΥΤΕΡΟΣ ΠΑΙΚΤΗΣ',Ν,'ΦΟΡΕΣ.'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters