Τώρα είναι Τετ 08 Απρ 2020 08:27 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΤΕΛΕΙΟΙ ΑΡΙΘΜΟΙ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 22 Ιαν 2004 07:34 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 21 Ιαν 2004 03:43 am
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
!=======================================================================
! ΤΟ ΠΑΡΑΚΑΤΩ ΠΡΟΓΡΑΜΜΑ ΔΕΧΕΤΑΙ ΣΑΝ ΕΙΣΟΔΟ ΕΝΑΝ ΑΚΕΡΑΙΟ ΚΑΙ ΕΜΦΑΝΙΖΕΙ
! ΟΛΟΥΣ ΤΟΥΣ ΤΕΛΕΙΟΥΣ ΑΡΙΘΜΟΥΣ ΜΕΧΡΙ ΤΟΝ ΑΚΕΡΑΙΟ ΠΟΥ ΔΟΘΗΚΕ. ΤΕΛΕΙΟΣ
! ΛΕΓΕΤΑΙ ΕΝΑΣ ΑΡΙΘΜΟΣ ΠΟΥ ΕΙΝΑΙ ΙΣΟΣ ΜΕ ΤΟ ΑΘΡΟΙΣΜΑ ΟΛΩΝ ΤΩΝ ΓΝΗΣΙΩΝ
! ΔΙΑΙΡΕΤΩΝ ΤΟΥ.
!=======================================================================
ΠΡΟΓΡΑΜΜΑ ΤΕΛΕΙΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: N,I,J,P,S,Q


ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑΝ ΑΚΕΡΑΙΟ'
  ΔΙΑΒΑΣΕ N
  ΓΙΑ P ΑΠΟ 1 ΜΕΧΡΙ N
    S <-- 0
    Q <-- P DIV 2
    ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ Q
      ΑΝ P MOD I =0 ΤΟΤΕ
        S <-- S+I
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ S=P ΤΟΤΕ
      ΓΡΑΨΕ 'Ο  ',P,'  ΕΙΝΑΙ ΤΕΛΕΙΟΣ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters