Τώρα είναι Δευτ 10 Αύγ 2020 02:01 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Πρώτοι αριθμοί
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 13 Ιαν 2011 10:16 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Ιαν 2011 10:09 pm
Δημοσιεύσεις: 1
Κώδικας:
ΠΡΟΓΡΑΜΜΑ  Ευρεση_Πρωτων_αριθμων

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ναμ, σαμ, ι

ΑΡΧΗ
  ΔΙΑΒΑΣΕ ναμ
  ΓΙΑ ι  ΑΠΟ  2 ΜΕΧΡΙ ναμ-1  ΜΕ ΒΗΜΑ 1
    σαμ <-- ναμ  MOD ι
    ΑΝ σαμ = 0  ΤΟΤΕ
      ΓΡΑΨΕ 'Ο αριθμός',ναμ,'δεν είναι πρώτος. Μπορεί να διαιρεθεί με το',ι

    ΑΛΛΙΩΣ_ΑΝ σαμ <> 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Ο αριθμός',ναμ,'είναι πρώτος!'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


i dikia mou ekdoxi evrisis prwtwn arithmwn. vevaia den einai teleiomenos dld dexetai kai arnitikous arithmous alla variemai na to grapsw lol :P. tha ithela an kserei kapoios pos borw na termatisw proora ton vronxo gia dld kati san to break; stin c#, c++ klp. thanks :)


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Πρώτοι αριθμοί
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 23 Ιαν 2011 04:59 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
billiout έγραψε:
tha ithela an kserei kapoios pos borw na termatisw proora ton vronxo gia dld kati san to break; stin c#, c++ klp
Θα μπορούσες να δίνεις στο ι την τιμή ναμ-1 για να τερματίσει αλλά αυτό δεν θεωρείται καλή προγραμματιστική τακτική. Καλύτερα θα ήταν να μετατρέψεις την Για σε Όσο ή Μέχρις_Ότου και να χρησιμοποιείς μια λογική μεταβλητή της οποία η τιμή θα δηλώνει αν θες να τερματιστεί πρόωρα ο βρόχος. Δεν υπάρχει break στην γλωσσομάθεια. Πάντως, όταν σαμ <> 0 δεν είναι απαραίτητα πρώτος ο ναμ ! (Το με βήμα 1 και _ΑΝ σαμ <> 0 ΤΟΤΕ εννοούνται και δεν χρειάζονται. Επίσης κάνεις πολλούς περιττούς ελέγχους τους οποίους μπορείς να τους γλιτώσεις με λίγη προσπάθεια)

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Πρώτοι αριθμοί
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 01 Μάιος 2011 04:57 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Επίσης δεν χρειάζεται να διαιρείς για i μέχρι και ναμ-1 αλλά μέχρι την τετραγωνική ρίζα του ναμ...


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters