Τώρα είναι Παρ 10 Απρ 2020 08:48 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Άθροισμα ψηφίων αριθμού
ΔημοσίευσηΔημοσιεύτηκε: Τετ 25 Φεβ 2009 01:02 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 25 Φεβ 2009 12:19 am
Δημοσιεύσεις: 8
Syntax: [ Download ] [ Hide ]
! Να γραφτεί αλγόριθμος ο οποίος θα βρίσκει τους τριψήφιους αριθμούς που είναι ίσοι
! με το άθροισμα των κύβων των ψηφίων τους. Π.χ. 153=1^3+5^3+3^3 και 370=3^3+7^3+0^3
! Μπορεί να λυθεί με δύο τρόπους.
!
ΠΡΟΓΡΑΜΜΑ Ιδιότητα_α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,x,sum,Ψηφίο
  ΠΡΑΓΜΑΤΙΚΕΣ:γιν
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 100 ΜΕΧΡΙ 999
    x <-- i
    sum <-- 0
    ΟΣΟ x>0 ΕΠΑΝΑΛΑΒΕ
      Ψηφίο <-- x MOD 10
      sum <-- sum + Ψηφίο^3
      x <-- x DIV 10
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ i=sum ΤΟΤΕ
      ΓΡΑΨΕ i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ιδιότητα_α
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Άθροισμα ψηφίων αριθμού
ΔημοσίευσηΔημοσιεύτηκε: Τετ 25 Φεβ 2009 01:16 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 25 Φεβ 2009 12:19 am
Δημοσιεύσεις: 8
Syntax: [ Download ] [ Hide ]
! Να γραφτεί αλγόριθμος ο οποίος θα βρίσκει τους τριψήφιους αριθμούς που είναι ίσοι
! με το άθροισμα των κύβων των ψηφίων τους. Π.χ. 153=13+53+33 και 370=33+73+03
!
! Ο προηγούμενος τρόπος δίνει έμφαση στη "διάσπαση" ενός αριθμού στα ψηφία του.
! Ο δεύτερος τρόπος δίνει έμφαση στη "σύνθεση" ενός αριθμού από τα ψηφίου του.
! Διδακτικά, αποτελεί μια αφορμή για:
! α) υπενθύμιση της ολίσθησης, που χρησιμοποιείται για τη σύνθεση του x από τα ψηφία του,
! β) συζήτηση περί του πλήθους των επαναλήψεων στις εμφωλευμένες δομές επανάληψης
!    (κι εδώ, όπως και στον πρώτο τρόπο, ελέγχουμε 900 αριθμούς, γεγονός που επιτυγχάνεται
!     με έναρξη της πρώτης Δομής από 1 και ΟΧΙ από 0. Η σημασία αυτής της αρχικής τιμής
!     είναι προφανής καθώς αναφερόμαστε σε αυστηρά τρiψήφιους αριθμούς)
! γ) σχολιασμό στο θέμα "Χρονικές Επιδόσεις" ενός αλγόριθμου, ο οποίος γίνεται συνοπτικά
!    και παρενθετικά, αφού το αντίστοιχο θέμα δεν είναι στην εξεταστέα ύλη, αλλά δεν παύει
!    να είναι ενδιαφέρον για ένα προγραμματιστή.
!
ΠΡΟΓΡΑΜΜΑ Ιδιότητα_β
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:x1,x2,x3,x,sum
  ΠΡΑΓΜΑΤΙΚΕΣ:γιν
ΑΡΧΗ
  ΓΙΑ x1 ΑΠΟ 1 ΜΕΧΡΙ 9
    ΓΙΑ x2 ΑΠΟ 0 ΜΕΧΡΙ 9
      ΓΙΑ x3 ΑΠΟ 0 ΜΕΧΡΙ 9
        x <-- x1*100 + x2*10 + x3
        sum <-- x1^3 + x2^3 + x3^3
        ΑΝ x=sum ΤΟΤΕ
          ΓΡΑΨΕ x
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ιδιότητα_β
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters