Τώρα είναι Τετ 08 Απρ 2020 08:12 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμός του π
ΔημοσίευσηΔημοσιεύτηκε: Τετ 25 Φεβ 2009 12:49 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 25 Φεβ 2009 12:19 am
Δημοσιεύσεις: 8
Syntax: [ Download ] [ Hide ]
! Από τα μαθηματικά γνωρίζουμε ότι η τιμή του π με έλλειψη δίνεται από τη σχέση
!
!  π     2     2     4     4     6     6     8     8         N-1
! --- = --- x --- x --- x --- x --- x --- x --- x --- x ... -----
!  2     1     3     3     5     5     7     7     9          N
!
! ενώ με υπεροχή δίνεται από τη σχέση
!
!  π     2     2     4     4     6     6     8     8          N
! --- = --- x --- x --- x --- x --- x --- x --- x --- x ... -----
!  2     1     3     3     5     5     7     7     9         N-1
!
! Να γράψετε αλγόριθμο που θα επιτρέπει στο χρήστη να υπολογίσει την τιμή του π,
! καθορίζοντας την τιμή του Ν καθώς και την μέθοδο προσέγγισης (1. 'Έλλειψη, 2. Υπεροχή).

ΠΡΟΓΡΑΜΜΑ π
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:αρ,παρ,i,Ν,επιλογή
  ΠΡΑΓΜΑΤΙΚΕΣ:γιν
ΑΡΧΗ
  γιν <-- 1
  παρ <-- 1
  αρ <-- 2
  ΓΡΑΨΕ 'Δώσε την τιμή του Ν'
  ΔΙΑΒΑΣΕ Ν
  ΓΡΑΨΕ 'Δώσε μοντέλο προσέγγισης'
  ΓΡΑΨΕ '1. Έλλειψη , 2. Υπεροχή'
  ΔΙΑΒΑΣΕ επιλογή
  επιλογή <-- επιλογή - 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν - επιλογή
    γιν <-- γιν*αρ/παρ
    ΑΝ i MOD 2 = 1 ΤΟΤΕ
      παρ <-- αρ + 1
    ΑΛΛΙΩΣ
      αρ <-- παρ + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  γιν <-- 2 * γιν
  ΓΡΑΨΕ γιν
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ π
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters