Τώρα είναι Τετ 08 Απρ 2020 09:24 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ανισότητα ψηφίων αριθμού
ΔημοσίευσηΔημοσιεύτηκε: Τετ 23 Απρ 2003 03:55 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =========================================
! Να γίνει πρόγραμμα που να εμφανίζει όλους
! τους τριψήφιους αριθμούς για τους οποίους
! ισχύει Ψ1<Ψ2<Ψ3, όπου Ψ1, Ψ2 και Ψ3 τα
! ψηφία του αριθμού από αριστερά προς τα
! δεξιά.
! =========================================


ΠΡΟΓΡΑΜΜΑ Ανισότητα_ψηφίων_αριθμού

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ, Ψ1, Ψ2, Ψ3, υπόλοιπο

ΑΡΧΗ

  ΓΙΑ Χ ΑΠΟ 100 ΜΕΧΡΙ 999

    Ψ1 <-- Χ DIV 100
    υπόλοιπο <-- Χ MOD 100
    Ψ2 <-- υπόλοιπο DIV 10
    Ψ3 <-- υπόλοιπο MOD 10

    ΑΝ (Ψ1<Ψ2) ΚΑΙ (Ψ2<Ψ3) ΤΟΤΕ
      ΓΡΑΨΕ_ Χ, '  '
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ανισότητα_ψηφίων_αριθμού

 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Ανισότητα ψηφίων αριθμού (2)
ΔημοσίευσηΔημοσιεύτηκε: Τετ 23 Απρ 2003 03:57 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =========================================
! Να γίνει πρόγραμμα που να εμφανίζει όλους
! τους τριψήφιους αριθμούς για τους οποίους
! ισχύει Ψ1<Ψ2<Ψ3, όπου Ψ1, Ψ2 και Ψ3 τα
! ψηφία του αριθμού από αριστερά προς τα
! δεξιά.
! =========================================


ΠΡΟΓΡΑΜΜΑ Ανισότητα_ψηφίων_αριθμού

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ, Ψ1, Ψ2, Ψ3

ΑΡΧΗ

  ΓΙΑ Ψ1 ΑΠΟ 1 ΜΕΧΡΙ 9
    ΓΙΑ Ψ2 ΑΠΟ Ψ1+1 ΜΕΧΡΙ 9
      ΓΙΑ Ψ3 ΑΠΟ Ψ2+1 ΜΕΧΡΙ 9

        Χ <-- Ψ1*100 + Ψ2*10 + Ψ3
        ΓΡΑΨΕ_ Χ, '  '

      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ανισότητα_ψηφίων_αριθμού

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters