Τώρα είναι Δευτ 13 Ιούλ 2020 02:03 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ποσοστά εξετάσεων
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 23 Μαρ 2003 06:14 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =============================================================================
! Μια τάξη της Τεχνολογικής Κατεύθυνσης της Γ Λυκείου έχει 25 μαθητές, οι
! οποίοι εξετάστηκαν στις Πανελλήνιες Εξετάσεις στο μάθημα "Ανάπτυξη
! Εφαρμογών". Να γίνει πρόγραμμα το οποίο:
!   Α) Για κάθε μαθητή
!        - θα ζητάει τον προφορικό και το γραπτό του βαθμό (όλοι οι βαθμοί
!          είναι στην 20βάθμια κλίμακα).
!        - θα εμφανίζει την τελική του βαθμολογία, η οποία εξάγεται κατά 70%
!          από το γραπτό και κατά 30% από τον προφορικό του βαθμό.
!   Β) Θα εμφανίζει το επί τοις εκατό ποσοστό των μαθητών που έχουν τελική
!      βαθμολογία μεγαλύτερη από 15.
! =============================================================================


ΠΡΟΓΡΑΜΜΑ Ποσοστά_εξετάσεων

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: προφορικός_βαθμός, γραπτός_βαθμός, τελικός_βαθμός
  ΑΚΕΡΑΙΕΣ: υψηλοί_βαθμοί, i

ΑΡΧΗ

  υψηλοί_βαθμοί <-- 0

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 25

    ΓΡΑΨΕ 'Δώσε τον προφορικό βαθμό του ', i, 'ου μαθητή:'
    ΔΙΑΒΑΣΕ προφορικός_βαθμός
    ΓΡΑΨΕ 'Δώσε το γραπτό βαθμό του ', i, 'ου μαθητή:'
    ΔΙΑΒΑΣΕ γραπτός_βαθμός

    τελικός_βαθμός <-- (30/100)*προφορικός_βαθμός + (70/100)*γραπτός_βαθμός
    ΓΡΑΨΕ 'Τελικός βαθμός του μαθητή: ', τελικός_βαθμός

    ΑΝ τελικός_βαθμός>15 ΤΟΤΕ
      υψηλοί_βαθμοί <-- υψηλοί_βαθμοί+1
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Το ποσοστό των υψηλών βαθμών είναι: ', 100*υψηλοί_βαθμοί/25, ' %'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ποσοστά_εξετάσεων

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters