Τώρα είναι Τετ 08 Απρ 2020 09:38 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 26 Δεκ 2006 03:30 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]

! Να γραφεί πρόγραμμα το οποίο :
!  · θα δέχεται το πλήθος των μαθητών ενός σχολείου και
!    τους ετήσιους μέσους όρους του καθενός από αυτούς.
! Στη συνέχεια θα υπολογίζει και εμφανίζει :
!  · το πλήθος των μαθητών που δεν προάγονται (αυτοί με βαθμό μικρότερο του 9,5).
!  · το πλήθος των μαθητών που προάγονται με βαθμό μικρότερο του 18.
!  · το πλήθος των μαθητών που προάγονται με βαθμό μεγαλύτερο ή ίσο του 18.
!  · για την κάθε κατηγορία το αντίστοιχο ποσοστό επί του συνόλου των μαθητών του σχολείου.
!  . το μέσο όρο της βαθμολογίας αυτών που προάγονται.
! Να γίνεται έλεγχος για το αν ο βαθμός είναι θετικός και μικρότερος ή ισος του 20.
! Να μη χρησιμοποιηθεί πίνακας.


ΠΡΟΓΡΑΜΜΑ ΕΠ_1_16
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, Ν , Ν1 , Ν2 , Ν3
  ΠΡΑΓΜΑΤΙΚΕΣ: x , s , mo
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε πλήθος των μαθητών του σχολείου.'
  ΔΙΑΒΑΣΕ Ν
  Ν1 <-- 0
  Ν2 <-- 0
  Ν3 <-- 0
  s <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'Δώσε το βαθμό του μαθητή',i
    ΔΙΑΒΑΣΕ x
    ΟΣΟ x <= 0 ή x > 20 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε.'
      ΔΙΑΒΑΣΕ x
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ x < 9.5 ΤΟΤΕ
      Ν1 <-- Ν1 + 1
    ΑΛΛΙΩΣ_ΑΝ X < 18 ΤΟΤΕ
      s <-- s + x
      Ν2 <-- Ν2 + 1
    ΑΛΛΙΩΣ
      s <-- s + x
      Ν3 <-- Ν3 + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mo <-- s /(Ν2 + Ν3)
  ΓΡΑΨΕ 'Δεν προάγονται',Ν1,'μαθητές. Ποσοστό',Ν1*100/Ν,'% επί του συνόλου των μαθητών'
  ΓΡΑΨΕ 'Με βαθμό κάτω του 18 προάγονται',Ν2,'μαθητές. Ποσοστό',Ν2*100/Ν,'% επί του συνόλου των μαθητών'
  ΓΡΑΨΕ 'Με βαθμό από 18 και πάνω προάγονται',Ν3,'μαθητές. Ποσοστό',Ν3*100/Ν,'% επί του συνόλου των μαθητών'
  ΓΡΑΨΕ 'Ο μέσος όρος της βαθμολογίας αυτών που προάγονται είναι',mo
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters