Τώρα είναι Τετ 08 Απρ 2020 08:07 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ζαριές
ΔημοσίευσηΔημοσιεύτηκε: Τετ 20 Δεκ 2006 01:01 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Τρία ζάρια ρίχνονται διαδοχικά πολλές φορές.
! Να γραφεί πρόγραμμα το οποίο :
! · να βρίσκει και να εμφανίζει πόσες και ποιες ζαριές έχουν άθροισμα μεγαλύτερο από 14.
! · να υπολογίζει και να εμφανίζει ποια η πιθανότητα να έχουμε ζαριά με άθροισμα μεγαλύτερο από 14.

ΠΡΟΓΡΑΜΜΑ Ζαριές
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,k,Ν,l
  ΠΡΑΓΜΑΤΙΚΕΣ: x
ΑΡΧΗ
  Ν <-- 0
  l <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 6
        l <-- l + 1
        ΑΝ i + j + k  > 14 ΤΟΤΕ
          Ν <-- Ν + 1
          ΓΡΑΨΕ Ν,':',i,j,k
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  x <-- Ν*100/l
  ΓΡΑΨΕ Ν,'Ζαριές με άθροισμα πάνω από 14 ή ποσοστό',x,'% επί του συνόλου.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters