Τώρα είναι Τετ 08 Απρ 2020 09:18 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Άθροισμα Κύβων Ψηφίων
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 19 Νοέμ 2005 02:34 pm 
Syntax: [ Download ] [ Hide ]
! Να γράψετε έναν αλγόριθμο ο οποίος να εμφανίζει
! όλους τους τριψήφιους ακέραιους αριθμούς
! των οποίων το άθροισμα των κύβων των ψηφίων τους
! ισούται με τον αριθμό.

ΠΡΟΓΡΑΜΜΑ  Άθροισμα_Κύβων
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , π , υ
  ΠΡΑΓΜΑΤΙΚΕΣ: Sum
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 100 ΜΕΧΡΙ 199
    Sum <-- 0
    υ <-- Ι MOD 10
    Sum <-- Sum + υ^3
    π <-- Ι DIV 10
    υ  <-- π MOD 10
    Sum <-- Sum + υ^3
    π <-- π DIV 10
    Sum <-- Sum +π^3
    ΑΝ  Ι = Sum  ΤΟΤΕ
      ΓΡΑΨΕ  Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  Άθροισμα_Κύβων
 


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters