Τώρα είναι Παρ 10 Απρ 2020 08:51 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 16 Δεκ 2004 01:16 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 15 Δεκ 2004 04:26 am
Δημοσιεύσεις: 10
Τοποθεσία: Πρέβεζα
Syntax: [ Download ] [ Hide ]
!/////////////////////////////////////////\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
! Να Γράψετε Πρόγραμμα το οποίο να εμφανίζει ενα Χριστουγεννιάτικο Δένδρο,
! οπως φαίνεται παρακάτω, σε 18 γραμμές και ή βάση του να είναι σε 3 γραμμές.
! Να χρησιμοποιηθούν μεταβλητές (παράμετροι) ώστε το πρόγραμμα
! να μην αλλάζει όταν αλλάζουν τα δεδομένα (τα 2 ύψη που δίνονται - σε γραμμές).
!
!                          *
!                         ***
!                        *****
!                       *******
!                      *********
!                     ***********
!                    *************
!                         ***
!                         ***
!\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\//////////////////////////////////////////
! ΧΡΙΣΤΟΥΓΕΝΙΑΤΙΚΟ ΔΕΝΔΡΟ
!
ΠΡΟΓΡΑΜΜΑ ΔΕΝΔΡΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Ν,Κ,ΓΡ,ΒΑΣΗ,ΠΛ,ΥΨ
ΑΡΧΗ

! Η ΕΝΤΟΛΗ ΓΡΑΨΕ_ ΔΕΝ ΑΛΛΑΖΕΙ ΓΡΑΜΜΗ
! Η ΕΝΤΟΛΗ ΓΡΑΨΕ  ΑΛΛΑΖΕΙ ΓΡΑΜΜΗ ΜΕΤΑ ΤΗΝ ΕΚΤΥΠΩΣΗ/ΕΜΑΝΙΣΗ ΚΕΙΜΕΝΟΥ

! ΔΕΝΔΡΟ ΣΕ Ν ΓΡΑΜΜΕΣ, ΟΧΙ ΠΑΝΩ ΑΠΟ 20 ΓΙΑ ΝΑ ΧΩΡΑΕΙ ΣΤΗΝ ΟΘΟΝΗ
! `ΓΡ` ΚΕΝΑ ΔΕΞΙΟΤΕΡΑ ΑΠΟ ΤΗΝ ΑΚΡΗ
! Η ΒΑΣΗ ΚΑΛΟ ΕΙΝΑΙ ΝΑ ΕΙΝΑΙ ΠΕΡΙΤΤΟΣ ΓΙΑ ΝΑ ΕΙΝΑΙ ΣΤΟ ΜΕΣΟΝ
  Ν <-- 18
  ΓΡ <-- Ν+10
  ΒΑΣΗ <-- 3
  ΥΨ <-- 4


  ΠΛ <-- ΒΑΣΗ DIV 2 + 1

  ! ΦΤΙΑΞΕ ΤΑ ΚΛΑΔΙΑ ΣΕ Ν ΓΡΑΜΜΕΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν

    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ ΓΡ-Ι
      ΓΡΑΨΕ_ ' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 2*Ι-1
      ΓΡΑΨΕ_ '*'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! φτιαξε ΤΗΝ ΒΑΣΗ ΣΕ ΥΨ ΓΡΑΜΜΕΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΥΨ

    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ ΓΡ-ΠΛ
      ΓΡΑΨΕ_ ' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ ΒΑΣΗ
      ΓΡΑΨΕ_ '*'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters