Τώρα είναι Παρ 10 Απρ 2020 09:47 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 02 Απρ 2004 08:00 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2003 12:44 pm
Δημοσιεύσεις: 4
Τοποθεσία: Drama, Greece
Κατασκευάστε αλγόριθμο που υπολογίζει άν ένας αριθμός είναι άρτιος ή περιττός χρησιμοποιώντας μόνο τους βασικούς αριθμητικούς τελεστές (+ - / * χωρίς mod & div) και χωρίς βοηθητικές συναρτήσεις (πχ. Α_Μ).

Ιδού η απάντηση :)

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Άρτιος_ή_περιττός_χωρίς_mod_κλπ

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: χ, ν, μ, βήμ
  ΛΟΓΙΚΕΣ: περιττός

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε έναν ακέραιο αριθμό: '
  ΔΙΑΒΑΣΕ Χ

  ΑΝ Χ<0 ΤΟΤΕ
    βήμ <-- 1
  ΑΛΛΙΩΣ
    βήμ <-- -1
  ΤΕΛΟΣ_ΑΝ

  περιττός <-- ΨΕΥΔΗΣ
  ΓΙΑ ν ΑΠΟ Χ ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ βήμ
    μ <-- μ - βήμ
    ΑΝ μ=ν ΤΟΤΕ
      περιττός <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ περιττός ΤΟΤΕ
    ΓΡΑΨΕ 'περιττός'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'άρτιος'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Έχω λάβει επίσης μια άλλη πολύ καλή λύση! Αναμένω την δημοσίευση....

[Διόρθωση ενός λάθους για τους αρνητικούς αριθμούς στις 6 Απρ]


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 06 Απρ 2004 07:07 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
:wink: Ιδού λοιπόν:
http://spinet.gr/glossomatheia/programs ... .php?t=142


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters