Τώρα είναι Δευτ 23 Σεπ 2019 04:37 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Πυθαγόρειες_Τριάδες
ΔημοσίευσηΔημοσιεύτηκε: Παρ 01 Ιουν 2012 06:50 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 01 Ιουν 2012 02:27 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
!Ξέρουμε ότι η περίμετρος του τριγώνου είναι ίση με το άθροισμα των πλευρών του τριγώνου
!δλδ Περ=a+b+c αν το συνδυάσω με το Πυθαγόρειο Θεώρημα
!a2=c2+d2 τότε a=Τ_Ρ c2+d2 οπότε αν είναι γνωστή η περίμετρος του τριγώνου μπορώ να βρω
!την Πυθαγόρεια τριάδα τ2ου τριγώνου π.χ 12 =Τ_Ρc2+d2 +c+d αν θέσω τιμές
!για c από 1 έως ν και για d από 1 έως ν βρίσκω τις δύο πλευρές του ορθογώνιου τριγώνου,
!τέλος από τον τύπο της περιμέτρου έχω την υποτείνουσα  12=a+3+4.


ΠΡΟΓΡΑΜΜΑ ΠυθαγόρειεςΤριάδες

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β, γ, δ, ε

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε την περίμετρο του ορθογώνιου τριγώνου'
  ΓΡΑΨΕ 'για την οποία θέλεις να βρώ την Πυθαγόρεια Τριάδα:'
  ΔΙΑΒΑΣΕ α

  ΓΙΑ β ΑΠΟ 1 ΜΕΧΡΙ 500
    ΓΙΑ γ ΑΠΟ β ΜΕΧΡΙ 500

      δ <-- (β*β)+(γ*γ)
      ε <-- α-(β+γ)

      ΑΝ Τ_Ρ(δ)+β+γ =α ΤΟΤΕ

        ΓΡΑΨΕ 'Η Πυθαγόρεια τριάδα αποτελείται από τους αριθμούς:',β,',',γ,'και',ε


      ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠυθαγόρειεςΤριάδες


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Πυθαγόρειες_Τριάδες
ΔημοσίευσηΔημοσιεύτηκε: Τετ 10 Οκτ 2012 07:54 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 10 Οκτ 2012 04:00 am
Δημοσιεύσεις: 7
athoos ,
Το πρόγραμμά σου είναι αρκετά καλό. Όμως έχει ένα βασικό μειονέκτημα : Δουλεύει ΜΟΝΟ αν του δώσεις περιμέτρους που αντιστοιχούν σε πυθαγόρειες τριάδες ακεραίων. Για παράδειγμα για περίμετρο =12 θα δώσει [3,4,5]. Όμως για περίμετρο =13 δεν θα δώσει τίποτε γιατί ΔΕΝ υπάρχει τέτοια τριάδα ακεραίων. Επομένως θέλει και μια δόση...τύχης όταν το τρέχεις :D

Παρακάτω δίνω ένα πρόγραμμα, που βρίσκει ΜΟΝΟ τις πρωτόγονες πυθαγόρειες τριάδες που έχουν υποτείνουσα μέχρι ένα (συγκεκριμένο) όριο. Βιβλιογραφία : http://eprints.utas.edu.au/144/1/triads.pdf

Οι τριάδες είναι δύο ειδών: Πρωτόγονες και Μη-Πρωτόγονες. Πρωτόγονες είναι αυτές που οι αριθμοί είναι πρώτοι μεταξύ τους. Δηλαδή δεν έχουν κανένα κοινό διαιρέτη, με άλλα λόγια: ΜΚΔ (α,β,γ,)=1

Οι υπόλοιπες είναι απλώς πολλαπλάσια των πρωτόγονων. π.χ: [3,4,5] * 2 = [6,8,10]. Άρα μας ενδιαφέρουν ΜΟΝΟ οι πρωτόγονες πυθαγόρειες τριάδες.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΠΡΩΤΟΓΟΝΕΣ_ΠΥΘΑΓΟΡΕΙΕΣ_ΤΡΙΑΔΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Α,Β,Λ,ΜΑΧ,Δ
  ΠΡΑΓΜΑΤΙΚΕΣ: Γ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Θέστε όριο υποτείνουσας (όχι μικρότερο του 5)'
    ΔΙΑΒΑΣΕ Λ
    ΑΝ Λ<5 ΤΟΤΕ
      ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
      ΓΡΑΨΕ ''
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Λ>=5
  ΓΡΑΨΕ ''
  ΜΑΧ <-- Α_Μ(Τ_Ρ(Λ-1))
  Δ <-- 0
  ΓΙΑ Α ΑΠΟ 2 ΜΕΧΡΙ ΜΑΧ
    ΓΙΑ Β ΑΠΟ Α-1 ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -2
      ΑΝ ΜΚΔ(Α,Β)=1 ΤΟΤΕ
        Γ <-- Α^2+Β^2
        ΑΝ Γ<=Λ ΤΟΤΕ
          Δ <-- Δ+1
          ΓΡΑΨΕ Α^2-Β^2,2*Α*Β,Γ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'Πλήθος:'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΜΚΔ(Α,Β): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,ΜΑΧ,ΜΙΝ,Ι
ΑΡΧΗ
  ΑΝ Α>=Β ΤΟΤΕ
    ΜΑΧ <-- Α
    ΜΙΝ <-- Β
  ΑΛΛΙΩΣ
    ΜΑΧ <-- Β
    ΜΙΝ <-- Α
  ΤΕΛΟΣ_ΑΝ
  ΜΚΔ <-- 1
  ΑΝ (ΜΑΧ MOD ΜΙΝ)=0 ΤΟΤΕ
    ΜΚΔ <-- ΜΙΝ
  ΑΛΛΙΩΣ
    ΜΙΝ <-- Α_Μ(Τ_Ρ(ΜΙΝ))
    ΓΙΑ Ι ΑΠΟ 3 ΜΕΧΡΙ ΜΙΝ ΜΕ ΒΗΜΑ 2
      ΑΝ (ΜΑΧ MOD Ι)=0 ΤΟΤΕ
        ΜΚΔ <-- Ι
        Ι <-- ΜΙΝ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

_________________
"Peace to everyone, and - who knows ? - maybe one day ... civilization !!!" - Pat Condell


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters