Τώρα είναι Δευτ 26 Αύγ 2019 07:56 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Ιούλ 2008 12:47 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ==============================================================================
! ΗΜΕΡΗΣΙΟ - ΙOYΛIΟΣ 2008 - ΘΕΜΑ 3
! ==============================================================================
! Μία εταιρεία αποφάσισε να δώσει βοηθητικό επίδομα στους υπαλλήλους της για το
! μήνα Ιούλιο. Το επίδομα διαφοροποιείται, ανάλογα με το φύλο του/της υπαλλήλου
! και τον αριθμό των παιδιών του/της, με βάση τους παρακάτω πίνακες:
!
!     *--------------------------------*---------------------------------*
!     |               ΑΝΔΡΕΣ           |             ΓΥΝΑΙΚΕΣ            |
!     *--------------------------------*---------------------------------*
!     | ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ | ΕΠΙΔΟΜΑ ΣΕ € | ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ | ΕΠΙΔΟΜΑ ΣΕ €  |
!     *-----------------*--------------*-----------------*---------------*
!     |      1          |       20     |         1       |      30       |
!     |      2          |       50     |         2       |      80       |
!     |   >= 3          |      120     |      >= 3       |     160       |
!     *-----------------*--------------*-----------------*---------------*
!
! Να γράψετε αλγόριθμο ο οποίος
!  α. διαβάζει το φύλο ("Α" ή "Γ") το οποίο ελέγχεται ως προς την ορθότητα της
!     εισαγωγής του. Επίσης διαβάζει τον μισθό και τον αριθμό των παιδιών του
!     υπαλλήλου.
!  β. υπολογίζει και εμφανίζει το επίδομα και το συνολικό ποσό που θα εισπράξει
!     ο υπάλληλος τον μήνα Ιούλιο.
!  γ. δέχεται απάντηση "ΝΑΙ" ή "ΟΧΙ" για τη συνέχεια ή τον τερματισμό της
!     επανάληψης μετά την εμφάνιση σχετικού μηνύματος.
!  δ. υπολογίζει και εμφανίζει το συνολικό ποσό επιδόματος που πρέπει να
!     καταβάλει η Εταιρεία στους υπαλλήλους της.
! ==============================================================================

ΠΡΟΓΡΑΜΜΑ  ΗΜ_2008_07_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : s , n , x
  ΠΡΑΓΜΑΤΙΚΕΣ : pay
  ΧΑΡΑΚΤΗΡΕΣ : gender , answer
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ 'Δώσε το φύλο του/της υπαλλήλου (Α ή Γ)'
    ΔΙΑΒΑΣΕ gender                                          
    ΟΣΟ gender <> 'Α' ΚΑΙ gender <> 'Γ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε.'
      ΔΙΑΒΑΣΕ gender
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ 'Δώσε το μισθό που παίρνει.'
    ΔΙΑΒΑΣΕ pay

    ΓΡΑΨΕ 'Πόσα παιδιά έχει;'
    ΔΙΑΒΑΣΕ n

    ΑΝ gender = 'Α' ΤΟΤΕ
      ΑΝ n = 1 ΤΟΤΕ
        x <-- 20
      ΑΛΛΙΩΣ_ΑΝ n = 2 ΤΟΤΕ
        x <-- 50
      ΑΛΛΙΩΣ
        x <-- 120
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ n = 1 ΤΟΤΕ
        x <-- 30
      ΑΛΛΙΩΣ_ΑΝ n = 2 ΤΟΤΕ
        x <-- 80
      ΑΛΛΙΩΣ
        x <-- 160
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Επίδομα υπαλλήλου =' , x
    ΓΡΑΨΕ 'Συνολικό ποσό προς είσπραξη =' , pay+x

    s <-- s + x

    ΓΡΑΨΕ 'Υπάρχει και άλλος ή άλλη;'
    ΓΡΑΨΕ '     (ΝΑΙ ή ΟΧΙ)'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ answer
    ΜΕΧΡΙΣ_ΟΤΟΥ answer = 'ΝΑΙ' ή answer = 'ΟΧΙ'

  ΜΕΧΡΙΣ_ΟΤΟΥ answer = 'ΟΧΙ'

  ΓΡΑΨΕ 'Συνολικό ποσό επιδομάτων =' , s

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters