Τώρα είναι Σάβ 06 Ιουν 2020 10:47 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 1γ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 25 Ιούλ 2008 10:35 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2008 - ΘΕΜΑ 1Γ
! ================================================================================================
! Το παρακάτω τμήμα αλγορίθμου να μετατραπεί σε ισοδύναμο, χρησιμοποιώντας αποκλειστικά τη δομή
! Όσο... Επανάλαβε.
!
!    Σ <-- 0
!    Μ <-- 1000
!    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!       ΔΙΑΒΑΣΕ αρ
!       Σ <-- Σ + αρ
!       M <-- M + 1
!    ΜΕΧΡΙΣ_ΟΤΟΥ (Σ < -100) ή ( Μ = 2008)
!    ΕΜΦΑΝΙΣΕ Σ , Μ
!
!================================================================================================

ΠΡΟΓΡΑΜΜΑ  PR_07_1C
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ , Μ , αρ
ΑΡΧΗ

! ΟΠΩΣ ΔΙΝΕΤΑΙ

  Σ <-- 0
  Μ <-- 1000
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ αρ
    Σ <-- Σ + αρ
    M <-- M + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ (Σ < -100) ή ( Μ = 2008)        ! ΜΟΛΙΣ ΙΣΧΥΣΟΥΝ ΟΙ ΣΥΝΘΗΚΕΣ Η ΕΠΑΝΑΛΗΠΤΙΚΗ ΔΟΜΗ
  ΓΡΑΨΕ Σ , Μ                                             ! ΠΑΥΕΙ ΝΑ ΕΚΤΕΛΕΙΤΑΙ

! ΜΕΤΑ ΤΗΝ ΜΕΤΑΤΡΟΠΗ

  Σ <-- 0
  Μ <-- 1000
  ΟΣΟ (Σ >= -100) ΚΑΙ (Μ <> 2008) ΕΠΑΝΑΛΑΒΕ   ! ΟΙ ΣΥΝΘΗΚΕΣ ΕΙΝΑΙ ΑΝΑΠΟΔΕΣ ΜΕ ΑΥΤΕΣ ΤΟΥ ΑΡΧΙΚΟΥ
    ΔΙΑΒΑΣΕ αρ                                                ! ΔΙΟΤΙ ΟΣΟ ΙΣΧΥΟΥΝ Η ΕΠΑΝΑΛΗΠΤΙΚΗ ΔΟΜΗ ΕΚΤΕΛΕΙΤΑΙ
    Σ <-- Σ + αρ
    M <-- M + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Σ , Μ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters