Τώρα είναι Παρ 05 Ιουν 2020 12:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 1δ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 25 Ιούλ 2008 10:34 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===========================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2008 - ΘΕΜΑ 1Δ
! ===========================================================================================
! Στο ακόλουθο τμήμα προγράμματος, να συμπληρώσετε το τμήμα δηλώσεων που έχει παραλειφθεί.
!
!  ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
!  …
!  ΑΡΧΗ
!    ΔΙΑΒΑΣΕ Β
!    X <-- 28
!    Κ <-- 13
!    ΟΣΟ Χ<> 0 ΕΠΑΝΑΛΑΒΕ
!       Κ <-- Κ - 2
!       ΑΝ Β = 'ΑΛΗΘΗΣ' ΤΟΤΕ
!          Υ <-- Κ MOD 2
!          L <-- K MOD Y
!       ΑΛΛΙΩΣ
!          R <-- K / 2
!          X <-- X + R
!       ΤΕΛΟΣ_ΑΝ
!       ΓΡΑΨΕ Χ , Κ
!   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
!============================================================================================

ΠΡΟΓΡΑΜΜΑ  PR_07_1D
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: K , Y , L ! Οι μεταβλητές αυτές συνδέονται με την πράξη MOD γιαυτό είναι ακέραιες.
  ΠΡΑΓΜΑΤΙΚΕΣ: X , R  ! Η τιμή του Κ είναι 13, οπότε τα R ΚΑΙ Χ παίρνουν δεκαδικές τιμές.
  ΧΑΡΑΚΤΗΡΕΣ: B       ! Η τιμή του Β συγκρίνεται με το ΑΛΗΘΗΣ σε εισαγωγικά, άρα είναι αλφαριθμητικό
ΑΡΧΗ                  ! (αν το συγκρίναμε με το ΑΛΗΘΗΣ χωρίς εισαγωγικά θα το δηλώναμε ΛΟΓΙΚΗ μεταβλητή.

  ΔΙΑΒΑΣΕ B
  X <-- 28
  K <-- 13
  ΟΣΟ X <> 0 ΕΠΑΝΑΛΑΒΕ
    K <-- K - 2
    ΑΝ B = 'ΑΛΗΘΗΣ' ΤΟΤΕ
      Y <-- K MOD 2
      L <-- K MOD Y
    ΑΛΛΙΩΣ
      R <-- K / 2
      X <-- X + R
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ X , K
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! ΠΑΡΑΤΗΡΗΣΗ : Το πρόγραμμα είναι λάθος γιατί το Χ ποτέ δε γίνεται μηδέν, οπότε η επαναληπτική δομή
!              είναι ατέρμων βρόχος (παραβιάζεται το κριτήριο της περατότητας).
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters