Τώρα είναι Παρ 10 Απρ 2020 01:28 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 24 Ιούλ 2008 07:23 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ============= ΕΣΠΕΡΙΝΟ ΙΟΥΛΙΟΣ 2007 - Θέμα 3 ========================
! Ένας καταναλωτής διαθέτει 150 € για αγορά ρυζιού, προκειμένου να το
! δωρίσει σε ένα φιλανθρωπικό ίδρυμα. Σε ένα πολυκατάστημα διατίθενται
! πακέτα ρυζιού σε τέσσερις διαφορετικές συσκευασίες από διαφορετικές
! εταιρείες.
! Να γράψετε αλγόριθμο ο οποίος:
!   α. Διαβάζει το όνομα της εταιρείας, την αξία και την ποσότητα σε
!      γραμμάρια για κάθε μία από τις τέσσερις συσκευασίες ρυζιού.
!   β. Υπολογίζει και εμφανίζει το όνομα της εταιρείας που προσφέρει
!      το ρύζι στην πλέον συμφέρουσα για τον καταναλωτή συσκευασία
!      (να θεωρήσετε ότι υπάρχει μόνο μία τέτοια εταιρεία).
!   γ. Υπολογίζει και εμφανίζει τον αριθμό των πακέτων που μπορεί να
!      αγοράσει από την πλέον συμφέρουσα για τον καταναλωτή συσκευασία
!      (σύμφωνα με το ερώτημα β).
! =====================================================================

ΠΡΟΓΡΑΜΜΑ ESP_2007_03
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i , k , n
  ΠΡΑΓΜΑΤΙΚΕΣ: β[4] , τ[4] , min
  ΧΑΡΑΚΤΗΡΕΣ: ετ[4]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ 'Δώσε το όνομα της εταιρείας Νο :' , i
    ΔΙΑΒΑΣΕ ετ[i]
    ΓΡΑΨΕ 'Δώσε το βάρος σε γραμμάρια της συσκευασίας της' , ετ[i]
    ΔΙΑΒΑΣΕ β[i]
    ΓΡΑΨΕ 'Δώσε και την τιμή της συσκευασίας.'
    ΔΙΑΒΑΣΕ τ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  min <-- τ[1] / β[1]
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 4
    ΑΝ τ[i]/β[i] <= min ΤΟΤΕ
      min <-- τ[i]/β[i]
      k <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Συμφέρει να αγοραστεί ρύζι της εταιρείας' , ετ[k]
  n <-- Α_Μ(150/τ[k])
  ΓΡΑΨΕ 'Με τα 150 EURO θα αγοραστούν' , n , 'πακέτα ρύζι.'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters